Posts: 5
Joined: Sun May 27, 2012 7:00 pm

Unable to mount root fs

Mon May 28, 2012 11:13 am

So I just recieved the pi this morning, and I try to boot and recieve the
'Kernel panic - not syncing: VFS Unable to mount root fs on unknown-block(179,2)'
It then stops there and I am unable to type...
The line of code before that: 'No filesystem could mount root, tried: ext4'

I have no idea what be the problem :S
Any suggestions? Thank you very much!

Posts: 8
Joined: Sun May 13, 2012 1:17 am

Re: Unable to mount root fs

Tue May 29, 2012 3:47 am

I had the same problem as well! Either try another SD card, or if you're more advanced, download the actual Fedora image, un-gzip it (it downloads as a *.gz), then using dd, write the resultant file to an SD card.

User avatar
Posts: 1280
Joined: Sat Feb 04, 2012 4:18 pm

Re: Unable to mount root fs

Tue May 29, 2012 8:04 am

I'd hesitate to use the Fedora image as it has 'issues'. However it does sound like your card wasn't completely imaged. As it got as far as reading the first part, the dos partition that allows it to boot up, I'd redo the image and try again.
Pico/RP2040 ≠ Arduino
Pico = hot rod kit car, Arduino = hot rod kit car wrapped in cotton wool with buoyancy aids & parachute

User avatar
Posts: 24
Joined: Sat Sep 10, 2011 4:34 pm

Re: Unable to mount root fs

Wed May 30, 2012 10:38 pm

I had the same problem with 4 SD cards.

I ended up ordering a preloaded card from ebay, and my pi now works fine.

Posts: 41
Joined: Sun Mar 18, 2012 10:13 am

Re: Unable to mount root fs

Sat Jun 09, 2012 1:45 am

I have the same problem. My Pi has just arrived and I want to get it going. Got the new Debian image. I get '-110 errors', Kernal Panics, and now 'No filesystem could mount root'. I've tried 2 different SD cards now, including a Kingston that is supposed to work. Really disappointed that I have to muck around like should just work! Have spent 5 hours on this so far, researching and formatting new cards. There's been a few swearwords. Feel like smashing the Pi with a hammer to be honest.

<deep breath>

If anyone can help (not hammer choice, but Pi help) I'd be grateful.

User avatar
Posts: 24
Joined: Sat Sep 10, 2011 4:34 pm

Re: Unable to mount root fs

Sat Jun 09, 2012 9:10 am

Can you try the other OSs? e.g. Arch.

Posts: 2
Joined: Sun Sep 04, 2011 12:44 am

Re: Unable to mount root fs

Sat Jun 23, 2012 10:42 pm

Nearly, same problem here. After flashing debian wheezy image to the sd card, it boot's and run's fine until I install some Software. Then, after reboot it throw's the "No filesystem could mount root" Error.

Does anybody know if it's a hardware(the sd card) bug or it may be solved by refactoring the images?

Posts: 7
Joined: Fri Jul 13, 2012 12:22 pm

Re: Unable to mount root fs

Mon Jul 30, 2012 5:12 am

No hardware problem. No Raspberry Pi problem. She's inocent I swear. You just need "CONFIG_LBDAF=y" in your kernel. If you have compiled it yourself, recompile it with that config set. If you haven't, well, you can start doing it or get updated kernel images.
If you haven't compiled it and you want to give it a try, you will have to do the following:
  • Get the sources and the config of the kernel you are trying to use.
  • If you aren't currently using another ARM box (which is probably the case) you will have to build your own cross toolchain.
  • Use the config and the (cross) toolchain to recompile the kernel.
If you are wondering how to do all this which seems pretty easy (?), you will find out it's not. But is it worth the effort? God yes.
Maybe the most frustrating part can be the cross toolchain. Some people avoid this problem using some kind of virtualization like qemu. My advice would be: if you really can't make the cross toolchain and you are about to kill your cat, then use the virtualization. That's because this technique uses too much resources when compiling or doing any other intensive stuff.

Return to “Troubleshooting”