Go to advanced search

by dazz100
Thu Aug 05, 2021 11:44 am
Forum: Advanced users
Topic: How to tether a Headless Raspi Pi to the Internet with a USB cable via Android phone??
Replies: 2
Views: 484

Re: How to connect a Headless Raspi Pi to the Internet with a USB cable via mobile phone??

Hi I connected my Android phone to the Raspberry Pi with a USB tether. I configured the phone. Note data saver feature needs to be turned off. When I plugged in the phone and enabled USB tether, the Raspberry, running Rasbian Lite, recognised the connection and allocated it the label usb0. Running i...
by dazz100
Sun Aug 01, 2021 10:07 am
Forum: Advanced users
Topic: How to tether a Headless Raspi Pi to the Internet with a USB cable via Android phone??
Replies: 2
Views: 484

How to tether a Headless Raspi Pi to the Internet with a USB cable via Android phone??

Hi I need to test connection to a remote headless Raspi Pi running Raspian Lite connected to my home via the internet. The remote device will initiate a reverse ssh tunnel back to my firewall using a dynamic DNS service to find the IP address. It is this tunnel that I want to test, which I can't ful...
by dazz100
Tue Oct 13, 2020 8:23 am
Forum: Troubleshooting
Topic: AP won't connect : hostapd: invalid MIC in msg , wlan0: STA IEEE 802.11: disassociated
Replies: 2
Views: 1269

Re: AP won't connect : hostapd: invalid MIC in msg , wlan0: STA IEEE 802.11: disassociated

Hi It looks like AES can be used instead of TKIP based on this article: https://www.comparitech.com/blog/information-security/wpa2-aes-tkip/ According to this article, AES is preferred unless your network includes older devices not compatible with the newer AES. I am now looking to see if that can b...
by dazz100
Tue Oct 13, 2020 8:09 am
Forum: Troubleshooting
Topic: AP won't connect : hostapd: invalid MIC in msg , wlan0: STA IEEE 802.11: disassociated
Replies: 2
Views: 1269

Re: AP won't connect : hostapd: invalid MIC in msg , wlan0: STA IEEE 802.11: disassociated

Hi Here is the contents of /etc/hostapd/hostapd.conf on a working AP. interface=wlan0 driver=nl80211 ssid=mySSID hw_mode=g channel=3 wmm_enabled=0 macaddr_acl=0 auth_algs=1 ignore_broadcast_ssid=0 wpa=2 wpa_passphrase=myPassPhrase wpa_key_mgmt=WPA-PSK wpa_pairwise=TKIP rsn_pairwise=CCMP logger_syslo...
by dazz100
Mon Oct 12, 2020 9:58 am
Forum: Troubleshooting
Topic: AP won't connect : hostapd: invalid MIC in msg , wlan0: STA IEEE 802.11: disassociated
Replies: 2
Views: 1269

AP won't connect : hostapd: invalid MIC in msg , wlan0: STA IEEE 802.11: disassociated

Hi I have a case of the dreaded hostapd: wlan0: STA 04:f1:28:54:37:af IEEE 802.11: disassociated logged error message. I turned on maximum debug messaging in the hostapd.conf file by adding logger_syslog=-1 logger_syslog_level=1 syslog revealed the following error when I tried to connect with my and...
by dazz100
Mon May 11, 2020 1:56 am
Forum: Raspberry Pi OS
Topic: Howto add a second IP address to eth0 on boot??
Replies: 9
Views: 1458

Re: Howto add a second IP address to eth0 on boot??

dickon wrote:
Sun May 10, 2020 11:21 am
You said:
dazz100 wrote:
Mon May 04, 2020 9:15 am
I want to have two persistent IP addresses active on eth0.
One address is a permanent default that cannot be edited by the user.
This is silly, and may cause a conflict with the user's network environment.
... and the alternative, not silly, solution is ... ????


Dazz
by dazz100
Sun May 10, 2020 11:19 am
Forum: Raspberry Pi OS
Topic: Howto add a second IP address to eth0 on boot??
Replies: 9
Views: 1458

Re: Howto add a second IP address to eth0 on boot??

You are making a lot of assumptions about the user's network there, which may not actually be true. Certainly, if someone brings a random 192.168.x.y-addressed machine on to my network, I get grumpy. I was demonstrating the use of a label in the command to separately identify the added interface. C...
by dazz100
Sun May 10, 2020 9:08 am
Forum: Raspberry Pi OS
Topic: Howto add a second IP address to eth0 on boot??
Replies: 9
Views: 1458

Re: Howto add a second IP address to eth0 on boot??

Hi To add to the previous answer: ip -4 address add 192.168.1.20/24 dev eth0 label eth0:1 adds a label which can be seen in the output of: ip -4 address show dev eth0 2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000 inet 172.30.21.43/24 brd 172.30...
by dazz100
Mon May 04, 2020 9:15 am
Forum: Raspberry Pi OS
Topic: Howto add a second IP address to eth0 on boot??
Replies: 9
Views: 1458

Howto add a second IP address to eth0 on boot??

Hi I want to have two persistent IP addresses active on eth0. One address is a permanent default that cannot be edited by the user. The 2nd address is user set through an application GUI. If the user forgets the user set IP address, the default address will always make the RPi accessible to them. I ...
by dazz100
Mon Oct 21, 2019 9:37 am
Forum: Troubleshooting
Topic: Updating hostapd fails…
Replies: 18
Views: 41293

Re: Updating hostapd fails…

It is still necessary and there doesn't seem to be an alternative. With a clean copy of Buster Lite, my experience says it is not. I made a typo error in the config file and the AP failed on error because it couldn't find the file name. So I know that it is used if it is there. I haven't tried remo...
by dazz100
Sat Oct 05, 2019 10:11 am
Forum: Troubleshooting
Topic: Updating hostapd fails…
Replies: 18
Views: 41293

Re: Updating hostapd fails…

The fix for me is to edit /etc/default/hostapd and set DAEMON_CONF ="/etc/hostapd/hostapd.conf" This works for me too with Buster but the documentation says DAEMON_CONF is depreciated and will no longer be supported. It is still necessary and there doesn't seem to be an alternative. Dazz
by dazz100
Thu Oct 03, 2019 8:49 am
Forum: Raspberry Pi OS
Topic: What are the side effects of multiple IP addresses on one port???
Replies: 3
Views: 471

What are the side effects of multiple IP addresses on one port???

Hi I have figured out that I can add multiple IP addresses to the eth0 port using the command: ip address add 192.168.1.69/24 dev eth0 and delete with ip address del 192.168.1.69/24 dev eth0 I have confirmed this works on Buster. I am concerned that the side effect of adding multiple IP addresses to...
by dazz100
Wed Oct 02, 2019 9:57 am
Forum: Raspberry Pi OS
Topic: Multiple STATIC IP addresses on one interface - BUSTER
Replies: 3
Views: 2624

Re: Multiple STATIC IP addresses on one interface - BUSTER

Andyroo wrote:
Sat Sep 07, 2019 9:04 pm
This works:

Code: Select all

sudo ip address add 192.168.1.12/24 dev eth0
That could go in rc.local, a system.d program or /etc/dhcpcd.exit-hook
Yes, this works for me too.

To remove an ip address:

Code: Select all

sudo ip address del 192.168.1.200/24 dev eth0
I can confirm this works also.
by dazz100
Wed Oct 02, 2019 9:37 am
Forum: Raspberry Pi OS
Topic: Raspbian Buster - Need to get 3 IP addresses on eth0 from DHCP
Replies: 8
Views: 3483

Re: Raspbian Buster - Need to get 3 IP addresses on eth0 from DHCP

Hi My reading on this is that the ip link add link code creates a vlan. That adds a tag to the packets so needs a vlan aware device to connect to. I have just got this working: sudo ip address add 192.168.1.12/24 dev eth0 As an experiment, I added 3 IP addresses to eth0. I can ping all three from an...
by dazz100
Wed Jun 26, 2019 10:21 am
Forum: Troubleshooting
Topic: Updating hostapd fails…
Replies: 18
Views: 41293

Re: Updating hostapd fails…

I have tried downgrading hostapd but that doesn't work either. Here is the screen. root@my-server:/etc/hostapd# apt-cache madison hostapd hostapd | 2:2.6-21~bpo9~rpt1 | http://archive.raspberrypi.org/debian stretch/main armhf Packages hostapd | 2:2.4-1+deb9u4 | http://raspbian.raspberrypi.org/raspbi...
by dazz100
Wed Jun 26, 2019 9:38 am
Forum: Troubleshooting
Topic: Updating hostapd fails…
Replies: 18
Views: 41293

Re: Updating hostapd fails…

Hi I have had the same problem. I have followed the instructions https://www.raspberrypi.org/documentation/configuration/wireless/access-point.md down to, but not including "Add routing and masquerade". This included update and upgrade to: Raspbian GNU/Linux 9 (stretch) Kernel: Linux 4.14....
by dazz100
Tue Jan 01, 2019 10:57 am
Forum: Networking and servers
Topic: Pi3 as wireless AP + wireless client controlled with network manager?
Replies: 2
Views: 2216

Re: Pi3 as wireless AP + wireless client controlled with network manager?

Hi I have just tried the peebles solution but failed. The syslog file is below: Jan 1 10:10:24 raspberrypi systemd-udevd[153]: Process '/sbin/iw phy phy0 interface add uap0 type__ap' failed with exit code 1. Jan 1 10:10:24 raspberrypi sh[324]: ifquery: unknown interface uap0 Jan 1 10:10:24 raspberry...
by dazz100
Fri Jul 27, 2018 9:16 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: (solved)pi 3 B+ killing the I2C shield
Replies: 21
Views: 5051

Re: (solved)pi 3 B+ killing the I2C shield

Hi I am using this XBee to Pi shield found here: https://store.ncd.io/product/i2c-shield-for-raspberry-pi-2-3-with-outward-facing-i2c-and-xbee-port/ This works perfectly on a 3B but not a 3B+ When the CE XBee HAT is used on a 3B+ the Pi will not boot. The multi-colour splash screen does not show. Th...
by dazz100
Thu Jul 12, 2018 3:05 am
Forum: Java
Topic: How to get Raspian 3rd party code into Maven repository??
Replies: 1
Views: 1943

How to get Raspian 3rd party code into Maven repository??

Hi I am involved in the development of a Java application running on Raspbian. The code is managed with Maven. There seems to be a problem with code that isn't on the Maven repository. The compiler produces the following error code: [ERROR] Failed to execute goal org.xolstice.maven.plugins:protobuf-...
by dazz100
Mon May 28, 2018 8:34 pm
Forum: Troubleshooting
Topic: cron won't run a perl program
Replies: 6
Views: 1452

Re: cron won't run a perl program

Hi It turned out to be a problem with the perl environment and @INC (but not PATH). I installed most perl modules from packages but some were only available from cpan. When I installed them from cpan as user, they were installed into my home directory. cron couldn't find them there. I then installed...
by dazz100
Thu May 24, 2018 11:17 am
Forum: Troubleshooting
Topic: cron won't run a perl program
Replies: 6
Views: 1452

Re: cron won't run a perl program

Hi
The problem is that CPAN installed a couple of modules in my home directory. All of the other modules in deb packages were installed in /usr

cron can find the /usr modules but can't find the ones in the home directory.

Dazz
by dazz100
Wed May 23, 2018 10:14 pm
Forum: Troubleshooting
Topic: cron won't run a perl program
Replies: 6
Views: 1452

Re: cron won't run a perl program

Hi I tried * * * * * /usr/bin/perl /home/user/upload_image.pl 1 2>&1 | /usr/bin/logger -t test_cron & which sent the perl compiler error messages to syslog with the tag " test_cron" for easy filtering. The error messages told me that the perl compiler couldn't find one of the modul...
by dazz100
Tue May 22, 2018 10:05 am
Forum: Troubleshooting
Topic: cron won't run a perl program
Replies: 6
Views: 1452

cron won't run a perl program

Hi I am stuck on a problem with cron. It won't run some of my perl programs. These programs have been running for years under Ubuntu and now Raspbian. Now they don't. These programs run perfectly from the CLI. The crontab looks like this: # Edit this file to introduce tasks to be run by cron. # Tell...
by dazz100
Fri Apr 20, 2018 9:57 am
Forum: Troubleshooting
Topic: Stuck in Emergency Mode Hell
Replies: 2
Views: 794

Re: Stuck in Emergency Mode Hell

Hi
I found the add init=/bin/sh command to the cmdline.txt file.
I then edited fstab and commented out the USB autoload line.

That got me out of a big fire.

Dazz

Go to advanced search