Go to advanced search

by liderbug
Sun Jul 25, 2021 5:55 pm
Forum: General discussion
Topic: STICKY: Raspberry Pi OS (64 bit) beta test version feedback
Replies: 995
Views: 264329

Re: STICKY: Raspberry Pi OS (64 bit) beta test version feedback

DL'd 2020-05-27-raspios-buster-arm64.zip, unzip, dd to a sd. Inserted in to a 3B+. Lights blink for 1 second and nada. Suggestion? Thanks
by liderbug
Fri Jul 23, 2021 2:25 pm
Forum: General discussion
Topic: Raspberry Pi as a WiFi Router
Replies: 0
Views: 119

Raspberry Pi as a WiFi Router

I'm in the process of replacing a 60 yo 15 meg DSL copper line with >fiber< @ 1000 meg - YA-HOOO. I can't use my old router as it's hard coded to CenturyLink. So OK, a Tp-Link AC1750 has the specs I need - woops couple of minor problems. The way they look at iptables is somewhat limited. If you open...
by liderbug
Sun May 30, 2021 11:15 pm
Forum: General discussion
Topic: A big thank you
Replies: 4
Views: 2123

A big thank you

Two days ago reading a forum post I came across "RP OS upgrade just released" and you should upgrade right now. So I logged on to my headless greenhouse PI and ran apt upgrade. It took a while and finished. When I rebooted I found that the file "ssh" in /boot was gone and there w...
by liderbug
Mon Apr 12, 2021 3:03 pm
Forum: Troubleshooting
Topic: DTH22 stopped working
Replies: 3
Views: 193

Re: DTH22 stopped working

And with that, 3 days latter - dead. More research on the web says that the DTH22 will sometimes hang and the solution is to power cycle. From a python code I had run across they had used another GPIO pin to power the chip and not pin 1 (3v3). Original wiring was pins 1, 7, 9. I've moved the 3v to p...
by liderbug
Tue Apr 06, 2021 6:47 pm
Forum: Troubleshooting
Topic: DTH22 stopped working
Replies: 3
Views: 193

Re: DTH22 stopped working

Swapped the RasPi MB - temp is 83 and humd is 17. So, looks like my MB gpio is fubar? Firmware? It runs fine, just won't DTH22 ...
<sigh>
by liderbug
Tue Apr 06, 2021 5:22 pm
Forum: Troubleshooting
Topic: DTH22 stopped working
Replies: 3
Views: 193

DTH22 stopped working

Raspberry Pi 3 Model B Plus Rev 1.3 Linux 5.10.17-v7+ The system is in my greenhouse using a DTH22 to monitor the temperature. For some time now life has been good. A couple of days ago my DHT22 just quit - SW returns "0". I've been using a C package to read the values. I've also tried the...
by liderbug
Mon Jan 04, 2021 4:01 pm
Forum: Troubleshooting
Topic: DHT22 stops working
Replies: 5
Views: 381

Re: DHT22 stops working

Did some testing and ether stopped working - redid cable - still not working. Turns out my USB power plug was/is going fubar. Life now mo-better'er.
by liderbug
Tue Dec 08, 2020 5:38 pm
Forum: Troubleshooting
Topic: DHT22 stops working
Replies: 5
Views: 381

Re: DHT22 stops working

I downloaded your version of DHT22.py and ...
1 18.8 11.6 0.18 0 0 0 0
2 19.1 11.6 0.18 0 0 0 0
which is right on. A question: how do I cause it to power cycle the sensor? Or does it to it automagicly?

Thanks
by liderbug
Tue Dec 08, 2020 3:50 am
Forum: Troubleshooting
Topic: DHT22 stops working
Replies: 5
Views: 381

DHT22 stops working

RasPi-B+ with a DHT11 to control my greenhouse. It's been running fine for years, but lately the DHT22 just stops giving data. System reboot doesn't fix the problem, however power off/on does. The board? SW? sensor?
thanks
by liderbug
Mon Dec 07, 2020 1:41 pm
Forum: Troubleshooting
Topic: DHT22 hanging
Replies: 1
Views: 105

DHT22 hanging

I have a Pi controling my greenhouse with a DHT22. Lately I'm unable to read the sensor. A reboot doesn't fix it, I have to power cycle the Pi. DHT22? SW? Pi?
TKS
by liderbug
Tue May 05, 2020 4:03 am
Forum: Troubleshooting
Topic: re.local runs but doesn't run programs
Replies: 1
Views: 227

re.local runs but doesn't run programs

On boot /etc/rc.local runs. I know this because the lines: date > /tmp/mylocal.tst echo "local works" >> /tmp/mylocal.tst and /tmp/mylocal.tst contains the proper data. However the line /usr/local/bin/mochad doesn't start the program. Twisty little passages all alike ... Thanks for any help
by liderbug
Mon May 04, 2020 4:01 am
Forum: Troubleshooting
Topic: RasPi data/nodata
Replies: 3
Views: 304

Re: RasPi data/nodata

I've got it working. Looks like A) mysql/mariadb is preinstalled and the LAMP directions cause FUBAR and some other corruption caused my problems.

mark solved.
by liderbug
Sat May 02, 2020 10:41 pm
Forum: Troubleshooting
Topic: RasPi data/nodata
Replies: 3
Views: 304

Re: RasPi data/nodata

<?php require_once 'phplot/phplot.php'; $conn = mysqli_connect ("localhost", "mememememe", "12345678", "lennox"); $a1 = mysqli_query ($conn, "select ts, csp1, (fm1*5)+40, hsp1, it1 from (select * from temps order by ts desc limit 1152) var1 order by ts a...
by liderbug
Sat May 02, 2020 4:21 pm
Forum: Troubleshooting
Topic: RasPi data/nodata
Replies: 3
Views: 304

RasPi data/nodata

Pre: a curl script collects information on my heating/cooling system and inserts into a mysql DB. A Phplot web script on a Fedora box runs fine. Copied to a new Raspberry Pi - when run as a web app says "DrawGraph(): No data array". But if I run from the cmd line "php furnace.php > fu...
by liderbug
Thu Apr 30, 2020 10:13 pm
Forum: Troubleshooting
Topic: Unable to load dynamic library 'mysqli
Replies: 1
Views: 548

Re: Unable to load dynamic library 'mysqli

Never mind. Config problem.
by liderbug
Thu Apr 30, 2020 3:00 pm
Forum: Troubleshooting
Topic: Unable to load dynamic library 'mysqli
Replies: 1
Views: 548

Unable to load dynamic library 'mysqli

Just loaded 2020-02-13-raspbian-buster on a 3B+ and went through the LAMP install. Then I copied over a script that uses Mysql and Phplot from another machine. It works just fine there but on the new RP I get nodata. But if I run it from the command line: php furnace.php > fur.png PHP Warning: PHP S...
by liderbug
Sun Oct 13, 2019 4:08 pm
Forum: Automation, sensing and robotics
Topic: Liquid volume sensor in a tank
Replies: 11
Views: 3635

Re: Liquid volume sensor in a tank

So, went out to the garage ... hmm, a can of Flex Seal. I cut a pair of tape circles to protect the sensors and - well not quite encased. I tried some Saranwrap - nope, no, nada and ...... nope!
by liderbug
Fri Oct 11, 2019 5:34 pm
Forum: Automation, sensing and robotics
Topic: Liquid volume sensor in a tank
Replies: 11
Views: 3635

Re: Liquid volume sensor in a tank

Hydroponic greenhouse, 4'x4'x2' deep sump. A HC-SR04 mounted over a hole in the lid. Works great. Minor problem, they don't last. Every 9 months to a year - FUBAR. The moisture seems to get to it. Corrosion. I'm looking for suggestions how to solve the problem. Incapsulate in RTV? Will the sonic wor...
by liderbug
Fri Sep 13, 2019 2:58 am
Forum: Troubleshooting
Topic: Buster updates started to fail at 22th August
Replies: 10
Views: 1329

Re: Buster updates started to fail at 22th August

OK, so what happened to 'apt-get update'? Someone decided it wasn't broke, so...
I would expect "update" to update any files/programs that have minor upgrades and changes
I would expect "upgrade" to take me from stretch to buster - major upgrades and changes, new features
by liderbug
Thu Sep 05, 2019 1:42 pm
Forum: Troubleshooting
Topic: Buster updates started to fail at 22th August
Replies: 10
Views: 1329

Re: Buster updates started to fail at 22th August

So, are there any "updates" for Buster? If I run "sudo apt-get update" it seems to run saying I'm up to date. I just ran apt list --upgradable and was told there are 5 packages to upgrade.. Are there updates (grades) to Buster? Is it broken? Or is "apt-get update" out a...
by liderbug
Tue Sep 03, 2019 11:52 am
Forum: Raspberry Pi OS
Topic: STICKY: Buster bug report thread
Replies: 434
Views: 142979

Re: Buster bug report thread

Adding the .vimrc file has fixed the "feature" :roll:
by liderbug
Sun Sep 01, 2019 3:28 pm
Forum: Raspberry Pi OS
Topic: STICKY: Buster bug report thread
Replies: 434
Views: 142979

Re: Buster bug report thread

This seems to be the thread I'm looking for:

Mouse copy/paste on Buster not working. From any other Linux box I can ssh to any of my other RasPi boards, VI a file and, using my mouse, copy and paste from anywhere to the edit file or from file to cmd line. Not on Buster.
by liderbug
Thu Aug 29, 2019 5:13 pm
Forum: Troubleshooting
Topic: Buster copy/paste via mouse
Replies: 2
Views: 1534

Re: Buster copy/paste via mouse

Ya, I just love "s'not broke, so let's fix it."

[solved] [described as a 'feature'] add a empty .vimrc file and the mouse C/P works - :roll:
by liderbug
Thu Aug 29, 2019 2:55 pm
Forum: Troubleshooting
Topic: Buster copy/paste via mouse
Replies: 2
Views: 1534

Buster copy/paste via mouse

Running Buster 4.19.66-v7+ on a 3B+ From my Linux laptop I can open a Konsole and ssh to another RasPi. Then with mouse highlight some text, open a file and middle button paste the text. But not on the system running Buster. When I try to paste I get something from a past copy. Under some conditions...
by liderbug
Wed Aug 28, 2019 1:23 am
Forum: Beginners
Topic: Motioneye
Replies: 3
Views: 3159

Re: Motioneye

Linux Drive1 4.19.66-v7+ #1253 SMP Thu Aug 15 11:49:46 BST 2019 armv7l GNU/Linux
3B+ running Buster with on board camera

I've installed Motioneye and it seems to be working OK - except Motioneye shows the camera window - blank. If I display IP:8081 I get the camera but not under :8765

Thanks

Go to advanced search