Go to advanced search

by hansotten
Tue Feb 08, 2022 8:40 am
Forum: Troubleshooting
Topic: Pi Zero 2 W is unresponsive most of the time.
Replies: 14
Views: 1057

Re: Pi Zero 2 W is unresponsive most of the time.

What do you use as power supply? I've been using a 2.4watt cell phone supply or plugged in a USB3.0 port on my computer ( so i can plug it into a monitor easily) Replace with a better power supply, cell phone supplies are not so good powering computers. The official power supply is excellent and no...
by hansotten
Sun Feb 06, 2022 12:11 pm
Forum: Troubleshooting
Topic: Pi Zero 2 W is unresponsive most of the time.
Replies: 14
Views: 1057

Re: Pi Zero 2 W is unresponsive most of the time.

What do you use as power supply?
by hansotten
Mon Dec 27, 2021 9:27 am
Forum: Advanced users
Topic: SSD - boot and Samba partition
Replies: 5
Views: 290

Re: SSD - boot and Samba partition

Use SD card copier on the Pi.

Read up on USB boot settings in raspi-config, eeprom up to date.
by hansotten
Sun Dec 26, 2021 1:07 pm
Forum: Advanced users
Topic: SSD - boot and Samba partition
Replies: 5
Views: 290

Re: SSD - boot and Samba partition

Yes, the setup is a good solution. I wanted a NAS based on SSD, silent, small. No RAID, all files are media files which are easy to restore from backup or video see-it-once. The Pihut cable you refer to is the one I use, ASmedia is fit for USB boot. Sold out alas at the moment, worth to wait for new...
by hansotten
Sun Dec 26, 2021 10:57 am
Forum: Advanced users
Topic: SSD - boot and Samba partition
Replies: 5
Views: 290

Re: SSD - boot and Samba partition

I did this as follows: - RPi4 2 GB with 2T SSD (WD), USB to SSD cable (from the Pihut, ASmedia chipset), official Raspberry PI power supply - Image Raspberry PI OS Lite (Buster) to SSD on PC, SSH enabled) - booted SSD, do the usual update and upgrade, latest eeprom utility - install Raspbery PI OS f...
by hansotten
Thu Dec 23, 2021 5:44 pm
Forum: General discussion
Topic: Pi Zero 2W stopped working after updating of OS Raspbian Lite Desktop
Replies: 5
Views: 262

Re: Pi Zero 2W stopped working after updating of OS Raspbian Lite Desktop

How did you update?

Hopefully with apt update (stable) and not rpi-update (which gets the latest, possibly unstable, development version).
by hansotten
Sat Dec 11, 2021 10:38 am
Forum: Troubleshooting
Topic: RPi3 with SSD boot fails
Replies: 5
Views: 226

Re: RPi3 with SSD boot fails

jmicron and Raspberry Pi SSD boot, not a good combination.

Did your try the 'quirks' method? viewtopic.php?t=245931

As already said, ASmedia is a better chipset for a USB to SSD controller on the Pi..
by hansotten
Tue Dec 07, 2021 6:40 pm
Forum: Troubleshooting
Topic: USB Connection Issues Arduino Uno R3 <> Raspberry Pi 3 B+
Replies: 13
Views: 616

Re: USB Connection Issues Arduino Uno R3 <> Raspberry Pi 3 B+

Looks like the mystery device might be used to connect USB to some “wires” that attach to the UART GPIO pins on the UNO R3. The OP talks about USB to connect the Pi and the UNO. The UART Bridge is on his clone, the Holten IC and seen by the OS, but not working right. So it looks like a Raspberry PI...
by hansotten
Tue Dec 07, 2021 4:02 pm
Forum: Troubleshooting
Topic: USB Connection Issues Arduino Uno R3 <> Raspberry Pi 3 B+
Replies: 13
Views: 616

Re: USB Connection Issues Arduino Uno R3 <> Raspberry Pi 3 B+

Arduino UNO clones from China come with a variety of serial UART - USB bridges.

CP2102, CH340 e.g. Most work fine.
Holten is new for me. Driver missing?
by hansotten
Thu Aug 19, 2021 9:03 am
Forum: Nederlands
Topic: Raspberry Pi booten vanaf een SSD
Replies: 1
Views: 2209

Re: Raspberry Pi booten vanaf een SSD

Raspbery Pi3 en 4 kunnen zonder HAT van USB SSD/M2 booten. Voor een M2 is een USB adapter/behuizing wel te vinden. Zo iets als https://nl.aliexpress.com/item/32915406103.html LEt wel opd at dit een werkende versie is, liefst een ASM IC gebaseerd type zoals de ASMedia ASM1153E . Dit is een goeie: htt...
by hansotten
Tue Jul 20, 2021 2:29 pm
Forum: Other
Topic: install windows on rpi with Linux
Replies: 18
Views: 2129

Re: install windows on rpi with Linux

hi all how to install wor project on ubuntu i want to install windows on rpi but i do not have a windows machine,but i have a Ubuntu 21.04 pls tell me a way to install windows on rpi with ubuntu.I also tried using gnome boxes (virtual box) but it is so slow that it took around 4 hours to get 1 perc...
by hansotten
Sat Jul 17, 2021 11:43 am
Forum: Troubleshooting
Topic: Pi 4 doesn't recognise SSD
Replies: 9
Views: 791

Re: Pi 4 doesn't recognise SSD

It is the JMicron interface probably. Try the quirks solution. Or get a cheap working USB 3 adapter , ASmedia is good as chip set (the Pihut one is fine and cheap and sold out ...). The OS you are using may not be the cause (despite the remarks above), I boot other OS'es without problems from ASMedi...
by hansotten
Fri Jul 09, 2021 8:28 am
Forum: Other
Topic: Before Anyone Asks...(Windows 11)
Replies: 53
Views: 9368

Re: Before Anyone Asks...(Windows 11)

On Windows 11 on ARM on the Pi400 X86 emulation works.

I tested some of my Lazarus programs Windows .exe files and installed Lazarus for WIn32, it runs fine with decent performance.
Quite impressive!
by hansotten
Tue Jun 08, 2021 5:55 pm
Forum: Troubleshooting
Topic: Headless pi4 in another building - duh!
Replies: 9
Views: 439

Re: Headless pi4 in another building - duh!

How did you configure networking? If it is DHCP you could at your new location still SSH to it, once you find the IP with any tool (or use <name of the pi>.local if you have Bonjour running) Of course this requires an ethernet cable. With a fixed IP (bad idea usually) you need a working keyboard ind...
by hansotten
Mon May 03, 2021 11:46 am
Forum: SDK
Topic: Always getting only four bytes instead of nine bytes on serial port of Pico
Replies: 15
Views: 1009

Re: Always getting only four bytes instead of nine bytes on serial port of Pico

So the sensor sends in HEX format 9 bytes? A hex byte is represented by two characters! It is still unclear whether 'byte' for you means received byte/character or a binary byte presented as two hex characters. Without you showing the datasheet of the sensor and seeing the received data I tend to th...
by hansotten
Fri Apr 30, 2021 12:30 pm
Forum: SDK
Topic: Always getting only four bytes instead of nine bytes on serial port of Pico
Replies: 15
Views: 1009

Re: Always getting only four bytes instead of nine bytes on serial port

You state the sensor sends 9 bytes of data. What is the specification? Binary? Ascii? CR LF terminated? Header? And you try to read 9 characters in your array, assuming it is ASCII readable. The time you read more bytes, it has a CR LF 0D 0A, so that is received also in the byte stream. Is it ASCII ...
by hansotten
Thu Apr 29, 2021 1:00 pm
Forum: Beginners
Topic: 5v, gpios and 74hc595 is this damaging my pi
Replies: 20
Views: 869

Re: 5v, gpios and 74hc595 is this damaging my pi

Soz my first wiring diagram haha. Fixed my errors https://drive.google.com/file/d/1uoLxrqhJnBS2Jk28g_VKKVBnvcgJZSwY/view?usp=drivesdk All Pi connections you use are output only so no problem if the 595 runs at 5V, the voltage level for a '1' will be high enough to drive the 595 inputs. Since the Pi...
by hansotten
Sun Apr 25, 2021 9:11 am
Forum: Beginners
Topic: My 4th headless setup failure
Replies: 21
Views: 1145

Re: My 4th headless setup failure

Final report! Reformatted an SD card from a RasPi Zero W and flashed a copy of Buster. Added my ssh file. This time I took my wpa_supplicant.conf into Notepad++ and changed the line ending format from Windows (CR LF) to Unix (LF) and added that to the SD card root. Same result: SSH enabled but no W...
by hansotten
Mon Mar 01, 2021 10:55 am
Forum: Troubleshooting
Topic: Raspberry cant boot from USB 3.0
Replies: 9
Views: 441

Re: Raspberry cant boot from USB 3.0

Natec Rhino GO Sata 2,5' Is there something wrong with this cable? According to the Website it is an enclosure not a cable :? https://natec-zone.com/product/external-hdd-enclosure-natec-rhino-go-2-5-sata-usb-3-0 Look again and see it is a USB 3.0 device. Lacking information on chipset alas.
by hansotten
Mon Mar 01, 2021 10:53 am
Forum: Troubleshooting
Topic: Raspberry cant boot from USB 3.0
Replies: 9
Views: 441

Re: Raspberry cant boot from USB 3.0

What does lsusb tell you about the chipset of the USB adapter? Google for this chipset and USB boot problems on a Pi.

Many Jmicrons are known to cause problems. Using Quirks (google it or check the pinned forum topics here!) may help.
by hansotten
Mon Mar 01, 2021 10:49 am
Forum: Beginners
Topic: Can Raspberry Pi Zero W be powered by a USB 2.0?
Replies: 3
Views: 322

Re: Can Raspberry Pi Zero W be powered by a USB 2.0?

In theory an USB 2.0 port would be able to supply 0,5A . In practice, it depends. 0.5A will be enough for a low load on the Pi (avoid GUI, use lite OS). Get a Digital USB Mobile Power Charging Current Voltage Tester Meter thingie from AliExpress for a couple of dollars. Also get USB Load Resistance ...
by hansotten
Fri Feb 26, 2021 8:26 am
Forum: Advanced users
Topic: Install OS on USB-MSD from a Pi
Replies: 5
Views: 517

Re: Install OS on USB-MSD from a Pi

I'd like to get the best performance I can by using a M.2 NVMe SSD formatted in ext4. Thanks The drive being ext4 is not important, the imager program will overwrite any formatting on the drive present, with a small boot FAT partition on front. The original formatting will be lost and you get what ...
by hansotten
Fri Feb 26, 2021 8:15 am
Forum: Raspberry Pi 400
Topic: Raspberry Pi 400 died suddenly
Replies: 10
Views: 1143

Re: Raspberry Pi 400 died suddenly

"Another thing I noticed is I connected it to a mobile charger which was rated 2A instead of a similarly looking 3A I have." That adapter is not fit for a Raspberry Pi 4 at all, it is a charger, not a power supply. Most probably it did not react very well to the increased power request for...
by hansotten
Thu Feb 25, 2021 3:49 pm
Forum: General discussion
Topic: Pi 400 still only accepting max 16GB SD cards for Pi OS [false claim!]
Replies: 28
Views: 1650

Re: Pi 400 still only accepting max 16GB SD cards for Pi OS

Not true.

How did you image the SD card? Brand of SD card?

Go to advanced search