Go to advanced search

by QBall1977
Mon Nov 22, 2021 6:57 pm
Forum: Advanced users
Topic: Blender 2.79b on Bullseye.
Replies: 7
Views: 422

Re: Blender 2.79b on Bullseye.

Hi everyone, Barely six months experience with Pi and brand new here on this forum. Thanks QBall for your info. Since it was my first time installing software by packages, I took copious notes. I needed more packages than you, perhaps you already had those. This list worked for me and I hope I wrot...
by QBall1977
Mon Nov 22, 2021 6:54 pm
Forum: Advanced users
Topic: Blender 2.79b on Bullseye.
Replies: 7
Views: 422

Re: Blender 2.79b on Bullseye.

is this not a good case for a container solution like docker or maybe flatpack to isolate the buster stuff from the bullseye stuff. i would be scared about making my bullseye environment unstable with installing buster packages. You are right this would be a perfect case. Anyone got any tips on mak...
by QBall1977
Sun Nov 14, 2021 12:22 am
Forum: Raspberry Pi OS
Topic: STICKY: Bullseye - Comments and bug reports thread.
Replies: 491
Views: 27742

Re: Bullseye - Comments and bug reports thread.

Try LIBGL_ALWAYS_SOFTWARE=1 blender No idea if it is usable, but it does start up. Thanks; that gets it running; but it is laggy as hell! The 2.79 version on Buster ran with no lag at all... I will keep testing it, but I don't think that this version is usable from my initial tests... I certainly w...
by QBall1977
Sun Nov 14, 2021 12:19 am
Forum: Advanced users
Topic: Blender 2.79b on Bullseye.
Replies: 7
Views: 422

Blender 2.79b on Bullseye.

Dear All, After an evening of searching how to get back Blender 2.79b on Bullseye after the update I finally stumbled on a (long winded) solution. This is not for the feint of heart, but I can confirm it does work (at least for me!) We're going to go digging in some debian archives. The hardest part...
by QBall1977
Sat Nov 13, 2021 10:19 pm
Forum: Raspberry Pi OS
Topic: STICKY: Bullseye - Comments and bug reports thread.
Replies: 491
Views: 27742

Re: Bullseye - Comments and bug reports thread.

Hi, have just installed Bullseye on a PI4 4Gb on an SSD and have started to test out software which we use on our school Raspberry Pis to check if we are good to upgrade to Bullseye. First off; blender is no longer working... It installs fine but when running from the CLI you get the following erro...
by QBall1977
Wed Mar 17, 2021 3:09 pm
Forum: General discussion
Topic: Downgrade required to upgrade?
Replies: 9
Views: 1066

Re: Downgrade required to upgrade?

I suspect it was something similar for me. I had to mess around a bit to get Docker working to.

I do have Minecraft (Java) installed also.

Always worth checking this file every once in a while.
by QBall1977
Wed Mar 17, 2021 6:23 am
Forum: General discussion
Topic: Downgrade required to upgrade?
Replies: 9
Views: 1066

Re: Downgrade required to upgrade?

A quick # before this line will comment it out. I did this, ran

Code: Select all

sudo apt-get update && sudo apt-get upgrade -y 
and boom no more errors. I'm not sure what I'm missing without this repository. But as far as I can tell all other software is now updated.
by QBall1977
Tue Mar 16, 2021 11:50 pm
Forum: General discussion
Topic: Downgrade required to upgrade?
Replies: 9
Views: 1066

Re: Downgrade required to upgrade?

I think the culprit for me seemed to be this line in

Code: Select all

sudo nano /etc/apt/sources.list
This line that I commented out

Code: Select all

deb http://deb.debian.org/debian buster-backports main
by QBall1977
Tue Mar 16, 2021 11:45 pm
Forum: General discussion
Topic: Downgrade required to upgrade?
Replies: 9
Views: 1066

Re: Downgrade required to upgrade?

I have exactly the same issue The following packages will be DOWNGRADED: cmake-data 0 upgraded, 0 newly installed, 1 downgraded, 0 to remove and 0 not upgraded. Need to get 0 B/1,628 kB of archives. After this operation, 0 B of additional disk space will be used. Do you want to continue? [Y/n] But w...
by QBall1977
Fri Feb 26, 2021 10:28 am
Forum: Gaming
Topic: How to setup any version of Minecraft on Pi4
Replies: 210
Views: 47521

Re: How to setup any version of Minecraft on Pi4

Okay, So I have just stumbled across Sodium. This has really improved performance for me. Around 10+ fps over optifine and seems more stable. Install Java 11 sudo apt-get install openjdk-11-jdk sudo apt install default-jdk Run to check which version of Java is default. sudo update-alternatives --con...
by QBall1977
Wed Feb 24, 2021 7:34 pm
Forum: Gaming
Topic: How to setup any version of Minecraft on Pi4
Replies: 210
Views: 47521

Re: How to setup any version of Minecraft on Pi4

I think maybe it's working already working, but it just doesn't list it as a mod. I'm assuming as I have the option for shaders (I'd only recommend using the OpenGL pi one listed) Going to try out a couple of texture packs! and turn lots of settings down or to FAST! Best of luck everyone with this. ...
by QBall1977
Wed Feb 24, 2021 5:27 pm
Forum: Gaming
Topic: How to setup any version of Minecraft on Pi4
Replies: 210
Views: 47521

Re: How to setup any version of Minecraft on Pi4

I have now!!!
by QBall1977
Wed Feb 24, 2021 4:13 pm
Forum: Gaming
Topic: How to setup any version of Minecraft on Pi4
Replies: 210
Views: 47521

Re: How to setup any version of Minecraft on Pi4

I know this thread hasn't had any comments for a couple of weeks but still. I've only just stumbled across this after not having any success with the Pi-Apps installer version (I think it errors). I spent the last few weeks setting up a PaperMC minecraft server on a Pi4 with 8GB of RAM, I have insta...
by QBall1977
Sat Feb 13, 2021 1:08 am
Forum: Gaming
Topic: Guide: Mapping controller to Moonlight-Qt Rasberry pi linux
Replies: 2
Views: 1623

Re: Guide: Mapping controller to Moonlight-Qt Rasberry pi linux

Thank so you so much. I have a controller connected and Moonlight-qt definitely detects it. Sadly the Pc at the other end shows no controllers.

Any suggestion?

I feel I’m really close and your post really helped. Thank you so much.
by QBall1977
Mon Jan 18, 2021 9:23 pm
Forum: Graphics, sound and multimedia
Topic: Building Krita from source on the pi4
Replies: 5
Views: 2490

Re: Building Krita from source on the pi4

For anyone still following this thread here is how I got it working on the Pi. I basically followed the instructions above, but had to comment out the section in /krita/CMakeLisrs.txt about 'mypaint;' I commented out all this... #find_package(LibMyPaint) #set_package_properties(LibMyPaint PROPERTIES...
by QBall1977
Mon Jan 18, 2021 12:22 am
Forum: Graphics, sound and multimedia
Topic: Building Krita from source on the pi4
Replies: 5
Views: 2490

Re: Building Krita from source on the pi4

Follow the instructions above as closely as possible. Learned some stuff along the way (how to search for line numbers in Nano!) I edited the recommended lines and have installed all the requirements I could find. I can get it to build to 98% soooo close, but nope. I don't think it likes libMyPaint,...
by QBall1977
Fri Jan 15, 2021 9:22 pm
Forum: Raspberry Pi OS
Topic: Blender 2.8
Replies: 6
Views: 1458

Re: Blender 2.8

Any ideas where I could get 2.82 for Raspberry Pi Bullseye to test?

I'm not quite confident enough to build it myself (yet) but I'd give it a go.

Thanks
by QBall1977
Fri Jan 15, 2021 9:20 pm
Forum: General discussion
Topic: Apt-Get Blender 2.8
Replies: 12
Views: 9027

Re: Apt-Get Blender 2.8

I use blender for simple modelling and would love to have it working under Raspberry Pi OS. I know version 2.8 can run on other 64 bit distros on the Pi. You can override the OpenGL 3.3 requirements, but how can you install it? The version in the Ubuntu repo is 2.8. But I don't want to move over to ...
by QBall1977
Wed Dec 30, 2020 3:50 pm
Forum: Troubleshooting
Topic: Multimedia Volume keys - PulseAudio
Replies: 0
Views: 145

Multimedia Volume keys - PulseAudio

Dear All, I'm posting this here in the hope that someone else finds this useful. Although the Pi400 sounds amazing I bought one of the RPi Keyboards (not Pi400) and the 'A' key stopped working within 4 months. Now I am using a mechanical keyboard with my Pi400. This keyboard has multimedia keys. I h...
by QBall1977
Mon Oct 26, 2020 1:03 am
Forum: Gaming
Topic: Quake and Quake III, but not Quake II?
Replies: 48
Views: 28530

Re: Quake and Quake III, but not Quake II?

Thought this was the final missing piece of the puzzle. Followed the steps. I really appreciate you taking the time, but when I run quake2 it seems to try to load and then comes back with a segmentation fault. The version yQuake2 not using Vulkan runs fine. I made sure to set the path to export VK_I...
by QBall1977
Wed Nov 20, 2019 11:33 pm
Forum: Troubleshooting
Topic: Reappearing Files following rm -rf command.
Replies: 0
Views: 431

Reappearing Files following rm -rf command.

Apologies if this is the wrong thread / forum page but I wondered if I could pick your brains. I'm running several Raspberry Pis around the house (infact using one to type this!). But currently I have a problem with a Pi3 running Raspbian Lite (Stretch) as a Samba server. During my en devours I mana...
by QBall1977
Mon Sep 23, 2019 2:02 am
Forum: Troubleshooting
Topic: apt-get update/upgrade literally broke post Buster install
Replies: 23
Views: 7657

Re: apt-get update/upgrade literally broke post Buster install

I experienced a similar issue. I think it was either after install Teamviewer, or NoMachine. I think I install NoMachine using a .deb file. This may have been the issue. But as suggested above navigated around till I found the arch file (/var/lib/dpkg/) , this did contain i386, removed this (using N...
by QBall1977
Sun Aug 18, 2019 1:01 pm
Forum: Troubleshooting
Topic: [Solved] Cura on Raspberry Pi 4
Replies: 12
Views: 21136

Re: Cura on Raspberry Pi 4 (Buster)

For all your information, I found this thread and can confirm you can get a version (Experimental) running for an AppImage found here. https://community.ultimaker.com/topic/28746-experimental-cura-build-for-raspberry-pi-4-now-available/ I'd not come across AppImage's. Just make excutable using chmod...
by QBall1977
Wed Feb 06, 2019 9:36 pm
Forum: Media centres
Topic: [Guide][Testing] Kodi 18.0 Leia beta versions for Raspbian Stretch! [obsolete and locked]
Replies: 109
Views: 79245

Re: [Guide][Testing] Kodi 18.0 Leia beta versions for Raspbian Stretch!

:D Thank you so much. Just got to the end of this. My Raspberry Pi desktop just keeps getting better and better. It really is an awesome beast. Also many thanks for all those who post here regularly and keep the information flowing, you are doing an amazing job and your efforts are greatly appreciat...
by QBall1977
Sat Oct 13, 2018 12:46 am
Forum: General discussion
Topic: Smtube for quick efficient Youtube browsing
Replies: 3
Views: 4303

Re: Smtube for quick efficient Youtube browsing

Dear all, Don’t suppose anyone knows where to get a modern build of this for the Pi3 B? I have tried compiling from source, but I can’t seem to get QT5 working with it. I just get build errors about scripts Project ERROR: Unknown module(s) in QT: script I’ve installed sudo apt-get install libqt5scri...

Go to advanced search