Go to advanced search

by AussieSusan
Mon Nov 22, 2021 4:45 am
Forum: General
Topic: Optimising PIO code and the use of shift registers
Replies: 5
Views: 253

Re: Optimising PIO code and the use of shift registers

@kilgraham - I must admit that this is the first time I've heard of interpolators - I guess I read the parts of the data sheet that I'm familiar with and skipped over the 'hard bits'!.
This has taught me a lesson. I'll go and read up on them now.
Susan
by AussieSusan
Wed Nov 17, 2021 2:15 am
Forum: General
Topic: Optimising PIO code and the use of shift registers
Replies: 5
Views: 253

Re: Optimising PIO code and the use of shift registers

Thanks @horuable - I'll give that a try. This is probably where I've getting confused: the 'rp2040-datasheet.pdf' documentation for the 'OUT' instruction says (section 3.4.5.2): Shift Bit count bits out of the Output Shift Register (OSR), and write those bits to Destination. Additionally, increase t...
by AussieSusan
Tue Nov 16, 2021 10:40 pm
Forum: General
Topic: Optimising PIO code and the use of shift registers
Replies: 5
Views: 253

Optimising PIO code and the use of shift registers

What I'm trying to do is to relieve the ARM processor(s) of the task of converting RGB888 to RGB565 which could be needed for every pixel of a 480 x 320 display and (hopefully)n several frames a second. (I'm trying to optimise how the display is updated as well, but this is more of a learning exerci...
by AussieSusan
Tue Nov 16, 2021 9:58 pm
Forum: General
Topic: How to handle multiple independent PIO code developments
Replies: 4
Views: 253

Re: How to handle multiple independent PIO code developments

I can see how to use the 'pio_claim_unused_sm()' function which requires one of the 'pio0' or 'pio1' constants - I guess it is easy enough to try with (say) 'pio0' first and, if you can't get a free state machine, then try again with 'pio1'.
Susan
by AussieSusan
Mon Nov 15, 2021 9:08 pm
Forum: General
Topic: How to handle multiple independent PIO code developments
Replies: 4
Views: 253

Re: How to handle multiple independent PIO code developments

Thank you all.

This has added to my understanding of the SDK.

Susan
by AussieSusan
Mon Nov 15, 2021 2:26 am
Forum: General
Topic: How to handle multiple independent PIO code developments
Replies: 4
Views: 253

How to handle multiple independent PIO code developments

This is a bit theoretical at this stage as I'm learning about the Pico and the PIO aspects in particular while working on an overall design for what I want to do. My idea is to use the Pico to drive a touch screen with a driver for the display and another for the touch aspect. The display part will ...
by AussieSusan
Mon Aug 16, 2021 2:08 am
Forum: Camera board
Topic: Video display (Rpi3B+) painfully slow
Replies: 0
Views: 193

Video display (Rpi3B+) painfully slow

I have written a web server using a RPi ZeroW that has an IR camera attached and running the Python code from the PiCamera Advanced Recipies 4.10 (Web Streaming) (V1.13) and it seems to be working well. Using my iMac or iPad I can view the image via WiFi perfectly. However when I use a RPI3B+ the im...
by AussieSusan
Fri Aug 06, 2021 4:23 am
Forum: Official Display
Topic: Touchscreen only works at extreme left edge
Replies: 1
Views: 910

Re: Touchscreen only works at extreme left edge

New RPi 3B+ and new screen works correctly.
Susan
by AussieSusan
Fri Jul 30, 2021 1:30 am
Forum: Official Display
Topic: Touchscreen only works at extreme left edge
Replies: 1
Views: 910

Touchscreen only works at extreme left edge

I have an official touch screen that I have been using some time ago that is attached to RPi2B. A few days ago I came up with a project that required a touch screen and so I created a new SD card with the latest Raspbian desktop OS on it. The touch part is no longer woking except along the extreme l...
by AussieSusan
Tue Feb 09, 2021 11:57 pm
Forum: Device Tree
Topic: UART works on RPi Zero W but not RPi 3A+
Replies: 5
Views: 1184

Re: UART works on RPi Zero W but not RPi 3A+

Thank you everyone for your comments. The solution turns out to be something different entirely (although hinted at in my original post!) As I said, I'm driving some Dynamixel servos that need to have the Rx and Tx transformed to half-duplex by an intermediary bit of hardware. To tell that hardware ...
by AussieSusan
Tue Feb 09, 2021 8:53 am
Forum: Device Tree
Topic: UART works on RPi Zero W but not RPi 3A+
Replies: 5
Views: 1184

Re: UART works on RPi Zero W but not RPi 3A+

Yes it is the same SD card moved from the Pi Zero W to the RPi 3A+.
Forgot to mention that I have disabled hciuart (again the same for both devices as I went back to the Zero after doing this on the RPI3).
Susan
by AussieSusan
Tue Feb 09, 2021 3:26 am
Forum: Device Tree
Topic: UART works on RPi Zero W but not RPi 3A+
Replies: 5
Views: 1184

UART works on RPi Zero W but not RPi 3A+

I need to swap from an RPi Zero W to an RPi 3A+ (because I now need something with multiple cores and I have a RPI 3A+ available). My application drives some Dynamixel servos through a suitable interface board and uses the TxD and RxD on GPIO ins 14 and 15 (plus some others that are not relevant her...
by AussieSusan
Mon Dec 16, 2019 1:55 am
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5334
Views: 1825234

Re: RPi Cam Web Interface

Thanks @ras07.
I'l give that a shot shortly (last week before my 2-week Christmas break - I just hope I have the time to get back to this then).
Susan
by AussieSusan
Mon Dec 09, 2019 1:52 am
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5334
Views: 1825234

Re: RPi Cam Web Interface

(There are so many entries in this thread! Almost needs a Wiki or something of its own. Searched but could not find the answer - sorry if it is buried somewhere.) I want to run my RPi Zero W with a read-only SD card (or as near as I can to that - I have another where the logs are written to memory d...
by AussieSusan
Wed Nov 20, 2019 10:04 pm
Forum: Troubleshooting
Topic: fstab not mounting drive on boot
Replies: 9
Views: 4639

Re: fstab not mounting drive on boot

What is the actual error message that fstab is generating when it is trying to mount the drive? (It will be in the log - try 'sudo journalctl -b' and page through the screens until you see the attempt to do the mount; there should be messages either telling you what the error is or where to look to ...
by AussieSusan
Wed Nov 20, 2019 9:54 pm
Forum: Troubleshooting
Topic: RPi Zero W - strange echo on UART Rx pin
Replies: 5
Views: 651

Re: RPi Zero W - strange echo on UART Rx pin

TL;DR: Looks like a faulty channel on the logic analyser part of my oscilloscope! I think I have this sorted out (eventually). Thanks for those who have contributed ideas. I took the idea of a fresh install a bit further. Basically I was already using a fresh install of Buster but I had been playing...
by AussieSusan
Tue Nov 19, 2019 9:26 pm
Forum: Troubleshooting
Topic: RPi Zero W - strange echo on UART Rx pin
Replies: 5
Views: 651

Re: RPi Zero W - strange echo on UART Rx pin

A short was the first thing I checked. Also, after I wrote that message, I managed to trigger off the first character sent by my code (as I said, I used a loop and before started the program and then triggered the scope; this time I did the opposite). In that case the Tx pin was idling high (as expe...
by AussieSusan
Tue Nov 19, 2019 10:09 am
Forum: Troubleshooting
Topic: RPi Zero W - strange echo on UART Rx pin
Replies: 5
Views: 651

RPi Zero W - strange echo on UART Rx pin

I have Raspbian Buster installed (all updated), hciuart disabled, no reference to any console or UART in the cmdline.txt line and dtoverlay=pi3-disable-bt in the config.txt file. Using Python 3 and PiSerial, I set up /dev/serial0 (or /dev/ttyAMA0 - same issue) and write a character to the Tx pin (de...
by AussieSusan
Wed Feb 07, 2018 5:22 am
Forum: Networking and servers
Topic: Impact of disabling the dhcpcd service
Replies: 5
Views: 1356

Impact of disabling the dhcpcd service

I have a RPi2 running the latest Raspian image. It is connected to the network through the ETH0: port and it obtains its IP address from my network's DHCP server. (For various reasons the DHCP server provides it with the same IPV4 address every time, but as far as I am aware, the RPi still asks for ...
by AussieSusan
Mon Jul 17, 2017 2:56 am
Forum: Beginners
Topic: Python Programming, invalid Syntax
Replies: 16
Views: 5315

Re: Python Programming, invalid Syntax

If you are running IDLE, then the cursor will be placed in your source file at the point where the error was found. It should also have a highlight at the spot.
That should help you at least locate where the compiler is having problems.
Susan
by AussieSusan
Wed Jun 07, 2017 6:44 am
Forum: General discussion
Topic: What is my correct locale?
Replies: 9
Views: 4605

Re: What is my correct locale?

I suspect that there is a bit of confusion in some of these answers. The OP was asking about "Locale". The 'Timezone' aspect might be wrong but that is NOT the thrust of the question (as I read it anyway). I must admit that setting the locale using either method can be rather difficult and...
by AussieSusan
Mon Dec 19, 2016 4:56 am
Forum: Beginners
Topic: Opening .exe in Raspbian on raspberry pi 2
Replies: 5
Views: 11789

Re: Opening .exe in Raspbian on raspberry pi 2

If the 'install.exe' program is actually for a Windows (rather than DOS) level program, then it will probably be looking for things such as the registry and windows-specific directories. While the install program might, I doubt if it will do what it is supposed to do and leave you with a runnable pi...
by AussieSusan
Fri Dec 09, 2016 2:16 am
Forum: Advanced users
Topic: systemd not stopping weewx daemon
Replies: 1
Views: 817

systemd not stopping weewx daemon

I have installed the latest weewx on a RPI with a fresh copy of the latest (November 2016) Rasbpian. Weewx comes with the old SysV script in /etc/init.d. The only change I've made to that script file is to add in a dependency on $network. Systemd seems to start weewx on boot very well. Also "sy...
by AussieSusan
Wed Nov 16, 2016 2:04 am
Forum: Automation, sensing and robotics
Topic: Ideas wanted for total cloud coverage device
Replies: 3
Views: 1605

Ideas wanted for total cloud coverage device

I want to augment my private weather station with a sensor to determine the total cloud cover at any point in time (generally measured in 'oktas' or 8ths of the sky covered with cloud) day or night. I have played with the NoIR Pi Camera but there are several things that concern me with this approach...
by AussieSusan
Mon Oct 24, 2016 3:02 am
Forum: Beginners
Topic: Can'r Enable VNC
Replies: 13
Views: 7590

Re: Can'r Enable VNC

Not quite related but several times I've tried to enable VNC from the config GUI and it has worked until the next boot.
The only way I've managed to get the VNC option to stick is to use the 'raspi-config' command form a terminal.
(Latest Raspbian PIXEL release as of today)
Susan

Go to advanced search