Go to advanced search

by shinnosuke
Sun Jul 10, 2022 10:40 pm
Forum: Networking and servers
Topic: 4G LTE signal analyzer
Replies: 0
Views: 128

4G LTE signal analyzer

... called Network Cell Info https://www.m2catalyst.com/features . I currently have a raspberry 4 and a SIXFAB 4G hat and and another hat of Waveshare SIM7600 (with which I have had some problems when trying to connect it) I wanted to know if anyone knows of a similar project or tools that I can use ...
by srf461
Tue Jul 05, 2022 11:29 am
Forum: Networking and servers
Topic: SIM7600 Query Network Connection Status
Replies: 3
Views: 228

Re: SIM7600 Query Network Connection Status

Oh, and thank you for the link. I hadn't seen it before. I'll check it and report back if I find anything that works.
by srf461
Tue Jul 05, 2022 11:27 am
Forum: Networking and servers
Topic: SIM7600 Query Network Connection Status
Replies: 3
Views: 228

Re: SIM7600 Query Network Connection Status

I checked COPS and CGACT, but the first is related to PDP and the other is related to registration.
I can't believe that I'm the first to run across this--I guess I'll just keep hitting it with ATs and just wait for it to reply--seems like a pretty brute force way to do it though... ;)
by MiscBits
Tue Jul 05, 2022 9:51 am
Forum: Networking and servers
Topic: SIM7600 Query Network Connection Status
Replies: 3
Views: 228

Re: SIM7600 Query Network Connection Status

Wonder if AT+COPS? would help? It's supposed to return the network operator but I'm unsure if it changes on connection status changes or not...

Possibly AT+CGACT? works - I've no hardware at the mo (house rewire) to check...

It may be worth checking here for some AT commands.
by srf461
Tue Jul 05, 2022 3:36 am
Forum: Networking and servers
Topic: SIM7600 Query Network Connection Status
Replies: 3
Views: 228

SIM7600 Query Network Connection Status

I have a SIM7600 module and am trying to figure out how to query the chip to get its 3g/4g, or "no g" status. Yes, there's an LED that flashes when the module is connected, but that's no help to my firmware. Does anyone ...
by testpost
Wed Jun 01, 2022 2:11 am
Forum: Networking and servers
Topic: 4G Hat
Replies: 149
Views: 171872

Re: 4G Hat

Turambar25 wrote:
Wed May 25, 2022 1:35 am
testpost wrote:
Wed Feb 23, 2022 3:21 am
testpost wrote:
Mon Jan 31, 2022 6:35 pm


Bump. Anyone?
Back to Rampart. Anyone?
I'm having trouble with Verizon verifying for the post just before this one, but I'll check after.
Do you have a SIM7600, and did you try CGPS=1,3 yet?
by Turambar25
Wed May 25, 2022 12:50 am
Forum: Networking and servers
Topic: 4G Hat
Replies: 149
Views: 171872

Re: 4G Hat

Thanks for all the help here! A quick summary of what worked in my adventure, so far: Pi-4B w/ 4GB 7 in HDMI Touchscreen SIM7600A-H attached on GPIO w/ USB connected Google fi SIM Ran the bcm2835 install (gave up on GPIO communication...for now) Installed-- minicom, NetworkManager, ...
by jonyskids
Sun Feb 20, 2022 2:54 am
Forum: Networking and servers
Topic: 4G Hat
Replies: 149
Views: 171872

Re: 4G Hat

... Inc. Hub Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub No matter what configuration I try it seems my dietpi does not see the Sim7600? (I am running bullseye, V8.1on Pi4 Model B) Could you give me any ideas?
by testpost
Wed Dec 15, 2021 1:43 am
Forum: Other projects
Topic: Assisted GPS (AGPS) on SIM7600 module - still an issue
Replies: 2
Views: 1751

Re: Assisted GPS (AGPS) on SIM7600 module - still an issue

I wouldn't consider this fully resolved yet, but it does look like that the "UE-based" mode (option 2) works, while UE-assisted mode (option 3) does not work. Both rely on the CGPSURL of supl.google.com:7276, the SUPL server. I can confirm that this does indeed still work. 7276 is the non-...
by testpost
Mon Dec 13, 2021 4:51 pm
Forum: Other projects
Topic: Assisted GPS (AGPS) on SIM7600 module - still an issue
Replies: 2
Views: 1751

Assisted GPS (AGPS) on SIM7600 module - still an issue

Hi All, I am at a bit of a loss here, as the only place I have seen this discussed has been here: https://forums.raspberrypi.com/viewtopic.php?t=250657. Unfortunately, the solution in this thread did not work for me. The short of it is that I recently got a SIM7600G breakout board, it works with con...
by moelha
Sun Nov 14, 2021 2:17 am
Forum: Troubleshooting
Topic: Disable UART during boot
Replies: 3
Views: 315

Disable UART during boot

Good evening, I have a Raspberry Pi 4 running Ubuntu Server. I figured out that my SIM7600 HAT messes with the booting sequence of Ubuntu, as it will be transmitting data to UART during boot, and this, apparently, doesn't let Ubuntu boot properly. I absolutely need ...
by moelha
Sun Nov 14, 2021 2:03 am
Forum: HATs and other add-ons
Topic: Raspberry Pi not rebooting with SIM7600 HAT
Replies: 1
Views: 200

Re: Raspberry Pi not rebooting with SIM7600 HAT

... isolated the reason, however, not the solution. It turns out that when I run Raspberry Pi OS, the reboot command works just fine even with the SIM7600 HAT on the Pi. However, the issue is that I'm running ubuntu-20.04 server-arm64+raspi. When I run ubuntu the reboot command does not work if ...
by moelha
Sat Nov 13, 2021 12:36 pm
Forum: HATs and other add-ons
Topic: Dirty serial output
Replies: 1
Views: 173

Dirty serial output

Hi all, I am using a SIM7600G-H HAT to get GPS and GSM signal. I am reading the HAT on the /dev/ttyS0 port with the following command: sudo minicom -D /dev/ttyS0 Sometimes the output on the serial will look normal like so: Capture2.JPG ...
by moelha
Sat Nov 13, 2021 12:19 pm
Forum: HATs and other add-ons
Topic: Raspberry Pi not rebooting with SIM7600 HAT
Replies: 1
Views: 200

Raspberry Pi not rebooting with SIM7600 HAT

Hi all, I am using a SIM7600G-H HAT on top of my Raspberry Pi 4 to get GPS and GSM signal. Whenever the SIM7600 HAT is installed, if I issue a sudo reboot command, the Raspberry Pi will turn off, but it will not turn on again, it just ...
by Sra1
Tue Oct 26, 2021 4:48 am
Forum: HATs and other add-ons
Topic: Suggest 4G HAT for Raspberry PI 3
Replies: 3
Views: 749

Re: Suggest 4G HAT for Raspberry PI 3

Hi Siva,

Yes, it supports GNSS,

You can power up the board by connecting the Raspberry pi USB port to the Micro USB connector of the SIM7600 4G HAT Board.

Please check out the below link for further details.

https://parrytech.net/estore/

Thanks.
Sravan
by hardliner_ap
Fri Sep 24, 2021 10:59 am
Forum: Networking and servers
Topic: 4G Hat
Replies: 149
Views: 171872

Re: 4G Hat

Hi, is anyone else having trouble connecting to the SIM7600 using LTE? I run a RPIcam webinterface with nginx on my raspberry zero, using the SIM7600G module and a static IP on the SIM card. Everything works well, except for accessing the server from ...
by hardliner_ap
Mon Sep 20, 2021 2:12 pm
Forum: Networking and servers
Topic: 4G Hat
Replies: 149
Views: 171872

Re: 4G Hat

Hi, is anyone else having trouble connecting to the SIM7600 using LTE? I run a RPIcam webinterface with nginx on my raspberry zero, using the SIM7600G module and a static IP on the SIM card. Everything works well, except for accessing the server from ...
by B.Goode
Thu Sep 16, 2021 7:11 am
Forum: Beginners
Topic: To configure Linux kernel?
Replies: 7
Views: 900

Re: To configure Linux kernel?

New to Raspberry Pi, and linux. Im trying to get a Sim7600a to work properly. The instructions i am following say To configure Linux kernel and make sure that: CONFIG_USB_SERIAL=y CONFIG_USB_SERIAL_WWAN=y CONFIG_USB_SERIAL_OPTION=y How do I go about finding the kernal and ensuring this has been con...
by Car_Ram_Rod
Thu Sep 16, 2021 3:51 am
Forum: Beginners
Topic: To configure Linux kernel?
Replies: 7
Views: 900

To configure Linux kernel?

New to Raspberry Pi, and linux. Im trying to get a Sim7600a to work properly. The instructions i am following say To configure Linux kernel and make sure that: CONFIG_USB_SERIAL=y CONFIG_USB_SERIAL_WWAN=y CONFIG_USB_SERIAL_OPTION=y How do I go about finding the kernal and ensuring this has been conf...
by Car_Ram_Rod
Mon Sep 13, 2021 5:14 am
Forum: Networking and servers
Topic: WaveShare sim7600A-H USB issues.
Replies: 1
Views: 543

WaveShare sim7600A-H USB issues.

... However, after shutting the Raspberry Pi down, i was greeted with usb 1-1-3: device descriptor read/64, error-71 and I am unable to connect to the sim7600A via usb. https://developers.telnyx.com/docs/v2/wireless/tutorials/sim7600. I tried following some of the instructions on this form https://www.raspberrypi.org/forums/viewtopic.php?f=36&t=254470 ...
by shinnosuke
Sun Aug 15, 2021 10:30 pm
Forum: Networking and servers
Topic: 4G measurements
Replies: 0
Views: 160

4G measurements

... measurements (db) to measure 4G coverage and then I will add other signal measurement values. I have seen different models like the Waveshare with SIM7600 to connect the raspberry pi to LTE, or also use a huawei usb modem. I don't know which one to use for the first tests and I don't know if there ...
by ADAchim
Wed Aug 04, 2021 9:00 am
Forum: Ubuntu
Topic: Sim7600G HAT on pi 4 Model B with Ubuntu 21.04 as OS
Replies: 2
Views: 646

Re: Sim7600G HAT on pi 4 Model B with Ubuntu 21.04 as OS

... Kconfig file in the drivers/usb/serial folder of the Kernel. Basic instructions are here: https://techship.com/faq/how-to-integrate-simcom-sim7500-sim7600-series-linux-ndis-driver-without-rebuilding-kernel/ CONFIG_USB_SERIAL=y CONFIG_USB_SERIAL_WWAN=y CONFIG_USB_SERIAL_OPTION=y changing those configurations ...
by rberger
Wed Aug 04, 2021 7:06 am
Forum: Ubuntu
Topic: Sim7600G HAT on pi 4 Model B with Ubuntu 21.04 as OS
Replies: 2
Views: 646

Re: Sim7600G HAT on pi 4 Model B with Ubuntu 21.04 as OS

... with: sudo systemctl unmask ModemManager.service # may need this sudo systemctl disable ModemManager.service Also the most recent versions of the SIM7600 HAT that is different than many of these instructions that are out there is the newer ones are already setup for powering on when the Pi is ...
by rberger
Wed Aug 04, 2021 6:56 am
Forum: Networking and servers
Topic: 4G Hat
Replies: 149
Views: 171872

Re: 4G Hat

... at least on Ubuntu Desktop, is conflicting with the qmcli stuff. This had me blocked for a couple of days trying to make the basics work with the SIM7600. You can disable ModemManager with the commands: sudo systemctl unmask ModemManager.service # may need this sudo systemctl disable ModemManager.service ...

Go to advanced search