User avatar
aallan
Raspberry Pi Trading Employee & Forum Moderator
Raspberry Pi Trading Employee & Forum Moderator
Posts: 226
Joined: Mon Feb 09, 2015 11:30 am
Location: Exeter, UK
Contact: Website Twitter

-DPICO_BOARD

Wed Feb 17, 2021 2:49 pm

Just a reminder for folks playing with the VGA Board. If you're building code for the VGA Board remember to pass -DPICO_BOARD=vgaboard to CMake. The default pin settings, which are for Pico, aren't going to be correct. See https://github.com/raspberrypi/pico-playground/issues/9. If you have everything connected up and you're not seeing any VGA output, this is probably the problem.

This issue will also apply to other boards as they start to arrive onto the market. We're currently in the process of getting board definition files from Adafruit, SparkFun, and Pimoroni merged into the SDK. Expect (some) of that to appear in the next SDK release. In the mean time, don't rely on default pins.
Head of Documentation
Raspberry Pi (Trading) Limited
About me, http://alasdairallan.com

mintaka
Posts: 2
Joined: Sat Feb 13, 2021 5:38 pm

Re: -DPICO_BOARD

Fri Mar 12, 2021 5:56 am

Thanks for posting this!

I hope it’s ok to ask about a related issue here. I am trying to build my code for the Adafruit feather RP2040, but I can not get anything to run properly. At this point, I am just trying to build Blink for the Feather but it’s not working. I am running cmake with the “-DPICO_BOARD=adafruit_feather_rp2040” flag, and confirm in the output that the build target board is being set correctly, but still no dice. I have the SDK updated and confirmed that the adafruit_feather_rp2040.h header is present.

Is there anything else I need to do to get the example program running properly on the feather?

jimro
Posts: 2
Joined: Fri Mar 26, 2021 10:50 pm

Re: -DPICO_BOARD

Fri Mar 26, 2021 11:05 pm

So it took me awhile to find, but it looks like you need to specify the generic boot_stage2 on the cmake line. try the following:

Code: Select all

cmake .. -DPICO_BOARD=adafruit_feather_rp2040 -DPICO_DEFAULT_BOOT_STAGE2_FILE=/pico-sdk/src/rp2_common/boot_stage2/boot2_generic_03h.S
Don't forget to change the boot2_generic_03h.S location to your configuration!
cheers,
-jim

kilograham
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 1028
Joined: Fri Apr 12, 2019 11:00 am
Location: austin tx

Re: -DPICO_BOARD

Wed Jul 14, 2021 7:17 pm

Just read this thread; it is no longer true (make sure you always have the latest Raspberry Pi Pico SDK) that you need to pass custom boot stage 2 for adafruit boards. PICO_BOARD= is sufficient

Return to “Other RP2040 boards”