sosa
Posts: 1
Joined: Wed Dec 26, 2012 2:05 pm

Cannot Install ia32-libs

Wed Dec 26, 2012 2:09 pm

I need to run a 32 bit binary, but I am unable to install 32 bit libraries.

Does the Wheezy supports this library?

grimgnaw
Posts: 2
Joined: Tue Dec 25, 2012 1:28 pm

Re: Cannot Install ia32-libs

Wed Dec 26, 2012 4:37 pm

I do not get what you really mean but you are on a 32bit system as you can check yourself quiet easily:

Code: Select all

 $ file /sbin/init
/sbin/init: ELF 32-bit LSB executable, ARM, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.26, BuildID[sha1]=CENSORED ;), stripped
You can install whatever library is available in the repo and if one isn't available you could always built it yourself ;)

If you want multiarch:
binutils-multiarch - Binary utilities that support multi-arch targets
multiarch-support - Transitional package to ensure multiarch compatibility
If you want to work with something which specifically needs ia32-libs I recommend to cross-compile that on a classic PC. There are some threads in this forum discussing that very topic.

Hope this helped you somewhat.

aaa801
Posts: 428
Joined: Mon Jun 04, 2012 9:06 pm
Location: Berkshire

Re: Cannot Install ia32-libs

Thu Dec 27, 2012 12:28 pm

You cant run x86 binarys on the pi

Return to “Beginners”