djjoegreen
Posts: 3
Joined: Thu Sep 16, 2021 2:30 am

New Set Up, Can't Get Anything On Screen

Thu Sep 16, 2021 2:35 am

First time user.

Tried throwing retro pi on my Raspberry Pi 4 using Apple Pi Baker, a 32gb SDHC, formatted using SD Card Formatter. My power supply is the the supply that came with the device (USB-C - 5.1v 3A)

After successfully getting Retro Pi on the SD card I then plug the HDMI in to my television but nothing comes up.

Literally nothing, the TV remains at "no signal input" like I didnt plug anything in.

I've tried a different SD card but got the same results.

I'm completely stumped.. Any help is greatly appreciated.

Cloudcentric
Posts: 1277
Joined: Fri Sep 14, 2012 9:13 am

Re: New Set Up, Can't Get Anything On Screen

Thu Sep 16, 2021 4:03 pm

djjoegreen wrote:
Thu Sep 16, 2021 2:35 am
First time user.

Tried throwing retro pi on my Raspberry Pi 4 using Apple Pi Baker, a 32gb SDHC, formatted using SD Card Formatter. My power supply is the the supply that came with the device (USB-C - 5.1v 3A)

After successfully getting Retro Pi on the SD card I then plug the HDMI in to my television but nothing comes up.

Literally nothing, the TV remains at "no signal input" like I didnt plug anything in.

I've tried a different SD card but got the same results.

I'm completely stumped.. Any help is greatly appreciated.


Switch on the HDMi connected TV before powering on the Raspberry Pi ;)
.
.

User avatar
B.Goode
Posts: 12973
Joined: Mon Sep 01, 2014 4:03 pm
Location: UK

Re: New Set Up, Can't Get Anything On Screen

Thu Sep 16, 2021 4:18 pm

djjoegreen wrote:
Thu Sep 16, 2021 2:35 am
First time user.

Tried throwing retro pi on my Raspberry Pi 4 using Apple Pi Baker, a 32gb SDHC, formatted using SD Card Formatter. My power supply is the the supply that came with the device (USB-C - 5.1v 3A)

After successfully getting Retro Pi on the SD card I then plug the HDMI in to my television but nothing comes up.

Literally nothing, the TV remains at "no signal input" like I didnt plug anything in.

I've tried a different SD card but got the same results.

I'm completely stumped.. Any help is greatly appreciated.

With an appropriate display cable (and adaptor if needed) fully pushed home into the socket, if you power up the RPi4 without a microSD card inserted, do you see this - https://www.raspberrypi.org/documentati ... berry-pi-4

djjoegreen
Posts: 3
Joined: Thu Sep 16, 2021 2:30 am

Re: New Set Up, Can't Get Anything On Screen

Thu Sep 16, 2021 4:43 pm

B.Goode wrote:
Thu Sep 16, 2021 4:18 pm

With an appropriate display cable (and adaptor if needed) fully pushed home into the socket, if you power up the RPi4 without a microSD card inserted, do you see this - https://www.raspberrypi.org/documentati ... berry-pi-4
I do not. Still getting the TV saying "no signal" like I never plugged anything in.

User avatar
HawaiianPi
Posts: 6515
Joined: Mon Apr 08, 2013 4:53 am
Location: Aloha, Oregon USA

Re: New Set Up, Can't Get Anything On Screen

Thu Sep 16, 2021 4:53 pm

What is the resolution of your TV?

Are you sure you have the correct input selected on the TV?

Try a different TV or computer monitor?

Are you using HDMI-0 on the Pi (closest to the USB-C power port)?

Is your Pi4 in a case (some cases and HDMI cable combinations don't fit well and won't allow the HDMI plug to be fully inserted)?

Try it with the default Raspberry Pi OS (32-bit) installed by Raspberry Pi Imager (also, enable SSH and see if you can login to the system)?
My mind is like a browser. 27 tabs are open, 9 aren't responding,
lots of pop-ups, and where is that annoying music coming from?

User avatar
B.Goode
Posts: 12973
Joined: Mon Sep 01, 2014 4:03 pm
Location: UK

Re: New Set Up, Can't Get Anything On Screen

Thu Sep 16, 2021 4:56 pm

djjoegreen wrote:
Thu Sep 16, 2021 4:43 pm
B.Goode wrote:
Thu Sep 16, 2021 4:18 pm

With an appropriate display cable (and adaptor if needed) fully pushed home into the socket, if you power up the RPi4 without a microSD card inserted, do you see this - https://www.raspberrypi.org/documentati ... berry-pi-4
I do not. Still getting the TV saying "no signal" like I never plugged anything in.

So you may have an incompatible tv/display; or a faulty hdmi+adaptor combination. Or a faulty RPi4.

Further testing/substitution might help you narrow it down.


Does the TV need to be preset to take its input from the hdmi connector? It won't necessarily autodetect the RPi input and switch to it.

djjoegreen
Posts: 3
Joined: Thu Sep 16, 2021 2:30 am

Re: New Set Up, Can't Get Anything On Screen

Mon Sep 27, 2021 11:19 pm

It ended up being the fan that came with the raspberry pi was taking too much power.

As soon as I unplugged it it started right up!

Cloudcentric
Posts: 1277
Joined: Fri Sep 14, 2012 9:13 am

Re: New Set Up, Can't Get Anything On Screen

Tue Sep 28, 2021 5:27 am

djjoegreen wrote:
Mon Sep 27, 2021 11:19 pm
It ended up being the fan that came with the raspberry pi was taking too much power.

As soon as I unplugged it it started right up!

Fan not usually required, nor a Heatsink:

https://www.raspberrypi.org/documentati ... al-control
.
.

Return to “Troubleshooting”