Axy
Posts: 25
Joined: Tue Sep 29, 2015 1:52 pm

fbtft_device not loading through /etc/modules

Tue Sep 29, 2015 9:39 pm

I've been trying to install Waveshare's 3.5 inch tft screen for the last few days.

Currently I'm in a case where running this command directly from shell makes the tft show console:

Code: Select all

sudo modprobe flexfb nobacklight regwidth=16 init=-1,0xb0,0x0,-1,0x11,-2,250,-1,0x3A,0x55,-1,0xC2,0x44,-1,0xC5,0x00,0x00,0x00,0x00,-1,0xE0,0x0F,0x1F,0x1C,0x0C,0x0F,0x08,0x48,0x98,0x37,0x0A,0x13,0x04,0x11,0x0D,0x00,-1,0xE1,0x0F,0x32,0x2E,0x0B,0x0D,0x05,0x47,0x75,0x37,0x06,0x10,0x03,0x24,0x20,0x00,-1,0xE2,0x0F,0x32,0x2E,0x0B,0x0D,0x05,0x47,0x75,0x37,0x06,0x10,0x03,0x24,0x20,0x00,-1,0x36,0x28,-1,0x11,-1,0x29,-3 width=480 height=320
sudo modprobe fbtft_device name=flexfb speed=16000000 gpios=reset:25,dc:24
However adding these lines to sudo nano /etc/modules does not have any effect:

Code: Select all

flexfb regwidth=16 nobacklight init=-1,0xb0,0x0,-1,0x11,-2,250,-1,0x3A,0x55,-1,0xC2,0x44,-1,0xC5,0x00,0x00,0x00,0x00,-1,0xE0,0x0F,0x1F,0x1C,0x0C,0x0F,0x08,0x48,0x98,0x37,0x0A,0x13,0x04,0x11,0x0D,0x00,-1,0xE1,0x0F,0x32,0x2E,0x0B,0x0D,0x05,0x47,0x75,0x37,0x06,0x10,0x03,0x24,0x20,0x00,-1,0xE2,0x0F,0x32,0x2E,0x0B,0x0D,0x05,0x47,0x75,0x37,0x06,0x10,0x03,0x24,0x20,0x00,-1,0x36,0x28,-1,0x11,-1,0x29,-3 width=480 height=320
fbtft_device name=flexfb speed=16000000 gpios=reset:25,dc:24
I found a temporary solution where I added the two modprobe lines to rc.local however rc.local runs very late. The main reason I'm trying to install this tft on my rpi2 is to see the boot log - so this temporary solution does not solve my actual problem.

Looking for a solution,
Thank you

lucasiorio
Posts: 1
Joined: Sun Nov 15, 2015 12:13 pm

Re: fbtft_device not loading through /etc/modules

Sun Nov 15, 2015 12:16 pm

I got the same problem, do you have found a solution ?

Axy
Posts: 25
Joined: Tue Sep 29, 2015 1:52 pm

Re: fbtft_device not loading through /etc/modules

Sun Nov 15, 2015 3:19 pm

sadly, no. Looks like this is the way some TFT's work.


User avatar
AndyD
Posts: 2334
Joined: Sat Jan 21, 2012 8:13 am
Location: Melbourne, Australia

Re: fbtft_device not loading through /etc/modules

Sun Nov 15, 2015 8:26 pm

Have a look at the wiki for fbtft.

You can load the module in /etc/modules-load.d/fbtft.conf

Code: Select all

spi-bcm2835
fbtft_device
Then you put the options in /etc/modprobe.d/fbtft.conf (something like?)

Code: Select all

flexfb regwidth=16 nobacklight init=-1,0xb0,0x0,-1,0x11,-2,250,-1,0x3A,0x55,-1,0xC2,0x44,-1,0xC5,0x00,0x00,0x00,0x00,-1,0xE0,0x0F,0x1F,0x1C,0x0C,0x0F,0x08,0x48,0x98,0x37,0x0A,0x13,0x04,0x11,0x0D,0x00,-1,0xE1,0x0F,0x32,0x2E,0x0B,0x0D,0x05,0x47,0x75,0x37,0x06,0x10,0x03,0x24,0x20,0x00,-1,0xE2,0x0F,0x32,0x2E,0x0B,0x0D,0x05,0x47,0x75,0x37,0x06,0x10,0x03,0x24,0x20,0x00,-1,0x36,0x28,-1,0x11,-1,0x29,-3 width=480 height=320
options fbtft_device name=flexfb speed=16000000 gpios=reset:25,dc:24

Return to “Troubleshooting”