di1111
Posts: 2
Joined: Sun Jan 10, 2016 5:12 pm

AmazonBasics 4 Port USB 3.0 Hub not working

Sun Jan 10, 2016 5:18 pm

Hi!
I have a AmazonBasics 4 Port USB 3.0 Hub with 5V/2.5A power adapter but it doesn't work. Is there any drivers that I need to get for it?
Thanks.

User avatar
mahjongg
Forum Moderator
Forum Moderator
Posts: 14622
Joined: Sun Mar 11, 2012 12:19 am
Location: South Holland, The Netherlands

Re: AmazonBasics 4 Port USB 3.0 Hub not working

Sun Jan 10, 2016 5:20 pm

no, if it doesn't work it doesn't work, buy a USB 2 hub.

drgeoff
Posts: 13130
Joined: Wed Jan 25, 2012 6:39 pm

Re: AmazonBasics 4 Port USB 3.0 Hub not working

Sun Jan 10, 2016 5:23 pm

Power adaptors do not need drivers. :)

Nor have I heard of drivers for USB hubs, even 3.0 ones.

Suggest you get a USB 2.0 hub.

BTW are you connecting the hub to a Zero?
Quis custodiet ipsos custodes?

fruitoftheloom
Posts: 27225
Joined: Tue Mar 25, 2014 12:40 pm

Re: AmazonBasics 4 Port USB 3.0 Hub not working

Sun Jan 10, 2016 5:45 pm

di1111 wrote:Hi!
I have a AmazonBasics 4 Port USB 3.0 Hub with 5V/2.5A power adapter but it doesn't work. Is there any drivers that I need to get for it?
Thanks.
There have been several reports of USB3 devices having issues with the RPi ZER0, as mahjongg stated use aMains Powered USB 2.0 Hub.
Take what I advise as advice not the utopian holy grail, and it is gratis !!

di1111
Posts: 2
Joined: Sun Jan 10, 2016 5:12 pm

Re: AmazonBasics 4 Port USB 3.0 Hub not working

Sat Jan 16, 2016 5:25 pm

drgeoff wrote:BTW are you connecting the hub to a Zero?
I am connecting it to a RPi 2

fruitoftheloom
Posts: 27225
Joined: Tue Mar 25, 2014 12:40 pm

Re: AmazonBasics 4 Port USB 3.0 Hub not working

Sat Jan 16, 2016 6:25 pm

di1111 wrote:
drgeoff wrote:BTW are you connecting the hub to a Zero?
I am connecting it to a RPi 2
https://www.raspberrypi.org/documentati ... nownissues
Take what I advise as advice not the utopian holy grail, and it is gratis !!

Return to “Troubleshooting”