Posts: 13
Joined: Fri May 29, 2015 1:18 am

arecord not working

Fri Feb 12, 2016 9:44 pm

Hi fellas,

I am quite new in python programming and linux. I tried to connect a usb device for recording some audio, I only could play audio, but what I record, I can't hear. Below is all of things I've tried. I would be grateful if someone could help.

Fisrt I change the priority of my usb audio device as you can se below:

pi@raspberrypi ~ $ cat /proc/asound/cards
0 [Device ]: USB-Audio - USB PnP Sound Device
USB PnP Sound Device at usb-20980000.usb-1.5.1, full speed
1 [ALSA ]: bcm2835 - bcm2835 ALSA
bcm2835 ALSA

I also edited my alsa-base.conf file like below:

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7
# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd$
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modp$
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 && { /sbin/modp$
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=0
options snd_bcm2835 index=1
# Prevent abnormal drivers from grabbing index 0

But nothing change, so looking for a solution I tried many other things like editing asoundrc file such below:
pi@raspberrypi ~ $ sudo nano ~/.asoundrc

pcm.!default {
type hw
card 0

type hw
card 0

At the end I creat a file such below:

pi@raspberrypi ~ $ sudo nano /etc/asound.conf
type plug
slave.pcm "internal"
type plug
slave.pcm "usb"

It still doesn't work. So I'm sure that some experienced that and solved. Please, help me!

Posts: 258
Joined: Sat Oct 24, 2015 1:50 pm

Re: arecord not working

Sat Feb 13, 2016 1:30 pm

Answer started here: viewtopic.php?f=63&t=136067&p=904934&si ... 33#p904934

Posting the same question lots of times does not get better answers ;)

Return to “Troubleshooting”