Posts: 1
Joined: Mon Dec 04, 2017 6:08 pm

Re: [RPi3] SSH not working via wifi

Mon Dec 04, 2017 6:15 pm

This solved SSH over wifi issues for me:

https://www.eknori.de/2017-09-01/ssh2_m ... -rhel-7-2/

To solve the issue, open the configuration for the connection and navigate to SSH -> Kex. In the “Algorithm selection policy”, move the “Diffie-Hellman group 14” entry to the first position in the list.

Posts: 1
Joined: Tue Feb 28, 2017 8:41 pm

Re: [RPi3] SSH not working via wifi

Mon Aug 27, 2018 3:59 pm

maulapi wrote:
Thu Mar 02, 2017 4:23 pm
I have RPi3 with Raspbian Jessie
- no problem with cabled LAN
- with wifi via USB dongle TL-WN725N no problem with port 80 but not possible to connect via SSH

I search with google for months but trick in this post ( page 4 ) SOLVE!!!:
- i add this line in bottom of /etc/ssh/sshd_config:

Code: Select all

IPQoS cs0 cs0
- restart ssh service and now SSH work also after reboot

Thank you for all


7hours that I am looking for a solution :D :D :D

Posts: 1
Joined: Wed Oct 03, 2018 12:09 pm

Re: [RPi3] SSH not working via wifi

Wed Oct 03, 2018 12:14 pm

For me, after months the only way to get a working WiFi connection on boot without an eth cable plugged in is:

Code: Select all

ifdown eth0
/etc/init.d/ssh restart
at the bottom of /etc/rc.local

So sad. :/

Posts: 4
Joined: Sun Oct 28, 2018 1:22 pm

Re: [RPi3] SSH not working via wifi

Sun Oct 28, 2018 1:25 pm

Guys, It is 2018, almost November. This issue exist since 2016.

Why this is still a problem and people have to struggle to find a solution?
If the fix is adding a single line why it is not out there by default?

Posts: 1
Joined: Sun Feb 24, 2019 7:49 pm

Re: [RPi3] SSH not working via wifi

Sun Feb 24, 2019 9:46 pm

It's strange that after three years this issue still exists. I read the hole discussion. Unfortunately, "IPQoS cs0 cs0" solution did not work for me. I have exactly the same problem with SSH over WiFi, only difference is that my PuTTY does not even ask me to login (as if there's no such IP at all). SSH works on eth0, as well as while being connected to mobile hotspot.

Sorry for dragging you back in 2016, but do you have any suggestions?

I just added IPQoS cs0 cs0 in the bottom of /etc/ssh/sshd_config and restarted the daemon: sudo service ssh restart.

Am I missing something?

Posts: 1
Joined: Sat Aug 10, 2019 8:06 pm

Re: [RPi3] SSH not working via wifi

Sat Aug 10, 2019 8:14 pm

I had similar problems using SSH to my Raspberry pi zero w and applied the solution mentioned here (adding IPQoS cs0 cs0 at the end of /etc/ssh/sshd_config) and it worked.

User avatar
Posts: 2
Joined: Wed Jan 01, 2020 1:58 pm
Location: Phoenix, Az
Contact: Website

Re: [RPi3] SSH not working via wifi

Sun May 10, 2020 6:18 pm

I found one issue quite by mistake that may be the source of a lot of issues. I was using Octoprint for controlling my 3D printers which comes with a reduced version of raspian. I could not get SSH to work at all. On working a few other issues I installed the Desktop and booted into X and opened up the Raspberry Pi Configuration and found that the default Keyboard and WiFi country are set to the UK. That does not surprise me I guess but I was trying to SSH over to it with my US keyboard and my password uses punctuation characters which are mapped different and this is the reason SSH was not working. I set my WiFi Country to US and changed all of the localizations on the Keyboard as well as Locale and Timezone to correctly map my location and now SSH works. It can be a bit devious as when I initially set up my Pi with Octoprint I was on a monitor with a USB keyboard/mouse. Everything I typed it all worked and I'm happy putting things in not realizing I'm not using a US keyboard I'm using a UK keyboard. Once that was fixed all works.
"Television, a medium because it is neither rare nor well done" Ernie Kovacs

Return to “Troubleshooting”