Posts: 1
Joined: Tue Mar 29, 2016 2:03 pm

R Pi 3 - Pure Data

Tue Mar 29, 2016 2:26 pm

Hi there guys,

I'm getting started the new RPi 3. And I've got a bug. Basically My RPi3 does not reboot after installing Pd.
Have you experienced similar problems? Any advice?

Following all dettails.

  • 1. To install the OS
    2. To install Pure Data (aka Pd)
    3. to run audio through Pd
To reproduce Expected
  • 1. RPi3 behaves as usual
    2. I can lunch Pd from the menu
    3. I can get audio from ASLA
  • 1. I cannot see Pd listed on the menu.
    2. I don't get any audio, through jack either
    3. RPi 3 does not reboot

Posts: 2
Joined: Tue Apr 26, 2016 5:23 pm

Re: R Pi 3 - Pure Data

Tue Apr 26, 2016 6:41 pm


Exact same thing here, same OS, same hardware, same problem.

I successfully install and run pd extended following this instructions: ... eezy-armhf
You'll have to use terminal to launch it, type: pd-extended

But I ran in another problem:
I start pd for the first time, tel it to use the usb soundcard, and it's fine.
Then I reboot the Pi, star pd, and it get stuck. Terminal window saw pd signaling watchdog forever.
All usb port are like dead, but the system keep running. CPU is not loaded (a few %).
So choice but to unplug the power supply.

Something is wrong here…

Good luck

Posts: 2
Joined: Tue Apr 26, 2016 5:23 pm

Re: R Pi 3 - Pure Data

Wed Apr 27, 2016 10:35 pm

For what it's worth, I found a way around:

I install Pd in command line following doing this:

Code: Select all

$ sudo apt-get update

Code: Select all

$ sudo apt-get install puredata

Code: Select all

$sudo apt-get install alsa-utils
(this turn out to be already up to date in Jessie Raspbian)
and not

Code: Select all

$ modprobe snd-bcm2835
For some reasons unknown to me, this cause the reboot fail.

From there Pd vanilla is installed and fine.
I can reboot my Pi, no black screen with blinking underscore.

But it's just Pd vanilla. I needed not vanilla object, in my case: grid, from_ascii_code, comport and limit.
Some are easy: you can get comport by:

Code: Select all

$ sudo apt-get install pd-comport
Some are not, like the tof library for the from_ascii_code object.
So downloaded the pd-extended package from the direct download link there: ... b/download
Then extract it, go into the data.tar.gz folder, and navigate to /usr/lib/pd-extended/extra
From there I extracted the needed library (tof and unauthorized) to my download folder.
Move them to the Pd extra folder doing:

Code: Select all

$ cd /home/pi/Downloads

Code: Select all

$ sudo cp -r unauthorized/ /usr/lib/pd/extra

Code: Select all

$ sudo cp -r tof/ /usr/lib/pd/extra
And last tell Pd to use them:
Open Pd, go to the File menu->Preferences->Path
Click New, and add the path for the library /usr/lib/pd/extra/tof
And again with /usr/lib/pd/extra/unauthorized
You will find that some other library are available in /usr/lib/pd/extra, you can add their path as well if ever they are needed.

And I get all my objects working!
It is not a straight way, but it get the job done.

My project is to adjust the volume of several sample playback in pd depending on the bearing of a digital compass. The compass is plugged via I2C to an arduino, who send the bearing with .01° accuracy via serial port/usb to the Raspberry Pi.
Sound is playback through a USB soundcard, the onboard jack of the Pi being too noisy for the project.
It need to be autonomous, the all thing being enclosed in a box, no screen or keyboard, just plug and play.

Tip: to get audio from the jack, go to

Code: Select all

$sudo raspi-config
advanced options / audio /Force 3.5
It will force sound to the jack, not the HDMI.

Hope it help.

Posts: 4
Joined: Sat Jul 30, 2016 10:51 am

Re: R Pi 3 - Pure Data

Sat Jul 30, 2016 10:53 am

wow, thanks a lot!
I tried to install puredata for hours but following to this information it turned out to be pretty simple.

Return to “Troubleshooting”