User avatar
liudr
Posts: 694
Joined: Sat Jun 01, 2013 12:11 am
Location: Central MN, USA

How to make sure the rpi cpu is not throttled down?

Fri Jun 24, 2016 7:19 pm

I wasn't aware of any throttling that I might have set up on my rpi's but today I have a hunch that my rpi 3 may have been running at a lower max frequency than 1.2GHz. I set up the 3b with an older dist that has been running on rpi 2b. I used dist-upgrade and a few apt-get commands to upgrade it. Wifi and bluetooth both work. If there is any throttling, where would I find the setting? The raspi-config GUI won't show me frequency. Same question for the zero I just got.
Arduino data loggers, user interface, printed circuit board designer since 2009, RPI 3B 2B 2B Zero Jessie, assembly/C/C++/java/python programmer since the 80's

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 32137
Joined: Sat Jul 30, 2011 7:41 pm

Re: How to make sure the rpi cpu is not throttled down?

Fri Jun 24, 2016 7:23 pm

CPU will idle at, I believe, 600, and boost to the higher frequencies as required. This keeps the temperatures down - exceed 85 and the device HAS to throttle itself to reduce temperature. Heatsinks can help in cases where this happens.

There are lots of posts on here about throttling etc, a search should find them.
Principal Software Engineer at Raspberry Pi Ltd.
Working in the Applications Team.

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6335
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: How to make sure the rpi cpu is not throttled down?

Fri Jun 24, 2016 7:24 pm

Run "vcgencmd get_throttled". If it is zero (0x0) there has been no throttling since boot. If it is non-zero then you can decode the number here:
viewtopic.php?f=63&t=147781&start=50#p972790

User avatar
jbeale
Posts: 3981
Joined: Tue Nov 22, 2011 11:51 pm

Re: How to make sure the rpi cpu is not throttled down?

Sun Mar 04, 2018 8:13 pm

http://math-atlas.sourceforge.net/atlas ... node5.html If ATLAS's configure detects that CPU throttling is enabled, it will kill itself. The reason is that ATLAS depends on timings to tune the library to your machine. OS-controlled throttling is so course-grained that essentially all timings become random. What this means is that instead of optimizing the code, ATLAS winds up randomly transforming the code, sometimes resulting in better code, and just as often, making the code slower.
If throttling is enabled, the only way to get a decent ATLAS install is therefore to turn it off.
Apparently I have to turn off CPU throttling for the above reason (as ATLAS is a prerequisite for the Caffe architecture that I need). Is there a way to turn this off on RPi model 3 ?

EDIT: nevermind. Apparently I can force the lower speed with

Code: Select all

echo powersave | sudo tee /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
and the higher one with "performance" instead of "powersave"

Return to “Troubleshooting”