User avatar
esbeeb
Posts: 169
Joined: Sun Feb 05, 2012 12:23 am

Setting USB audio dongle as default sound output device

Sun Oct 28, 2012 4:44 pm

After much struggling to get VOIP calls working properly (SIP, and POTS), I'm so pleased with my "Turtle Beach Audio Advantage Micro" USB audio dongle that I've set it up to be my default "soundcard" now. Here's how I did it:

I changed the ordering of the soundcards, so the USB dongle would be "first" (and therefore the dafault). I edited /etc/modprobe.d/alsa-base.conf, with a command like:

Code: Select all

sudo nano /etc/modprobe.d/alsa-base.conf
Then I commented out this line at the bottom, thusly:

Code: Select all

#options snd-usb-audio index=-2
...and added this line after:

Code: Select all

options snd-bcm2835 index=-2
Then after rebooting, the sound worked considerably better than before.

How can one test this out? By playing an MP3 (with abraca, a nice GUI-based MP3 jukebox, much like Rhythmbox, but more lightweight).

I installed abraca and xmms2 (which abraca depends upon), with the command:

Code: Select all

sudo apt-get install abraca xmms2
Before launching abraca, the xmms2 daemon must first be started (which abraca depends upon finding running), with the command:

Code: Select all

xmms2-launcher
Note: the xmms2 daemon is not run as root (thus, no "sudo" is used).

Now launch abraca, and open an MP3 of your choosing. Press Play, and you should hear it out of your speakers. Close abraca, and the MP3 continues playing! This is because it's actually the xmms2 daemon which is playing the MP3. To Stop the MP3, you can launch abraca again and press Stop.

In conclusion, I look forward to the day when the Raspberry Pi's onboard sound "just works", and all GUI programs can utilize it with all the same ease as is experienced on, say, an Ubuntu PC.
Last edited by esbeeb on Sun Oct 28, 2012 4:55 pm, edited 1 time in total.

User avatar
esbeeb
Posts: 169
Joined: Sun Feb 05, 2012 12:23 am

Re: Setting USB audio dongle as default sound output device

Sun Oct 28, 2012 4:54 pm

You also might want to install the "pulseaudio" and "pavucontrol" packages, before trying abraca. I'm not sure if they're required, but they don't seem to hurt if installed. "pavucontrol" is needed if you want to right-click your little "Volume Control" applet (the speaker icon in the lower right, which can be added to the LXDE panel), and click "Volume Control" Settings. "pavucontrol" is the GUI program which then gets launched, allowing you to set mixer levels, etc.

Note: To add the "Volume Control" applet to your LXDE panel (the bar along the bottom of your LXDE desktop), right click it, choose "Add/Remove Panel Items" -> click "Add" button -> Click "Volume Control" -> Click the "Add" button -> press "Up" and "Down" buttons to adjust positioning of applet in the panel (and you'll see the new speaker icon sliding left and right in the lower right of the screen), then click the "Close" button when you're satisfied.

Return to “Troubleshooting”