bill_w
Posts: 57
Joined: Thu Nov 26, 2015 11:16 pm

update / upgrade fails on older Raspian Installation

Fri Jan 10, 2020 3:08 pm

I am running my weather station on a Raspberry PI B+ using the version of Raspian available just before the PI 4 came out. Every few weeks I update and upgrade to be sure my setup has the latest security patches. Starting a few days ago update / Upgrade gives me this:
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
vlc-bin : Depends: libvlc-bin (= 3.0.8-0+deb10u1+rpt1) but 3.0.8-0+deb10u1+rpt7 is to be installed
vlc-plugin-skins2 : Depends: vlc-plugin-qt (= 3.0.8-0+deb10u1+rpt7) but 3.0.8-0+deb10u1+rpt1 is to be installed
E: Broken packages
How should I resolve this?

pcmanbob
Posts: 11959
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: update / upgrade fails on older Raspian Installation

Fri Jan 10, 2020 3:28 pm

Have you tried with

Code: Select all

sudo apt full-upgrade
sudo apt dist-upgrade
We want information… information… information........................no information no help
The use of crystal balls & mind reading are not supported

bill_w
Posts: 57
Joined: Thu Nov 26, 2015 11:16 pm

Re: update / upgrade fails on older Raspian Installation

Fri Jan 10, 2020 3:40 pm

Good idea. Unfortunately, I get another strange response.
9 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 138 MB of archives.
After this operation, 36.0 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Abort.
pi@raspberrypi:~ $

pcmanbob
Posts: 11959
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: update / upgrade fails on older Raspian Installation

Fri Jan 10, 2020 3:52 pm

You could try

Code: Select all

sudo apt-get install -f
but I am not sure that's going to help, as it seems what ever those dependencies are updating them will break them.
We want information… information… information........................no information no help
The use of crystal balls & mind reading are not supported

bill_w
Posts: 57
Joined: Thu Nov 26, 2015 11:16 pm

Re: update / upgrade fails on older Raspian Installation

Fri Jan 10, 2020 4:11 pm

Well, at least its not an error :)
pi@raspberrypi:~ $ sudo apt-get install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 39 not upgraded.

milkaca
Posts: 98
Joined: Fri Feb 05, 2016 6:01 pm

Re: update / upgrade fails on older Raspian Installation

Fri Jan 10, 2020 8:02 pm

I have the same issue. This is really frustrating.

User avatar
HawaiianPi
Posts: 6691
Joined: Mon Apr 08, 2013 4:53 am
Location: Aloha, Oregon USA

Re: update / upgrade fails on older Raspian Installation

Fri Jan 10, 2020 8:24 pm

bill_w wrote:
Fri Jan 10, 2020 3:08 pm
I am running my weather station on a Raspberry PI B+ using the version of Raspian available just before the PI 4 came out.
That would be Raspbian Stretch.

I just tried a sudo apt update && sudo apt full-upgrade -y on my older SSD booted 3B running Raspbian Stretch and it worked for me.

Are you sure it's not an older version (Jessie)? What does lsb_release -a return?

Code: Select all

tim@Legion-Y520:~$ ssh tim@HawaiianPi
tim@hawaiianpi's password:
Linux HawaiianPi 4.19.66-v7+ #1253 SMP Thu Aug 15 11:49:46 BST 2019 armv7l

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

 ██████╗ ██████╗██████╗     ██████╗ ██╗    ██████╗ ██████╗
██╔════╝██╔════╝██╔══██╗    ██╔══██╗██║    ╚════██╗██╔══██╗
███████╗███████╗██║  ██║    ██████╔╝██║     █████╔╝██████╔╝
╚════██║╚════██║██║  ██║    ██╔═══╝ ██║     ╚═══██╗██╔══██╗
██████╔╝██████╔╝██████╔╝    ██║     ██║    ██████╔╝██████╔╝
╚═════╝ ╚═════╝ ╚═════╝     ╚═╝     ╚═╝    ╚═════╝ ╚═════╝

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.

tim@HawaiianPi:~ $ sudo apt update && sudo apt full-upgrade -y
Get:1 http://archive.raspberrypi.org/debian stretch InRelease [25.4 kB]
Get:2 http://raspbian.raspberrypi.org/raspbian stretch InRelease [15.0 kB]
Get:3 http://raspbian.raspberrypi.org/raspbian stretch/main armhf Packages [11.7 MB]
Fetched 11.7 MB in 3d 0h 35min 51s (44 B/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
1 package can be upgraded. Run 'apt list --upgradable' to see it.
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  libssl1.0.2
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 901 kB of archives.
After this operation, 1,024 B of additional disk space will be used.
Get:1 http://mirror.web-ster.com/raspbian/raspbian stretch/main armhf libssl1.0.2 armhf 1.0.2u-1~deb9u1 [901 kB]
Fetched 901 kB in 0s (910 kB/s)
apt-listchanges: Reading changelogs...
Preconfiguring packages ...
(Reading database ... 84312 files and directories currently installed.)
Preparing to unpack .../libssl1.0.2_1.0.2u-1~deb9u1_armhf.deb ...
Unpacking libssl1.0.2:armhf (1.0.2u-1~deb9u1) over (1.0.2t-1~deb9u1) ...
Setting up libssl1.0.2:armhf (1.0.2u-1~deb9u1) ...
Processing triggers for libc-bin (2.24-11+deb9u4) ...
tim@HawaiianPi:~ $ lsb_release -a
No LSB modules are available.
Distributor ID: Raspbian
Description:    Raspbian GNU/Linux 9.11 (stretch)
Release:        9.11
Codename:       stretch
My mind is like a browser. 27 tabs are open, 9 aren't responding,
lots of pop-ups, and where is that annoying music coming from?

milkaca
Posts: 98
Joined: Fri Feb 05, 2016 6:01 pm

Re: update / upgrade fails on older Raspian Installation

Fri Jan 10, 2020 8:31 pm

I am on Buster.

bill_w
Posts: 57
Joined: Thu Nov 26, 2015 11:16 pm

Re: update / upgrade fails on older Raspian Installation

Fri Jan 10, 2020 8:41 pm

Just checked. I am also on Buster.

User avatar
HawaiianPi
Posts: 6691
Joined: Mon Apr 08, 2013 4:53 am
Location: Aloha, Oregon USA

Re: update / upgrade fails on older Raspian Installation

Fri Jan 10, 2020 9:07 pm

amilino wrote:
Fri Jan 10, 2020 8:31 pm
I am on Buster.
bill_w wrote:
Fri Jan 10, 2020 8:41 pm
Just checked. I am also on Buster.
Well then, that's not the version from before the Pi4 came out (Buster was released with the launch of the Pi 4B).

Did you install Buster, or do the non-recommended upgrade from Stretch to Buster?

Just tried the sudo apt update && sudo apt full-upgrade -y command on both of my Pi4Bs (4B4/4B2) and that also worked.

Both are running Raspbian Buster with desktop, and the 4GB model also has the 64-bit kernel and multiarch support installed.

The only odd thing I noticed is that Firefox-ESR was not listed as upgradeable on the first pass with my 4GB model, but when I repeated the sudo apt update command (expecting "All packages are up to date"), it showed up as an additional upgradeable package. It installed fine with a second sudo apt full-upgrade, so ... ¯\_(ツ)_/¯

A second sudo apt update on my 2GB returned "All packages are up to date" as expected (but I don't have Firefox installed on that one).
My mind is like a browser. 27 tabs are open, 9 aren't responding,
lots of pop-ups, and where is that annoying music coming from?

JohnKolb
Posts: 6
Joined: Sun Jul 07, 2019 10:24 pm

Re: update / upgrade fails on older Raspian Installation

Fri Jan 10, 2020 9:20 pm

I am also on Buster and I have the same problem. I am very new to this so any help at all will be appreciated. So far, the only problems that I have found involve the File Manager crashing when opened.

Here are some error messages:
pi@raspberrypi:~ $ sudo apt-get update
Hit:1 http://archive.raspberrypi.org/debian buster InRelease
Hit:2 http://raspbian.raspberrypi.org/raspbian buster InRelease
Reading package lists... Done
pi@raspberrypi:~ $ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
vlc-bin : Depends: libvlc-bin (= 3.0.8-0+deb10u1+rpt1) but 3.0.8-0+deb10u1+rpt7 is to be installed
vlc-plugin-skins2 : Depends: vlc-plugin-qt (= 3.0.8-0+deb10u1+rpt7) but 3.0.8-0+deb10u1+rpt1 is to be installed
E: Broken packages
And:
pi@raspberrypi:~ $ uname -a
Linux raspberrypi 4.19.75-v7l+ #1270 SMP Tue Sep 24 18:51:41 BST 2019 armv7l GNU/Linux
I honestly do not know what VLC does so I am afraid that I might make things worse by fiddling with it.
Any advice appreciated.

milkaca
Posts: 98
Joined: Fri Feb 05, 2016 6:01 pm

Re: update / upgrade fails on older Raspian Installation

Fri Jan 10, 2020 9:25 pm

Fresh install of Buster on RPi4 in my case.

User avatar
HawaiianPi
Posts: 6691
Joined: Mon Apr 08, 2013 4:53 am
Location: Aloha, Oregon USA

Re: update / upgrade fails on older Raspian Installation

Fri Jan 10, 2020 9:35 pm

JohnKolb wrote:
Fri Jan 10, 2020 9:20 pm
I am also on Buster and I have the same problem. I am very new to this so any help at all will be appreciated. So far, the only problems that I have found involve the File Manager crashing when opened.
Try the command I used above.

Code: Select all

sudo apt update && sudo apt full-upgrade -y
That might at least fix the crashing file manager (that bug has been fixed).


VLC is a media player.

Not sure about your vlc errors, I encountered no trouble upgrading that. It may be a propagation error that will resolve itself in a few hours (or minutes, or days). Try again later.

Or you could try a

Code: Select all

sudo apt update && sudo apt install --reinstall vlc -y
and see if that helps.
My mind is like a browser. 27 tabs are open, 9 aren't responding,
lots of pop-ups, and where is that annoying music coming from?

milkaca
Posts: 98
Joined: Fri Feb 05, 2016 6:01 pm

Re: update / upgrade fails on older Raspian Installation

Fri Jan 10, 2020 10:38 pm

Ok, reinstallation helped. Very strange, I need to apply this now on all my RPi's, thank you. 😉

pcmanbob
Posts: 11959
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: update / upgrade fails on older Raspian Installation

Fri Jan 10, 2020 10:49 pm

I have just run a update & full-upgrade on my pi4 2GB with the SD crad that has raspbian buster with desktop and recommended software,

as you can see from the details below its not been updated in a while but there was no problem , all the VLC related files installed OK

including vlc-bin , vlc-plugin-skins2 ,libvlc-bin:armhf (3.0.8-0+deb10u1+rpt7) , 081-vlc-plugin-qt_3.0.8-0+deb10u1+rpt7_armhf.deb
& vlc-plugin-qt:armhf (3.0.8-0+deb10u1+rpt7)

But I have always used sudo apt full-upgrade to make sure all dependences are updated at the same time , were as sudo apt upgrade does not , may be that's were the error was introduced in a previous update and why reinstalling VLC fixes the problem because it would also pull in all the required dependences.

Code: Select all

pi@DesktopPi:~ $ sudo apt update
Get:1 http://archive.raspberrypi.org/debian buster InRelease [25.1 kB]
Get:2 http://raspbian.raspberrypi.org/raspbian buster InRelease [15.0 kB]
Get:3 http://archive.raspberrypi.org/debian buster/main armhf Packages [261 kB]
Get:4 http://raspbian.raspberrypi.org/raspbian buster/main armhf Packages [13.0 MB]
Fetched 13.3 MB in 7s (1,943 kB/s)                                             
Reading package lists... Done
Building dependency tree       
Reading state information... Done
151 packages can be upgraded. Run 'apt list --upgradable' to see them.
pi@DesktopPi:~ $ sudo apt full-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  alsa-base gstreamer0.10-alsa gstreamer0.10-plugins-base libdrm-etnaviv1
  libgstreamer-plugins-base0.10-0 libgstreamer0.10-0 libllvm6.0 libva-drm2
  libva-wayland2 libva-x11-2 libva2 libvdpau-va-gl1 libvdpau1 libxfce4util-bin
  libxfce4util-common libxfce4util7 libxfconf-0-2 mesa-va-drivers
  mesa-vdpau-drivers pimixer point-rpi va-driver-all vdpau-driver-all xfconf
Use 'sudo apt autoremove' to remove them.
The following NEW packages will be installed:
  eject libdav1d3
The following packages will be upgraded:
  arandr base-files chromium-browser chromium-browser-l10n
  chromium-codecs-ffmpeg-extra cron dhcpcd5 distro-info-data ffmpeg
  fonts-opensymbol freetype2-doc git git-man gtk2-engines-pixflat libavcodec58
  libavdevice58 libavfilter7 libavformat58 libavresample4 libavutil56
  libegl-mesa0 libfm-data libfm-extra4 libfm-gtk-data libfm-gtk4 libfm-modules
  libfm4 libfreetype6 libfreetype6-dev libfribidi0 libgbm1 libgl1-mesa-dri
  libglapi-mesa libgles2-mesa libglib2.0-0 libglib2.0-bin libglib2.0-data
  libglx-mesa0 libgs9 libgs9-common libjavascriptcoregtk-4.0-18 libncurses5
  libncurses6 libncursesw5 libncursesw6 libnss3 libobrender32v5 libobt2v5
  libpam-systemd libpostproc55 libpython2.7 libpython2.7-dev
  libpython2.7-minimal libpython2.7-stdlib libreoffice
  libreoffice-avmedia-backend-gstreamer libreoffice-base libreoffice-base-core
  libreoffice-base-drivers libreoffice-calc libreoffice-common
  libreoffice-core libreoffice-draw libreoffice-gtk3 libreoffice-help-common
  libreoffice-help-en-gb libreoffice-impress libreoffice-java-common
  libreoffice-l10n-en-gb libreoffice-librelogo libreoffice-math
  libreoffice-nlpsolver libreoffice-report-builder
  libreoffice-report-builder-bin libreoffice-script-provider-bsh
  libreoffice-script-provider-js libreoffice-script-provider-python
  libreoffice-sdbc-firebird libreoffice-sdbc-hsqldb
  libreoffice-sdbc-postgresql libreoffice-style-colibre
  libreoffice-style-tango libreoffice-wiki-publisher libreoffice-writer
  libruby2.5 libsasl2-2 libsasl2-modules-db libswresample3 libswscale5
  libsystemd0 libtinfo5 libtinfo6 libudev1 libvlc-bin libvlc5 libvlccore9
  libvpx5 libwebkit2gtk-4.0-37 libxslt1.1 lxpanel lxpanel-data
  lxplug-bluetooth lxplug-ejecter lxplug-ptbatt lxplug-volume mesa-va-drivers
  mesa-vdpau-drivers ncurses-base ncurses-bin ncurses-term nodered obconf
  openbox pcmanfm pipanel pixflat-icons python-cryptography python-werkzeug
  python2.7 python2.7-dev python2.7-minimal python3-cryptography
  python3-thonny python3-uno python3-werkzeug raspberrypi-ui-mods raspi-config
  rp-prefapps rpcbind rpi-chromium-mods rpi-eeprom rpi-eeprom-images ruby2.5
  systemd systemd-sysv thonny udev uno-libs3 ure vlc vlc-bin vlc-data vlc-l10n
  vlc-plugin-base vlc-plugin-notify vlc-plugin-qt vlc-plugin-samba
  vlc-plugin-skins2 vlc-plugin-video-output vlc-plugin-video-splitter
  vlc-plugin-visualization
151 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 331 MB of archives.
After this operation, 18.9 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
We want information… information… information........................no information no help
The use of crystal balls & mind reading are not supported

JohnKolb
Posts: 6
Joined: Sun Jul 07, 2019 10:24 pm

Re: update / upgrade fails on older Raspian Installation

Sat Jan 11, 2020 1:00 am

Fixed! Thanks everyone for the help!

I ran sudo apt update followed by sudo apt upgrade followed by a reboot. This got me past the broken packages message to where I could update/upgrade again. I got the message about choosing one of the defaults from the Appearance Settings menu so after I rebooted I did that too. My icons are all big and funky but at least the File Manager works now!

Thanks again!

pcmanbob
Posts: 11959
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: update / upgrade fails on older Raspian Installation

Sat Jan 11, 2020 11:21 am

JohnKolb wrote:
Sat Jan 11, 2020 1:00 am
Fixed! Thanks everyone for the help!

I ran sudo apt update followed by sudo apt upgrade followed by a reboot. This got me past the broken packages message to where I could update/upgrade again. I got the message about choosing one of the defaults from the Appearance Settings menu so after I rebooted I did that too. My icons are all big and funky but at least the File Manager works now!

You should be using

Code: Select all

sudo apt update
sudo apt full-upgrade
note the full in front of upgrade, this way you will pull in all the dependences as well which should stop things like your file manager problem.

as per the docs

https://www.raspberrypi.org/documentati ... pdating.md
We want information… information… information........................no information no help
The use of crystal balls & mind reading are not supported

JohnKolb
Posts: 6
Joined: Sun Jul 07, 2019 10:24 pm

Re: update / upgrade fails on older Raspian Installation

Sat Jan 11, 2020 11:40 am

Sorry! I did actually use:

Code: Select all

sudo apt update
sudo apt full-upgrade
I should have been more specific!
Thanks again!

MikeCoder
Posts: 84
Joined: Fri Jan 24, 2020 12:05 am

Re: update / upgrade fails on older Raspian Installation

Fri Jan 24, 2020 12:08 am

just do sudo apt full-upgrade and then when it asks you y/n, just type "yes"

kevinmagno
Posts: 1
Joined: Sat Feb 01, 2020 9:26 am

Re: update / upgrade fails on older Raspian Installation

Sat Feb 01, 2020 9:30 am

HawaiianPi wrote:
Fri Jan 10, 2020 9:35 pm
JohnKolb wrote:
Fri Jan 10, 2020 9:20 pm
I am also on Buster and I have the same problem. I am very new to this so any help at all will be appreciated. So far, the only problems that I have found involve the File Manager crashing when opened.
Try the command I used above.

Code: Select all

sudo apt update && sudo apt full-upgrade -y
That might at least fix the crashing file manager (that bug has been fixed).


VLC is a media player.

Not sure about your vlc errors, I encountered no trouble upgrading that. It may be a propagation error that will resolve itself in a few hours (or minutes, or days). Try again later.

Or you could try a

Code: Select all

sudo apt update && sudo apt install --reinstall vlc -y
and see if that helps.


This reinstalling vlc fixed it for me, thanks.

Sayed01
Posts: 1
Joined: Thu Feb 06, 2020 6:25 am

Re: update / upgrade fails on older Raspian Installation

Thu Feb 06, 2020 6:28 am

Thank you all !!! Finally it works. :D

Code: Select all

sudo apt update && sudo apt full-upgrade -y 

Return to “Troubleshooting”