tbier
Posts: 3
Joined: Fri Jan 31, 2020 6:15 pm

Raspberry Pi 4 on armv7l: Missing permissions for v3d desktop performance?

Fri Jan 31, 2020 6:41 pm

Hi everybody,

first post here, although I have been using the Pi since the first one got out :)
Starting with the Pi 4, Desktop usage has become very interesting to me, and I am currently trying to set it up using CRUX (non official armv7l build, think of it more like a Linux from scratch experience? :) ) but I seem to be lacking permissions.

The sympton: X11 starts and shows the right driver in use (glxinfo -B output: http://dpaste.com/3WRVYQK ), but the performance is horrible and fast moving text (for example compiling something) on the terminal will render the font unreadable. First I was debugging the problem from all other angles (like mesa3d, libglvnd, libdrm or whatever else in the dependency chain) until I tried running X11 as root - and who knew, this works! :D

I do have my regular user in the video group, however, without the usage of udev rules all the devices in /dev are owned by root:root. This is what it looks like without udev rules: http://dpaste.com/2G135PS

I did take udev rules from archs kodi port, however, these don't change anything: https://archlinuxarm.org/packages/armv7 ... kodi.rules (I added my user to all these additional groups: gpio, video, tty)

Can somebody tell me where I am making the wrong move?

Thanks in advance and have a great weekend,

Tim

tbier
Posts: 3
Joined: Fri Jan 31, 2020 6:15 pm

Re: Raspberry Pi 4 on armv7l: Missing permissions for v3d desktop performance?

Sat Feb 01, 2020 12:22 am

I think i can mark this thread as solved.

I used i3 for the test, and I did copy its config from another machine to the Pi. I just tried it with a clean, default config and it just works.. The error was in front of the keyboard all along :)
Thanks! Have a great day!

Return to “Troubleshooting”