MrEngman
Posts: 4140
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: D.Link DWA 131 WLAN/USB Adapter not working

Tue Feb 10, 2015 5:03 am

bbrik wrote:I am having trouble with this wifi dongle on the latest Raspbian (2015-31-01).
lsusb output:

Code: Select all

Bus 001 Device 004: ID 2001:330d D-Link Corp.
uname -a

Code: Select all

Linux raspberrypi 3.18.5+ #744 PREEMPT Fri Jan 30 18:19:07 GMT 2015 armv6l GNU/Linux
I have no wlan0
Can anybody help?
Hi bbrik,

Your wifi is not working because the USB ID for your wifi does not appear to be included in the current 8192cu driver.

Not sure why this happened but the driver was not included in the 3.18 version to begin with and was added later and your device ID was included in a patch and I guess the patch was forgotten about and wasn't added.

I have edited the driver and added the device ID for your wifi. You should be able to download and install it with the following commands.

Code: Select all

wget https://dl.dropboxusercontent.com/u/80256631/8192cu-3.18.5-744.tar.gz
tar -xzf 8192cu-3.18.5-744.tar.gz
sudo install -p -m 644 8192cu.ko /lib/modules/3.18.5+/kernel/drivers/net/wireless/rtl8192cu
sudo depmod 3.18.5+
sudo insmod /lib/modules/3.18.5+/kernel/drivers/net/wireless/rtl8192cu/8192cu.ko
I am unable to test it with your driver module as I do not have one but it appears to work OK using an Edimax EW-7811Un.

I have raised an issue on the raspberrypi linux repository to add the USB ID so hopefully the problem will be fixed on the next rpi-update.


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

bbrik
Posts: 7
Joined: Wed Feb 04, 2015 11:38 pm

Re: D.Link DWA 131 WLAN/USB Adapter not working

Wed Feb 11, 2015 12:53 am

Hi MrEngman,
Thank you for your help.

I am still getting wpa supplicant errors on boot, but it IS working now! How come?

This is what I done:

Code: Select all

apt-get remove firmware-realtek
apt-get install firmware-realtek
apt-get install firmware-linux
added this line to /etc/modules

Code: Select all

8192cu

MrEngman
Posts: 4140
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: D.Link DWA 131 WLAN/USB Adapter not working

Wed Feb 11, 2015 1:13 am

bbrik wrote:Hi MrEngman,
Thank you for your help.

I am still getting wpa supplicant errors on boot, but it IS working now! How come?

This is what I done:

Code: Select all

apt-get remove firmware-realtek
apt-get install firmware-realtek
apt-get install firmware-linux
added this line to /etc/modules

Code: Select all

8192cu
The 8192cu driver does not need a separate firmware file so installing firmware is wasting space on the SD card.

You should also not need to add 8192cu to /etc/modules, but if you have it will not cause any problems. Adding module names to /etc/module will get them to load even if not needed, so if you boot the Pi without the wifi connected it will still load the module.

What are the errors you see?


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

seiko
Posts: 1
Joined: Sun Feb 08, 2015 1:18 pm

Re: D.Link DWA 131 WLAN/USB Adapter not working

Wed Feb 11, 2015 6:30 pm

MrEngman wrote:
bbrik wrote:I am having trouble with this wifi dongle on the latest Raspbian (2015-31-01).
lsusb output:

Code: Select all

Bus 001 Device 004: ID 2001:330d D-Link Corp.
uname -a

Code: Select all

Linux raspberrypi 3.18.5+ #744 PREEMPT Fri Jan 30 18:19:07 GMT 2015 armv6l GNU/Linux
I have no wlan0
Can anybody help?
Hi bbrik,

Your wifi is not working because the USB ID for your wifi does not appear to be included in the current 8192cu driver.

Not sure why this happened but the driver was not included in the 3.18 version to begin with and was added later and your device ID was included in a patch and I guess the patch was forgotten about and wasn't added.

I have edited the driver and added the device ID for your wifi. You should be able to download and install it with the following commands.

Code: Select all

wget https://dl.dropboxusercontent.com/u/80256631/8192cu-3.18.5-744.tar.gz
tar -xzf 8192cu-3.18.5-744.tar.gz
sudo install -p -m 644 8192cu.ko /lib/modules/3.18.5+/kernel/drivers/net/wireless/rtl8192cu
sudo depmod 3.18.5+
sudo insmod /lib/modules/3.18.5+/kernel/drivers/net/wireless/rtl8192cu/8192cu.ko
I am unable to test it with your driver module as I do not have one but it appears to work OK using an Edimax EW-7811Un.

I have raised an issue on the raspberrypi linux repository to add the USB ID so hopefully the problem will be fixed on the next rpi-update.


MrEngman
Your solution worked for me. Had identical problem after updating. Thx.

Dan279
Posts: 2
Joined: Thu Feb 12, 2015 12:48 pm

Re: D.Link DWA 131 WLAN/USB Adapter not working

Thu Feb 12, 2015 1:31 pm

Doesn't seem to be working for me I just keep getting "invalid module format". If anybody could help plz

MrEngman
Posts: 4140
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: D.Link DWA 131 WLAN/USB Adapter not working

Thu Feb 12, 2015 9:08 pm

Dan279 wrote:Doesn't seem to be working for me I just keep getting "invalid module format". If anybody could help plz
Guess you're trying to install it on a different revision.

What does the output of command uname -a show?


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

Dan279
Posts: 2
Joined: Thu Feb 12, 2015 12:48 pm

Re: D.Link DWA 131 WLAN/USB Adapter not working

Thu Feb 12, 2015 10:36 pm

Mr EngMan, on behave of myself and all of the community(well I hope all the community is with me) thanks for all your help and devotion.

I finally reinstalled raspbian without an internet connection, ran your code and then my usb wifi dongle d-link dwa 131 B1 and then updated, ran nearly out-of-the-box ( we should put a new abreviation up on elinux for that, maybe it could link right back to you, we could call it MEM-OOTB,Mr EngMan-Out-Of-The-Box)

aop
Posts: 1
Joined: Sat Feb 14, 2015 6:20 pm

Re: D.Link DWA 131 WLAN/USB Adapter not working

Sat Feb 14, 2015 6:25 pm

Hello
I face the same problem with the Kernel 3.18.5-v7+. The D.Link DWA 131 Rev. B1 with ID 2001:330d is recognized by the driver 8192cu.
May anyone provide me a compiled 8192cu.ko module for the 3.18.5-v7+, which includes the ID?

Thanks & regards
Peter

foofaa
Posts: 3
Joined: Sun Feb 15, 2015 10:02 pm

Re: D.Link DWA 131 WLAN/USB Adapter not working

Sun Feb 15, 2015 10:16 pm

Thank you for your help, Mr Engman.

I followed the instructions in your post, but changed all instances of "3.18.5" with "3.18.7" to match my Pi (uname -a = "Linux raspberrypi 3.18.7-v7+ #755 SMP PREEMPT Thu Feb 12 17:20:48 GMT 2015 armv7l GNU/Linux").

Upon trying the final step ("sudo insmod /lib/modules/3.18.7+/kernel/drivers/net/wireless/rtl8192cu/8192cu.ko") I got "Error: could not insert module /lib/modules/3.18.7+/kernel/drivers/net/wireless/rtl8192cu/8192cu.ko: Invalid module format".

Is the 8192cu.ko file you provide specifically for "3.18.5", as opposed to "3.18.X"? If so, is there a more generic solution to this issue? If your answer is "wait until next version of OS" (fair enough!), do you have any idea when it might be out (I'm very new to Pi and have no idea if this is likely to be days or weeks or months).

Thank you, again, for any assistance you can provide.

MrEngman
Posts: 4140
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: D.Link DWA 131 WLAN/USB Adapter not working

Mon Feb 16, 2015 2:54 am

foofaa wrote:Thank you for your help, Mr Engman.

I followed the instructions in your post, but changed all instances of "3.18.5" with "3.18.7" to match my Pi (uname -a = "Linux raspberrypi 3.18.7-v7+ #755 SMP PREEMPT Thu Feb 12 17:20:48 GMT 2015 armv7l GNU/Linux").

Upon trying the final step ("sudo insmod /lib/modules/3.18.7+/kernel/drivers/net/wireless/rtl8192cu/8192cu.ko") I got "Error: could not insert module /lib/modules/3.18.7+/kernel/drivers/net/wireless/rtl8192cu/8192cu.ko: Invalid module format".

Is the 8192cu.ko file you provide specifically for "3.18.5", as opposed to "3.18.X"? If so, is there a more generic solution to this issue? If your answer is "wait until next version of OS" (fair enough!), do you have any idea when it might be out (I'm very new to Pi and have no idea if this is likely to be days or weeks or months).

Thank you, again, for any assistance you can provide.
The 8192cu driver included in 3.18.7-v7+ #755 now includes the ID for the DWA-131 so you do not need to install a driver and the DWA-131 should work once you have configured your wifi.

You will need to restore the driver included with 3.18.7-v7+ as installing the driver I compiled will have over-written it. You can do that with the following commands

Code: Select all

sudo rm /boot/.firmware_revision
sudo rpi-update
.


MrEngman
Last edited by MrEngman on Mon Feb 16, 2015 3:05 am, edited 1 time in total.
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

MrEngman
Posts: 4140
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: D.Link DWA 131 WLAN/USB Adapter not working

Mon Feb 16, 2015 2:58 am

aop wrote:Hello
I face the same problem with the Kernel 3.18.5-v7+. The D.Link DWA 131 Rev. B1 with ID 2001:330d is recognized by the driver 8192cu.
May anyone provide me a compiled 8192cu.ko module for the 3.18.5-v7+, which includes the ID?

Thanks & regards
Peter
The driver I compiled will not work with 3.18.5-v7+. You could update to the latest version 3.18.7-v7+ which now includes the fix for the DWA-131. Just run command sudo rpi-update to update.


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

foofaa
Posts: 3
Joined: Sun Feb 15, 2015 10:02 pm

Re: D.Link DWA 131 WLAN/USB Adapter not working

Thu Feb 19, 2015 12:09 am

Thank you for your help, Mr Engman.

I actually ended up doing a clean install of Raspbian (3.18.5 + rpi-update to 3.18.7), as I stuffed up my rollback.

My DWA-131 is still not being recognized by my Pi.

I suspect that it might be down to the fact that I have a "D-Link DWA-131; H/W Ver.: E1; F/W Ver.: 5.00" - note the H/W version (not A1 nor B1, as referenced in many of these threads). I suspect my dongle is "a bit fresh".

So the question becomes how do I find the E1 equivalent of the "{USB_DEVICE(0x2001, 0x330d)},/* D-Link - DWA 131 */ \" addition that you added to the last Kernel update (I'm assuming the device number has changed)? Web searching has not enlightened me thus far.

FYI, from my Pi (not sure if this helps):
dmesg [after plugging in DWA-131]
...
[ 86.728884] usb 1-1.5: new high-speed USB device number 6 using dwc_otg
[ 86.829731] usb 1-1.5: New USB device found, idVendor=2001, idProduct=3319
[ 86.829784] usb 1-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 86.829802] usb 1-1.5: Product: Wireless N Nano USB Adapter
[ 86.829819] usb 1-1.5: Manufacturer: Realtek
[ 86.829835] usb 1-1.5: SerialNumber: 00e04c000001

lsusb
...
Bus 001 Device 006: ID 2001:3319 D-Link Corp.

Just noticed! Is "2001:3319" the number I'm looking for? If so, what do I do now?

Thank you, again, for any assistance you can provide.

MrEngman
Posts: 4140
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: D.Link DWA 131 WLAN/USB Adapter not working

Thu Feb 19, 2015 8:08 pm

foofaa wrote:Thank you for your help, Mr Engman.

I actually ended up doing a clean install of Raspbian (3.18.5 + rpi-update to 3.18.7), as I stuffed up my rollback.

My DWA-131 is still not being recognized by my Pi.

I suspect that it might be down to the fact that I have a "D-Link DWA-131; H/W Ver.: E1; F/W Ver.: 5.00" - note the H/W version (not A1 nor B1, as referenced in many of these threads). I suspect my dongle is "a bit fresh".

So the question becomes how do I find the E1 equivalent of the "{USB_DEVICE(0x2001, 0x330d)},/* D-Link - DWA 131 */ \" addition that you added to the last Kernel update (I'm assuming the device number has changed)? Web searching has not enlightened me thus far.

FYI, from my Pi (not sure if this helps):
dmesg [after plugging in DWA-131]
...
[ 86.728884] usb 1-1.5: new high-speed USB device number 6 using dwc_otg
[ 86.829731] usb 1-1.5: New USB device found, idVendor=2001, idProduct=3319
[ 86.829784] usb 1-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 86.829802] usb 1-1.5: Product: Wireless N Nano USB Adapter
[ 86.829819] usb 1-1.5: Manufacturer: Realtek
[ 86.829835] usb 1-1.5: SerialNumber: 00e04c000001

lsusb
...
Bus 001 Device 006: ID 2001:3319 D-Link Corp.

Just noticed! Is "2001:3319" the number I'm looking for? If so, what do I do now?

Thank you, again, for any assistance you can provide.
Hi foofaa,

I've been looking around the internet to try and find info on your wifi module. No sign of DWA-131 vE1 on D-Links web sites. I found some info here which seems to indicate the E1 uses the RTL8192EU chip set.

None of the current drivers appear to support that device but I've found driver source code supporting the 8192eu and compiled an 8192eu driver. I have no idea if it will work or not as I do not have a DWA-131 E1 wifi module to test it with.

You can download the compiled driver for 3.18.7+ and install it using the commands

Code: Select all

wget https://dl.dropboxusercontent.com/u/80256631/8192eu-3.18.7.tar.gz
tar -xzf 8192eu-3.18.7.tar.gz
sudo install -p -m 644 8192eu.ko /lib/modules/3.18.7+/kernel/drivers/net/wireless
sudo depmod 3.18.7+
After running the commands reboot to see if the driver loads and see if the command ifconfig shows a wlan0 wifi entry. The command lsmod should show a list of installed modules and should then include 8192eu.

If you have set up the wifi configuration to connect to your wireless network hopefully you will be connected. If you have not configured it yet you will need to do that to get the Pi to connect to your network. I find the simplest way is to edit the file /etc/network/interfaces. You can find some basic details here.

Hope this is OK. No doubt you will let me know if it doesn't work. :D


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

gertjvr
Posts: 3
Joined: Fri Feb 20, 2015 11:21 am

Re: D.Link DWA 131 WLAN/USB Adapter not working

Fri Feb 20, 2015 11:26 am

Sadly it doesn't work :( tried following your instructions

found that you can test the module with insmod

Code: Select all

sudo insmod 8192eu.ko

Code: Select all

Error: could not insert module 8192eu.ko: Invalid module format

gertjvr
Posts: 3
Joined: Fri Feb 20, 2015 11:21 am

Re: D.Link DWA 131 WLAN/USB Adapter not working

Fri Feb 20, 2015 11:34 am

DWA-131 E1G

uname -a
Linux raspberrypi 3.18.7-v7+ #755 SMP PREEMPT Thu Feb 12 17:20:48 GMT 2015 armv7l GNU/Linux

dmesg
[ 3.989022] usb 1-1.5: new high-speed USB device number 5 using dwc_otg
[ 4.099838] usb 1-1.5: New USB device found, idVendor=2001, idProduct=3319
[ 4.111217] usb 1-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 4.120953] usb 1-1.5: Product: Wireless N Nano USB Adapter
[ 4.129384] usb 1-1.5: Manufacturer: Realtek

MrEngman
Posts: 4140
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: D.Link DWA 131 WLAN/USB Adapter not working

Fri Feb 20, 2015 11:54 am

gertjvr wrote:DWA-131 E1G

uname -a
Linux raspberrypi 3.18.7-v7+ #755 SMP PREEMPT Thu Feb 12 17:20:48 GMT 2015 armv7l GNU/Linux

dmesg
[ 3.989022] usb 1-1.5: new high-speed USB device number 5 using dwc_otg
[ 4.099838] usb 1-1.5: New USB device found, idVendor=2001, idProduct=3319
[ 4.111217] usb 1-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 4.120953] usb 1-1.5: Product: Wireless N Nano USB Adapter
[ 4.129384] usb 1-1.5: Manufacturer: Realtek
Always useful to know the output of command uname -a to make sure of the actual kernel version. Change the download and install instructions to

Code: Select all

wget https://dl.dropboxusercontent.com/u/80256631/8192eu-3.18.7-v7.tar.gz
tar -xzf 8192eu-3.18.7-v7.tar.gz
sudo install -p -m 644 8192eu.ko /lib/modules/3.18.7-v7+/kernel/drivers/net/wireless
sudo depmod 3.18.7-v7+
MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

gertjvr
Posts: 3
Joined: Fri Feb 20, 2015 11:21 am

Re: D.Link DWA 131 WLAN/USB Adapter not working

Fri Feb 20, 2015 11:42 pm

Thank you so much for the quick response, looks like it working now!!!

MrEngman
Posts: 4140
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: D.Link DWA 131 WLAN/USB Adapter not working

Sat Feb 21, 2015 12:01 am

gertjvr wrote:Thank you so much for the quick response, looks like it working now!!!
Great, glad to be able to help.


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

foofaa
Posts: 3
Joined: Sun Feb 15, 2015 10:02 pm

Re: D.Link DWA 131 WLAN/USB Adapter not working

Mon Feb 23, 2015 12:09 am

Thank you so much, Mr Engman!

Apologies for not supplying all the info you required (uname -a). I, too, am "3.18.7-v7+", so I followed the modified process you put together for gertjvr. And it looks like it is working! I still can't seem to connect to my network (some config detail, presumably), but wpa_gui is scanning for, and detecting, networks, so that's a huge step forward...

Thank you, again, for your help. You are a real credit to the RaspberryPi community, and I hope one day I can "pay forward" the help you've supplied.

mvdhoek
Posts: 4
Joined: Wed Feb 25, 2015 1:34 pm

Re: D.Link DWA 131 WLAN/USB Adapter not working

Wed Feb 25, 2015 1:40 pm

Hi all,

I've been having problems with this wlan chipset (RTL8192eu) for quite a while now and have not been able to get it working...
The problem for me is to compile the driver.

I am running OSMC with the 3.18.5-v7+ (#225) on my rpi2. I have tried different sources and different guides. I tried to use the driver that was provided here, but no luck due to different kernel version.

Is there any way how i can get this driver working on my rpi2? I tried upgrading the kernel but dont really know how that works.
Can anyone point me in the right direction? Otherwise I assume I must just get a distribution with kernel version 3.18.7 so that the driver works with it...

Thanks

MrEngman
Posts: 4140
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: D.Link DWA 131 WLAN/USB Adapter not working

Thu Feb 26, 2015 9:46 am

mvdhoek wrote:Hi all,

I've been having problems with this wlan chipset (RTL8192eu) for quite a while now and have not been able to get it working...
The problem for me is to compile the driver.

I am running OSMC with the 3.18.5-v7+ (#225) on my rpi2. I have tried different sources and different guides. I tried to use the driver that was provided here, but no luck due to different kernel version.

Is there any way how i can get this driver working on my rpi2? I tried upgrading the kernel but dont really know how that works.
Can anyone point me in the right direction? Otherwise I assume I must just get a distribution with kernel version 3.18.7 so that the driver works with it...

Thanks
Hi mvdhoek,

I've compiled a version of the 8192eu driver for 3.18.5-v7+. I don't have an 8192eu wifi module to test it with but the driver loads OK using the sudo insmod command with OSMC 7.50 and also with the standard rasbian 3.18.5-v7+ image so I would expect it to work.

Download and install using commands

Code: Select all

wget https://dl.dropboxusercontent.com/u/80256631/8192eu-3.18.5-v7.tar.gz
tar xzf 8192eu-3.18.5-v7.tar.gz
sudo install -p -m 644 8192eu.ko /lib/modules/3.18.5-v7+/kernel/drivers/net/wireless
sudo depmod 3.18.5-v7+
After installing reboot and then configure your wifi and hopefully you will find it works.


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

AlessandroFerri
Posts: 61
Joined: Tue Apr 02, 2013 5:44 pm

Re: D.Link DWA 131 WLAN/USB Adapter not working

Thu Feb 26, 2015 3:58 pm

Hi Mr Engman,
before I often used my PI to create an access point with a Edimax EW-7811Un, compiling hostapd from its driver (RTL8188C_8192C_USB_linux_v4.0.2_9000.20130911). Worked great, both connecting the Pi to my home network and creating an Access Point.
Now with the kernel:
Linux raspberrypi 3.18.7+ # 758 PREEMPT Mon February 23 19:27:03 GMT 2015 armv6l GNU / Linux
while I can connect the Pi to my home network with Edimax EW-7811Un , now if I use default hostapd, this does not run, the edimax is turned off and died.
Have I to compile again in the old hostapd that I find on the old driver (RTL8188C_8192C_USB_linux_v4.0.2_9000.20130911), or has changed?

MrEngman
Posts: 4140
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: D.Link DWA 131 WLAN/USB Adapter not working

Thu Feb 26, 2015 4:05 pm

AlessandroFerri wrote:Hi Mr Engman,
before I often used my PI to create an access point with a Edimax EW-7811Un, compiling hostapd from its driver (RTL8188C_8192C_USB_linux_v4.0.2_9000.20130911). Worked great, both connecting the Pi to my home network and creating an Access Point.
Now with the kernel:
Linux raspberrypi 3.18.7+ # 758 PREEMPT Mon February 23 19:27:03 GMT 2015 armv6l GNU / Linux
while I can connect the Pi to my home network with Edimax EW-7811Un , now if I use default hostapd, this does not run, the edimax is turned off and died.
Have I to compile again in the old hostapd that I find on the old driver (RTL8188C_8192C_USB_linux_v4.0.2_9000.20130911), or has changed?
I think you will need to compile and use the old hostapd in RTL8188C_8192C_USB_linux_v4.0.2_9000.20130911 but I do not know if it will work or not as I have not tried it.


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

User avatar
redhenk
Posts: 41
Joined: Wed Feb 20, 2013 9:35 am
Location: Naaldwijk, The Netherlands

Re: D.Link DWA 131 WLAN/USB Adapter not working

Thu Feb 26, 2015 5:52 pm

Mr. Engman,

My RTL8192 works now, but i've still one problem. The powermanagement of the Wifi turns it off after about 20 minutes.
I tried to solve it in /etc/network/interfaces with this line:

Code: Select all

post-up iwconfig wlan0 power off
but then my Wifi turns off directly after booting.

Do you know how to solve it?
Pi B, Pi 2B, Pi zero, Pi 3B

MrEngman
Posts: 4140
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: D.Link DWA 131 WLAN/USB Adapter not working

Thu Feb 26, 2015 6:32 pm

redhenk wrote:Mr. Engman,

My RTL8192 works now, but i've still one problem. The powermanagement of the Wifi turns it off after about 20 minutes.
I tried to solve it in /etc/network/interfaces with this line:

Code: Select all

post-up iwconfig wlan0 power off
but then my Wifi turns off directly after booting.

Do you know how to solve it?
I assume this is the 8192cu driver. If it is try the following.

Edit a file /etc/modprob.d/8192cu.conf using

Code: Select all

sudo nano /etc/modprobe.d/8192cu.conf
and insert the following line

Code: Select all

options 8192cu rtw_power_mgnt=0 rtw_enusbss=0
If it is a different Realtek driver change the text 8192cu to match the driver you use. You will need to reboot after generating the file to make it active.


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

Return to “Troubleshooting”