Posts: 6
Joined: Thu Mar 10, 2016 11:34 am

Re: WiFi Issues ? Start here !

Fri Mar 11, 2016 9:29 am

vollmeise wrote:An update to my previous post...

Connecting the Pi3 and onboard wifi to a different access point (AVM FritzBox 7390) shows none of the described problems with traceroute and ssh! :roll:
So it is the combination of the Pi 3's onboard wifi and the Netgear access point which is making the trouble.
While good to know, it doesn't solve the problem for me (ssh not working in my wlan).
Could this be fixed by a driver update on the Pi 3?

The problem with SSH stopping after auth seems to be a routing problem which would also explain your traceroute troubles. Some questions to determine if this is the case: Do the different access points have different subnets? Like one is and the other Did you ever connect your eth0 to the network where SSH does not work? Does SSH over the Wifi IP work when eth0 is connected?

Posts: 9
Joined: Wed Mar 09, 2016 12:08 pm

Re: WiFi Issues ? Start here !

Fri Mar 11, 2016 11:17 am

Hello pierau

thank you for your reply.
The problem with SSH stopping after auth seems to be a routing problem which would also explain your traceroute troubles.
A routing problem (IP layer) should hit all higher protocol layers (ICMP, UDP, TCP) in the same way. But it is only udp traceroute and ssh which is not working. Both access points work as bridges in the same ip subnet (, so there is no routing involved at all.

Posts: 12
Joined: Wed Aug 15, 2012 7:01 am

Re: WiFi Issues ? Start here !

Fri Mar 11, 2016 11:28 am


I have had trouble with the WiFi on the Pi 3. Problem appeared to be possibly related to chip shutting down and not waking. My Pi would work well while ever it was used regularly but after a couple of hours idle it would no longer respond (difficult since it runs headless).

After turning off power management I no longer have the problem.


User avatar
Posts: 217
Joined: Sun Dec 06, 2015 8:50 pm
Location: Essex, UK

Re: WiFi Issues ? Start here !

Fri Mar 11, 2016 11:47 am

vollmeise wrote:Hello pierau

thank you for your reply.
The problem with SSH stopping after auth seems to be a routing problem which would also explain your traceroute troubles.
A routing problem (IP layer) should hit all higher protocol layers (ICMP, UDP, TCP) in the same way. But it is only udp traceroute and ssh which is not working. Both access points work as bridges in the same ip subnet (, so there is no routing involved at all.
I mentioned this in the other [RPi3] SSH not working via wifi thread, but I'll reiterate here to contribute to this thread; I'm seeing the same behaviour as you with regards to SSH and UDP over WiFi, also using a Netgear router funnily enough (DG834G), no bridging though. The problems do not exist whilst using a smartphone as a hotspot. I've got another wireless router I can test with, but I need to find the power cable first.
Raspberry Pi 3 model B Idle @ 250mA
  • HDMI +200mA
  • Minecraft 1.9 Server +100mA
  • 2.4Ghz dongle +20mA

Posts: 8
Joined: Mon Sep 09, 2013 3:45 pm

Re: WiFi Issues ? Start here !

Fri Mar 11, 2016 6:52 pm

Raspberry Pi model B, all updates and upgrades to Raspbian made today.
StarTech USB2.0 802.11g/n (150WN1X1) wifi dongle.

I configured etc/network/interfaces
and etc/wpa_supplicant/wpa_supplicant.conf
files according to the YouTube Tutorial by 'Circuit Basics'

This resulted in a message "Interface Doesn't Support Scanning"
once I'd entered the line sudo iwlist wlan0 scan | grep ESSID.

After iwconfig, it said No Wireless Extensions

??? I'm lost :)

Posts: 2
Joined: Mon Feb 08, 2016 11:16 pm

Re: WiFi Issues ? Start here !

Fri Mar 11, 2016 11:22 pm

In regard to to turning off the Power Management of the internal Wireless..

I opened the /etc/network/interfaces file and added the 'wireless-power off' under the wlan0 interface.

Upon rebooting, the power management was off. I could not get the wlan0 script on /etc/network/if-up.d to work and make sure I had the proper script, syntax as well ability to run the script. Not sure if I did anything wrong but what I did seems easier maybe.

sudo nano /etc/network/interfaces
find the wlan0 interface in the block
place the 'wireless-power off' line below the iface wlan0 call
ensure your settings are correct and hit CTL+X and when prompted to save hit enter

Here is my 'interfaces' file now:

Code: Select all

# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

iface eth0 inet manual

allow-hotplug wlan0
iface wlan0 inet manual
    wireless-power off
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

allow-hotplug wlan1
iface wlan1 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
After removing the other attempts and rebooting several times; it appears to be disabling for me on boot up just fine.

Hope this works for others!

Posts: 6
Joined: Sun Aug 16, 2015 11:07 pm

Re: WiFi Issues ? Start here !

Sun Mar 13, 2016 1:34 am

I have an application where I'm using the PI as a method of tunneling into my office. Basically, my laptop THINKS its actually in my office at the ethernet level, but the PI is actually eavesdropping on my Ethernet, sending packets inside of TCP packets, unpacking them when they arrive, and sending them out stamped with my laptop's ehternet address, so that the office end is non the wiser. I do the same in the opposite direction. I made this work on TCP/80 since I noticed some hotels I stay in only seem to pass web browser traffic and not things like VPN. I wanted a solution I could expect to work any place there is wifi available. For this to work in a hotel, I need the PI to be able to log into a foreign wifi access point. I don't have a monitor/keyboard/mouse ... just the PI connected to my laptop's ethernet port by a little stub of an ethernet cable. Upon boot-up, I can ssh into the PI and have full command line interface access. I can't find a way to tell what wifi ssid's area available much less get attached to them. I can't get "iwlist wlan0 scan" to work ... it says interface does not support scanning. I've heard of nmcli, but can't seem to find it for my PI. If I can't even see the hotels wifi, I can't connect to it. Can someone help me get that far at least? In the next step, I'd have to authenticate to get attached, and although some hotels give you a wifi password that you could install in the appropriate config file along with the ssid (which they MIGHT be able to tell you depending on how savvy the staff are) often you need a browser to type in some things to authenticate ... 'not sure how to handle that, unless there's some sort of text bassed browser available for the pi that would work in a terminal window. In a pinch, I suppose I might be able to run Xwindows on the laptop and get a full GUI interface to the PI, but I'd prefer not to have to revert to that. 'any ideas?

Posts: 6
Joined: Sun Aug 16, 2015 11:07 pm

Re: WiFi Issues ? Start here !

Sun Mar 13, 2016 1:42 am

Regarding my previous post - I managed to sort out command to show nearby access points, to that portion is solved. However I still need to sort out all the other issues I asked for help with. Thanks.

Posts: 1
Joined: Mon Mar 14, 2016 2:29 pm

Re: WiFi Issues ? Start here !

Mon Mar 14, 2016 2:34 pm

Disabling power saving also immediately fixed the issues I was seeing:
  • Slow response time in SSH, making typing frustrating
  • Inconsistent ping time to my router, jumping from 10ms to 1000ms
Thank you!
overskilling wrote:Just the command

iwconfig wlan0 power off

was sufficient without the update on a new Pi3. This fixed the hanging (sleeping) and PING times improved dramatically.

Thanks for the help.

Posts: 1
Joined: Mon Mar 14, 2016 11:32 pm

Wifi Connection Issues w/ Raspberry Pi 3

Mon Mar 14, 2016 11:39 pm

Recently bought Raspberry Pi 3 and got everything set up, SD card downloaded, went to connect to wifi, typed in password and nothing happened. I followed the original post's instructions to no avail. Not sure if this matters, but my Wifi network does show up on display, but it does not have the wifi bars symbol, just a computer icon.

I tried hooking up an Ethernet cord to the raspberry and that did not work as well.

Any help would be appreciated as I have no idea what else to do.


Posts: 3
Joined: Mon Aug 10, 2015 8:39 am

Re: WiFi Issues ? Start here !

Tue Mar 15, 2016 11:28 am

Arakun wrote:TL;DR: My D-Link DWA-131 wifi dongle has stopped working and I'm starting to suspect it's broken but I want some feedback before taking it back to the store.
Going to try and answer my own question here. I think my problem stems from the sheer amount of wireless networks where I live. Large building with tons of small apartments, each with its own wifi. My iMac picks up about 20 of them, the Pi around 10. I decided to get a Pi 3 and it shows similar behaviour: managing to connect every once in a while and then dropping the connection after a minute or so. Finding an unused channel helped a little bit it's still too unstable. Moving closer to the router solves the problem though. At least I now know that my wifi dongle isn't broken.

Posts: 8
Joined: Tue Mar 15, 2016 11:16 am

Re: WiFi Issues ? Start here !

Tue Mar 15, 2016 11:48 am

Hi Raspberry Pi fans!

I got two Raspberry's a Pi2 and a Pi Zero, both running on Jessie for Domoticz.

Unfortunately the Wifi on both devices drop very often, which is a pain as both are remote devices.

There are many scripts online available for securing the connection (no connection --> reboot of the system or reboot of the lan adapter)

Could someone please help me?

The script below I would like to uses, however it does not restart my system when connection is lost. Do you guys maybe know what I do wrong? I am really at the end of my options/ideas resolving this issue.

Script used (saved under /usr/local/bin/checkwifi.sh and chmodded to 755), which does not result in a restart of the system when connection is lost.

Code: Select all

ping -c4 > /dev/null
if [ $? != 0 ] 
  sudo /sbin/shutdown -r now

Line added in Crontab -e:

Code: Select all

*/5 * * * * /usr/bin/sudo -H /usr/local/bin/checkwifi.sh >> /dev/null 2>&1

Posts: 112
Joined: Wed Dec 30, 2015 9:04 pm
Location: Winnipeg, Canada

Re: WiFi Issues ? Start here !

Wed Mar 16, 2016 12:45 am


I've tried the steps mentioned for creating /etc/network/if-up.d/wlan0 and they don't work for me. I checked the filename, that it is executable and that the command is correct several times. If I enter the ifconfig command from the command line or use sudo to execute the file it works fine. But if I shutdown, pull the plug to remove power and start up again it doesn't work. Any suggestions as what to do? Is there any way to disable the onboard wireless adapter?


Posts: 112
Joined: Wed Dec 30, 2015 9:04 pm
Location: Winnipeg, Canada

Re: WiFi Issues ? Start here !

Wed Mar 16, 2016 1:07 am


It appears that putting the post-up iwconfig wlan0 power off command in /etc/network/interfaces works for me.

Thanks for posting this tip.


Posts: 27
Joined: Fri Sep 04, 2015 10:05 am

Re: WiFi Issues ? Start here !

Thu Mar 17, 2016 7:51 pm

A nice guide!
I have problem with getting my wifi to run.
I can get the list from iwlist, and I can see the access point.
I have incuded SSID and PSK in the wpa_supplicant.conf
But when running sudo ifup wlan0 I got the error
"failed to bring up wlan0"

Somewhere I also lost dhscpcd, which was running before I started to edit the conf - files.

Any tips?


Posts: 5
Joined: Sun Oct 04, 2015 6:23 am

Re: WiFi Issues ? Start here !

Fri Mar 18, 2016 6:00 am


I have an Edmiax EW-7811UAC that I'm trying to use with a Raspberry Pi 2. The interface comes up, but no IP address is assigned. I've had this working OK with another adapter, one of the WiPi dongles, so am pretty sure the configuration files are OK. I got the drivers from https://github.com/gnab/rtl8812au and they appeared to compile and install fine, and also appear in lsmod.

The main issue is in dmesg, in particular the line

IPv6: ADDRCONF(NETDEV_UP): wlan3: link is not ready

the full dmesg result for unplugging/replugging the adapter are

Code: Select all

[ 3429.269713] usb 1-1.5: new high-speed USB device number 6 using dwc_otg
[ 3429.358663] usb 1-1.5: New USB device found, idVendor=7392, idProduct=a812
[ 3429.358685] usb 1-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 3429.358701] usb 1-1.5: Product: Edimax AC600 USB
[ 3429.358716] usb 1-1.5: Manufacturer: Realtek
[ 3429.358731] usb 1-1.5: SerialNumber: 00e04c000001
[ 3429.576514] rtl8812au 1-1.5:1.0 wlan3: renamed from wlan0
[ 3429.582806] systemd-udevd[2711]: renamed network interface wlan0 to wlan3
[ 3430.001073] IPv6: ADDRCONF(NETDEV_UP): wlan3: link is not ready
[ 3430.006221] RTL871X: indicate disassoc
[ 3430.009214] IPv6: ADDRCONF(NETDEV_UP): wlan3: link is not ready
[ 3430.014864] RTL871X: set bssid:00:00:00:00:00:00
[ 3430.015078] RTL871X: set ssid [\x05\xffffffef\xfffffff7] fw_state=0x00000008
[ 3436.017467] RTL871X: nolinked power save enter
and lsmod shows

Code: Select all

Module                  Size  Used by
cfg80211              376661  0
bnep                   17650  2
rfcomm                 50085  0
bluetooth             353080  10 bnep,rfcomm
rfkill                 19527  4 cfg80211,bluetooth
binfmt_misc            12907  1
snd_soc_bcm2708_i2s    13257  0
bcm2708_rng            12445  0
snd_bcm2835            27675  0
snd_pcm_oss            44475  0
snd_mixer_oss          21946  1 snd_pcm_oss
regmap_mmio            12858  1 snd_soc_bcm2708_i2s
snd_soc_core          143741  1 snd_soc_bcm2708_i2s
snd_compress           17520  1 snd_soc_core
snd_pcm_dmaengine      12927  1 snd_soc_core
snd_seq_dummy          12465  0
snd_seq_oss            32826  0
snd_seq_midi           12782  0
snd_seq_midi_event     13200  2 snd_seq_oss,snd_seq_midi
snd_rawmidi            22437  1 snd_seq_midi
8812au                873896  0
snd_seq                56145  6 snd_seq_midi_event,snd_seq_oss,snd_seq_dummy,snd_seq_midi
snd_seq_device         13056  5 snd_seq,snd_rawmidi,snd_seq_oss,snd_seq_dummy,snd_seq_midi
snd_pcm                75238  4 snd_bcm2835,snd_pcm_oss,snd_soc_core,snd_pcm_dmaengine
snd_timer              26560  2 snd_pcm,snd_seq
snd                    51707  11 snd_bcm2835,snd_pcm_oss,snd_soc_core,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_seq_oss,snd_seq_device,snd_compress,snd_mixer_oss
spi_bcm2708            12686  0
i2c_bcm2708            12672  0
cuse                   12913  0
fuse                   78744  3 cuse
At the moment I power the Pi with a 3.1A 5V power plug, and have entered the line max_usb_current=1 in config.txt, thinking that this may be a power issue. I have been thinking pf making a splitter cable to power the adapter directly from 5V while running its data lines to the Pi (not running the 5V back into the Pi's USB port !)


Code: Select all

# interfaces(5) file used by ifup(8) and ifdown(8)
# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
auto eth0
iface eth0 inet static

auto wlan3
iface wlan3 inet dhcp
#wpa-driver wext
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
allow-hotplug wlan3

#auto wlan0
#       iface wlan0 inet dhcp
#       wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf

#####allow-hotplug wlan0
#auto wlan0
#iface wlan0 inet dhcp
#   wpa-ssid birdsnets
#   wpa-psk uhuh1wVOQR
#   #wireless-mode managed
#   #wireless-key "uhuh1wVOQR"

# alt method
 #auto wlan0
 #iface wlan0 inet dhcp
 #wpa-driver wext
 #wpa-conf /etc/wpa_supplicant.conf

### for AP
##auto wlan2
#iface wlan2 inet static
#allow-hotplug wlan2
##iface default inet manual
and wpa_supplicant.conf

Code: Select all


proto=WPA RSN
pairwise=CCMP TKIP

Thanks for any help with this, it'd be much appreciated.


Posts: 1
Joined: Fri Mar 18, 2016 9:51 am

Re: WiFi Issues ? Start here !

Fri Mar 18, 2016 10:20 am

I wasn't allowed to acces the wlan0 file. I did it this way:

Code: Select all

cd /etc/network/if-up.d/
sudo nano wlan0
I then wrote the command (iwconfig wlan0 power off)
saved (ctrl-o) and quit (ctrl-x)


User avatar
Posts: 4
Joined: Sat Mar 19, 2016 5:57 am
Location: 12S VA 868 817

Re: WiFi Issues ? Start here !

Sat Mar 19, 2016 6:41 am

Not sure if this helps or not, as I have my own Linux build - but it is built on top of the Raspbian/Jessie Lite install and I have been running wlan0 with no problems, SSH seems fine and it does not drop the connection. I use NetworkManager in my build BTW.

Try this?



Go into /etc/network/interfaces and comment out (#) any/all network connection except for the loopback (lo)

Then go to /etc/NetworkManager/networkmanager.conf and change "managed=false" to "managed=true"


ETA: Well, I grabbed the NOOBS install image this morning to check - I guess Raspbian does not use NetworkManager :/
Screenshot - 03182016 - 10_51_05 PM.png
Screenshot - 03182016 - 10_51_05 PM.png (18.59 KiB) Viewed 41457 times
Laeti Vescimur Nos Subacturis

Posts: 3
Joined: Sun Mar 20, 2016 7:50 am

Re: WiFi Issues ? Start here !

Sun Mar 20, 2016 9:29 am

Hi there guys.

Having some issues connecting my pi 3 to my wireless network. It can connect to wireless as I can connect to my neighbours open wifi network but it will not accept the password to my network.

I can see my network in the listing but it appears in a strange way, for example:


where my network is Network 3. It appears without the quotation marks and slashes on all my other devices. Would anyone please be able to point me in the right direction?

User avatar
Posts: 22
Joined: Sat Jul 21, 2012 3:11 am

Rp3 connected, not getting set up by router

Sat Mar 26, 2016 9:33 pm

I had the same problem with my network password not being accepted using the window interface.

Figured that one out by going to menu -> preferences -> raspberry configuration (going off memory here, might not be exactly right) and setting wifi country.

Now it's connected but not getting set up by the router with an address to my network, etc

As you can see below, eth(cabled) has gotten the correct address assigned by the router, 198.162.1.~ but wlan (wireless) has not

Code: Select all

pi@James-Rpi:~ $ iwconfig
wlan0     IEEE 802.11bgn  ESSID:"tanstaafl"
          Mode:Managed  Frequency:2.412 GHz  Access Point: 00:18:01:FB:04:CD
          Bit Rate=54 Mb/s   Tx-Power=1496 dBm
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=64/70  Signal level=-46 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0.

pi@Rpi:~ $ ifconfig
eth0      Link encap:Ethernet  HWaddr b8:27:eb:d5:d5:56
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::1293:683f:afe6:6300/64 Scope:Link
          RX packets:64728 errors:0 dropped:55 overruns:0 frame:0
          TX packets:19123 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:83907722 (80.0 MiB)  TX bytes:2429190 (2.3 MiB)

lo        Link encap:Local Loopback
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:424 errors:0 dropped:0 overruns:0 frame:0
          TX packets:424 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:34800 (33.9 KiB)  TX bytes:34800 (33.9 KiB)

wlan0     Link encap:Ethernet  HWaddr b8:27:eb:80:80:03
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::ba27:ebff:fe80:8003/64 Scope:Link
          RX packets:542 errors:0 dropped:542 overruns:0 frame:0
          TX packets:110 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:180429 (176.2 KiB)  TX bytes:28289 (27.6 KiB)

Question: linux != tanstaafl ?

Posts: 1
Joined: Sun Mar 27, 2016 1:08 pm

Re: WiFi Issues ? Start here !

Sun Mar 27, 2016 1:13 pm

Ok, I'm running xbmc on the raspberry pi 3 and everything was working fine. Then the wifi signal got weak then disappeared altogether. I'm seeing a lot of code for turning off power management which is great, because I hope it works. However, I have no idea how or where to write that code in. Does anyone know of a YouTube video that shows it or was there a post I missed taking me step by step on how to do it? Any help would be much appreciated.

Posts: 5
Joined: Sun Mar 27, 2016 7:26 pm

Re: WiFi Issues ? Start here !

Sun Mar 27, 2016 8:35 pm

I just purchased my second RPI 2, this time as CanaKit RPI 2 from Amazon (first RPI 2 I purchased as individual parts, not a kit).

The WiFi on the new RPI 2 is broken.
The WiFi on my first RPI 2 works reliably!

I am using the latest Raspbian, just downloaded and installed yesterday, I did apt-get update and apt-get upgrade just today, otherwise I have not done anything else with that system yet. Can't do anything until my WiFi works reliably like my first RPI 2.

After extensive reading of on-line articles and comments for days, and a huge number of experiments, I've concluded the following:

1. WiFi on the RPI 2 is broken!
2. My first RPI 2, purchased about 10 months ago, has reliable WiFi, the new one does not. For my tests, I used the same Edimax dongle--works on my first RPI 2, does not work reliably on my new RPI2.
3. If I boot with wired Ethernet and the Edimax dongle (that's known to work) plugged in, both the wired Ethernet and wlan0 successfully come up. I can remove the wire and the WiFi continues to work. I've done it multiple times and that is a fairly reliable operation.
4. If I remove the Ethernet wire and reboot with the dongle only, most times WiFi will not work. After numerous experiments, it will occasionally work, but it is unreliable.
5. It appears that there is some sort of dependency between the wired Ethernet and the WiFi dongle.
6. After a failure with WiFi, it may take more than one reboot to get wired Ethernet to work again. But WiFi will work reliably only when the Ethernet wire is plugged in (I get 2 IP addresses).
7. When WiFi fails to come up, the system keeps trying to bring up the interface but unsuccessfully. When I execute: tail -f /var/log/kern.log
the most obvious error that sticks out is:
Mar 27 15:15:13 raspberrypi kernel: [ 9.337973] smsc95xx 1-1.1:1.0 eth0: hardware isn't capable of remote wakeup
This keeps repeating over and over.
8. Wired only Ethernet seems to work OK most times, occasionally I need more than one reboot to get it up.
9. In researching this issue on-line, WiFi seems to be a huge problem for may users and probably stifles lots of people from innovating and working with the RPIs. It is also a big time killer, and may be the single biggest hurdle in working with the Pi. Because posts are from different time periods, I can't tell whether this problem is recent or has been there all along.
10. Improving the networking/ WiFi interface may be the most important ROI effort for the foundation!

After spending a huge amount of time on this, I am almost ready to send the kit back unless I can figure out how to fix the WiFi.

I would appreciate your thoughts on this.

Posts: 1184
Joined: Thu Jan 30, 2014 9:53 am

Re: WiFi Issues ? Start here !

Tue Mar 29, 2016 8:54 am

It might be due to the Jessie WiFi power handling bug.
If you go up this thread a bit you will find a discussion about the stupid way the WiFi is being hanled visavi power and also the solution to it.
This might be what you need to get the system running properly.
I have added an entry into the /etc/rc.local script (at the bottom) to make sure that power management is kept off also after a reboot.

Code: Select all

#Make sure WiFi power management stays off
sleep 10
iwconfig wlan0 power off
Bo Berglund

Posts: 53
Joined: Fri Jan 15, 2016 9:26 pm

Re: WiFi Issues ? Start here !

Wed Mar 30, 2016 11:35 pm

RPi3: On top of the problem with channel 12/13 (country = gb), it doesn't work on channel 11 (country = us)
I've given up. Does anyone know how to disable the on-board WiFi module? I'm going back to my old Edimax USB dongle.

User avatar
Forum Moderator
Forum Moderator
Posts: 4257
Joined: Mon Jan 09, 2012 3:16 pm
Contact: Website

Re: WiFi Issues ? Start here !

Wed Mar 30, 2016 11:38 pm

dchao99 wrote:RPi3: On top of the problem with channel 12/13 (country = gb), it doesn't work on channel 11 (country = us)
It should do. What does "iwlist freq" say?

Return to “Troubleshooting”