statisticalonion
Posts: 6
Joined: Sun Aug 31, 2014 6:12 am

Static when using earbuds

Sun Aug 31, 2014 6:21 am

I am fairly new to the raspberry pi so please try to be patient with me :) Anyways I have a problem with my raspberry pi b+. When I try to watch videos or listen to music using my Apple earbuds and running omxplayer, there is static noise in the background, but not loud enough to drown anything out and can only be heard when there is a pause in the song/movie. This issue isn't present when I plug in regular speakers, so it can't be a problem with the audio. I am using Raspbian (is that what wheezy is?) Thanks for reading and any help would be appreciated :)

jdb
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 2688
Joined: Thu Jul 11, 2013 2:37 pm

Re: Static when using earbuds

Sun Aug 31, 2014 2:24 pm

Does the static reduce or change intensity if you add

Code: Select all

disable_audio_dither=1
to /boot/config.txt?
Rockets are loud.
https://astro-pi.org

statisticalonion
Posts: 6
Joined: Sun Aug 31, 2014 6:12 am

Re: Static when using earbuds

Sun Aug 31, 2014 5:40 pm

Thanks for the fast reply.

Unfortunately I can't find the disable_audio_dither in the config.txt, even when I use ctrl+W.

It is probably worth noting that I do notice some static on my normal speakers too when I turn the volume high enough.

User avatar
DougieLawson
Posts: 42142
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK

Re: Static when using earbuds

Sun Aug 31, 2014 5:42 pm

Add it in as a new line at the bottom of the file.

sudo sh -c 'echo "disable_audio_dither=1" >> /boot/config.txt'
Languages using left-hand whitespace for syntax are ridiculous

DMs sent on https://twitter.com/DougieLawson or LinkedIn will be answered next month.
Fake doctors - are all on my foes list.

The use of crystal balls and mind reading is prohibited.

statisticalonion
Posts: 6
Joined: Sun Aug 31, 2014 6:12 am

Re: Static when using earbuds

Sun Aug 31, 2014 6:01 pm

Thank you for your prompt reply.

Unfortunately adding the configuration does make the static slightly worse.

drgeoff
Posts: 12880
Joined: Wed Jan 25, 2012 6:39 pm

Re: Static when using earbuds

Sun Aug 31, 2014 6:37 pm

For best results, always run apps or alsamixer or whatever with the volume control at maximum. Adjust to the required listening level after the RPi's output. Yes that isn't so easy when using headphones plugged directly into the RPi. :(
Quis custodiet ipsos custodes?

fruitoftheloom
Posts: 27225
Joined: Tue Mar 25, 2014 12:40 pm

Re: Static when using earbuds

Sun Aug 31, 2014 8:00 pm

drgeoff wrote:For best results, always run apps or alsamixer or whatever with the volume control at maximum. Adjust to the required listening level after the RPi's output. Yes that isn't so easy when using headphones plugged directly into the RPi. :(
Use headphone with an in-line volume control !
Take what I advise as advice not the utopian holy grail, and it is gratis !!

statisticalonion
Posts: 6
Joined: Sun Aug 31, 2014 6:12 am

Re: Static when using earbuds

Sun Aug 31, 2014 8:01 pm

Unfortunately I do not have a in line volume control, so I was hoping if there was a software fix to this issue.

User avatar
mahjongg
Forum Moderator
Forum Moderator
Posts: 14472
Joined: Sun Mar 11, 2012 12:19 am
Location: South Holland, The Netherlands

Re: Static when using earbuds

Sun Aug 31, 2014 8:04 pm

the analog audio output of a B+ isn't capable of driving low impedance devices like earbuds or headphones, only high impedance devices like audio amplifiers. Overloading the output with a low impedance, will indeed cause distortions.

statisticalonion
Posts: 6
Joined: Sun Aug 31, 2014 6:12 am

Re: Static when using earbuds

Sun Aug 31, 2014 11:58 pm

Thanks for your replies.

I have 2 more questions:
-Is this a software issue or a hardware issue?
-Would using the XMBC (I think thats the name) fix this? I heard it the problem doesn't exist using that player.

User avatar
mahjongg
Forum Moderator
Forum Moderator
Posts: 14472
Joined: Sun Mar 11, 2012 12:19 am
Location: South Holland, The Netherlands

Re: Static when using earbuds

Mon Sep 01, 2014 12:14 am

it (the output not being able to drive a 32 Ohm source) is a hardware issue, nothing you can do with software can change it.
so nothing to do with XMBC either!

statisticalonion
Posts: 6
Joined: Sun Aug 31, 2014 6:12 am

Re: Static when using earbuds

Mon Sep 15, 2014 1:51 pm

Sorry for reviving a old thread, but what exactly is the max volume in omxplayer? Is it 0.00 db?

Pengi
Posts: 1
Joined: Sun Sep 11, 2016 8:12 pm

Re: Static when using earbuds

Sun Sep 11, 2016 8:15 pm

statisticalonion wrote:Sorry for reviving a old thread, but what exactly is the max volume in omxplayer? Is it 0.00 db?
Yes. You can use

Code: Select all

omxplayer --vol "n" file.mp3
where n is a value between -6000 and 0. This corresponds to a value between -6000 and 0 millidecibel (mdB)

Return to “Troubleshooting”