Posts: 1
Joined: Sat Aug 10, 2019 5:57 pm

4G Module SIM7600 has modem

Sat Aug 10, 2019 6:11 pm

Hello everybody,

It's my first post here as i've always managed to do everthing needed with my raspberry pi's installation till now.
I've founded a lot of tutorial and info on the internet but here i'am stuck at a installation where i'm missing a part of something.

This is for my degree in IT so i realy need this SIM7600 module to work as expected.

My problem is, that i can't connect the SIM 7600 to work as a modem for my pi and use it to have a IP adresse from my phone provider.
The module is working as i'm able to make phone call through the pi.

I've followed this ... 4#p1450784

But i'have no /dev/cdc-wdm0

Then i've tried this with ppp:
but again not ppp0 interface when i do ifconfig

Does somebody know how to have this /dev/cdc-wdm0 listed in my /dev/ ?
The SIM7600 is working as i can make phone call, but no way to use it as a modem.

The SIM7600 is plug through GPIO, i've added a second supply through usb port and jumper are set to B, serial is enable as i see ttyS0 and can connect to it.

What am i missing. How to have this cdc-wdm0 device listed and this wwan0 like in the fisrt link?
Do i need to plug the SIM7600 in an other way or change the jumper or user usb to UART ?

Thank you for all the help, i'm lost at the moment in all that stuff.

Posts: 2
Joined: Mon Sep 02, 2019 3:42 am

Re: 4G Module SIM7600 has modem

Mon Sep 02, 2019 4:07 am

Hi there,

Not sure if you have solved the issue, but I think it is due to your connection. You should connect the SIM7600 via GPIO and USB to your Raspberry Pi. GPIO for the AT commands and the USB for the data connection as stated by mkrzysztofowicz in a later post.
mkrzysztofowicz wrote:
Mon Apr 29, 2019 12:45 pm

My setup uses the serial port only for control (i.e. sending the AT commands). The actual data connection goes via the USB port on the HAT. Also, make sure you use the correct USB port - on my HAT I use the micro USB port on the opposite edge of the HAT than the 40-pin header (i.e. NOT the one labeled USB TO UART).

Posts: 5
Joined: Mon Oct 16, 2017 12:48 am

Re: 4G Module SIM7600 has modem

Sun Oct 20, 2019 6:31 pm

I am having the same issue. I can send commands via minicom but cannot get it to show up in ifconfig. I'm using a pi2b so my serial is is ttyAMA0. Did you ever find a solution?

Posts: 1
Joined: Wed Nov 20, 2019 2:21 am

Re: 4G Module SIM7600 has modem

Wed Nov 20, 2019 2:25 am

Any updates on this? I have the exact same issue. Might be a problem with the kernel?

Thanks a lot for your help and kind regards!

Posts: 1
Joined: Sun Dec 01, 2019 3:57 pm

Re: 4G Module SIM7600 has modem

Sun Dec 01, 2019 4:10 pm

I've done it by reinstalling raspbian. I don't know why but I think there are some mistakes on my system. After that I try to insert the module on raspberry pi, connect USB port (not UART one) of module to raspberry pi, move both of yellow jumpers to A. Then check if there is /dev/cdc-wdm0 or not (I think it makes wwan0 available too).

Return to “Advanced users”