F2b
Posts: 4
Joined: Fri Sep 17, 2021 7:33 pm
Location: France/Estonia

Can't connect RPi directly to the ISP WAN

Sat Sep 18, 2021 3:32 pm

Hi everybody!

I'm currently making a few tests with my new Pi 4, to see if it could possibly be used as a router (in my particular use case), as well as a few other things.
Note that I have an Ethernet cable coming directly into my apartment from my ISP.
However, the Pi doesn't seem to be able to establish a connection through this cable. That's why I'm coming to you, in case someone can help me troubleshoot this.

So, at first, I flashed OpenWrt (to a USB thumb, as I didn't have an SD card reader available) and plugged the ISP Ethernet cable directly to the Pi. I managed to set the wlan0 access point as the only LAN device (used to connect to the web UI and SSH), and to configure the Ethernet port as WAN with PPPoE. I put the credentials given by my ISP. However, it doesn't connect, and I noticed that the LEDs of the Ethernet port were off.

Second experiment: I added a cheap router (TP-Link TL-WR844N) to connect to my ISP (still via PPPoE), and I linked that router to the Pi Ethernet port:

Code: Select all

----- ISP eth -----> TP-Link router WAN port
                     TP-Link router LAN port <------ Ethernet ------> RPi eth port (WAN, DHCP)
The Ethernet port on the Pi is set as WAN port, but is configured as a DHCP client (since the PPPoE is handled by the TP-Link router).
Now, I'm able to access the Internet by connecting to the Pi's Wi-Fi access point.

Third experiment: Same as above, but with Raspberry Pi OS. And same results:
- ISP cable connected directly to the Pi --> no light on the Ethernet port.
- ISP to TP-Link router, and then LAN from router to Pi --> of course it works.

Logs:
I'm not sure if it will help, but when I try to restart the interface in OpenWrt when connected diretly to the ISP cable, here is what I get:

Code: Select all

Tue Sep 14 15:22:45 2021 daemon.notice netifd: Interface 'wan' is disabled
Tue Sep 14 15:22:45 2021 kern.warn kernel: [  161.205702] bcmgenet: Skipping UMAC reset
Tue Sep 14 15:22:45 2021 kern.info kernel: [  161.210870] bcmgenet fd580000.ethernet: configuring instance for external RGMII
Tue Sep 14 15:22:45 2021 kern.info kernel: [  161.218705] bcmgenet fd580000.ethernet eth0: Link is Down
Tue Sep 14 15:22:45 2021 kern.info kernel: [  161.229765] device eth0 entered promiscuous mode
Tue Sep 14 15:22:45 2021 daemon.notice netifd: Interface 'wan' is enabled
I didn't find anything else potentially related to this problem in the logs.

I have no idea on how to solve this, so if anyone has a potential solution or anything that could help troubleshooting this, it would be greatly appreciated.
Please let me know if you need additional information.
Thank you for your time!

pcmanbob
Posts: 11784
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: Can't connect RPi directly to the ISP WAN

Sun Sep 19, 2021 2:53 pm

HI.

As your problem seems to be with connecting OpenWrt running on the pi ( noted actual router will connect to ISP no problem )

then I suggest you ask for help from the providers of OpenWrt on their support forum .. https://forum.openwrt.org/
We want information… information… information........................no information no help
The use of crystal balls & mind reading are not supported

F2b
Posts: 4
Joined: Fri Sep 17, 2021 7:33 pm
Location: France/Estonia

Re: Can't connect RPi directly to the ISP WAN

Sun Sep 19, 2021 2:56 pm

Thank you for that suggestion, I will probably do so.

However, it seems like I have the same problem in Raspberry Pi OS too...

pcmanbob
Posts: 11784
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: Can't connect RPi directly to the ISP WAN

Sun Sep 19, 2021 2:57 pm

F2b wrote:
Sun Sep 19, 2021 2:56 pm
Thank you for that suggestion, I will probably do so.

However, it seems like I have the same problem in Raspberry Pi OS too...
Raspberry Pi OS will not work as a router out of the box, you would need to set it up as such , which is what OpenWrt does.
We want information… information… information........................no information no help
The use of crystal balls & mind reading are not supported

epoch1970
Posts: 7035
Joined: Thu May 05, 2016 9:33 am
Location: France

Re: Can't connect RPi directly to the ISP WAN

Sun Sep 19, 2021 4:31 pm

Your cheap router uses Fast Ethernet.
I understand Pi4 has a problem with partners that advertise gigabit speed over non-giga Ethernet cabling, i.e. cables with only 2 pairs of wires in them, and not 4 pairs.

Check your cable, are the ends fully populated with wires, like this?
https://commons.wikimedia.org/wiki/File ... _568_B.svg
If not, get another one.

If yes, the building cabling may be at fault, and the infrastructure switch you’re connected to set to advertise gigabit capability when it shouldn’t.
Perhaps setting the Pi’s interface to fast Ethernet can help in this case?
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

F2b
Posts: 4
Joined: Fri Sep 17, 2021 7:33 pm
Location: France/Estonia

Re: Can't connect RPi directly to the ISP WAN

Thu Sep 23, 2021 10:38 am

@epoch1970

Sorry, iI took some time to answer. Was planning to do some testing, but I don't really know how to proceed...

The cable coming from outside into my apartment is a gigabit cable (Cat 5e, it has all 8 wires). Btw, even though my internet plan is 100 Mbps, the ISPs also offer higher speeds, so the cable should definitely be gigabit anyway.
That being said, that cable is not in perfect condition. When the technician activated the connection a few weeks ago he supposedly did some tests to verify that things were working properly, but who knows.
I'm not sure how to disable autonegociation and force 100Mbps; should I use ethtool? I'll try that tomorrow.
Last edited by F2b on Thu Sep 23, 2021 2:19 pm, edited 1 time in total.

Cloudcentric
Posts: 1277
Joined: Fri Sep 14, 2012 9:13 am

Re: Can't connect RPi directly to the ISP WAN

Thu Sep 23, 2021 11:36 am

F2b wrote:
Thu Sep 23, 2021 10:38 am
@epoch1970

Sorry, iI took some time to answer. Was planning to do some testing, but I don't really know how to proceed...

The cable coming from outside into my apartment is a gigabit cable (Cat 5e, it has all 8 wires).Btw, even though my internet plan is 100 Mbps, the ISPs also offer higher speeds, so the cable should definitely be gigabit anyway.
That being said, that cable is not in perfect condition. When the technician activated the connection a few weeks ago he supposedly did some tests to verify that things were working properly, but who knows.
I'm not sure how to disable autonegociation and force 100Mbps; should I use ethtool? I'll try that tomorrow.


Though you state your ISP gives you a RJ45 Connection, how does your ISP Authorise who is connected ?? Captive Portal ??
.
.

F2b
Posts: 4
Joined: Fri Sep 17, 2021 7:33 pm
Location: France/Estonia

Re: Can't connect RPi directly to the ISP WAN

Thu Sep 23, 2021 1:52 pm

Cloudcentric wrote:
Thu Sep 23, 2021 11:36 am
Though you state your ISP gives you a RJ45 Connection, how does your ISP Authorise who is connected ?? Captive Portal ??
PPPoE. They gave me credentials.

EDIT: Quick follow-up

Code: Select all

ethtool -s eth0 speed 100 duplex full autoneg off
After setting the eth0 port to FastEthernet with the previous command, the RaspberryPi (OpenWrt) is able to connect to the Internet.
Since my plan is 100Mbps I'll keep this setting for now, and ask my ISP about it.

Return to “Networking and servers”