dr.sputnik
Posts: 2
Joined: Thu Aug 30, 2018 3:31 pm

PoE HAT Fan Speed adjustment

Thu Aug 30, 2018 4:01 pm

Hi,

I saw the notes in ETA for Official POE Hat for 3B+, and decided to try this on one of mine.

After editing, compiling and copying over the file to the overlays folder, the fan no longer works. Also the faint high pitch noise made by the PoE HAT during boot is absent. Copying the original overlay file back and rebooting results in it all working again.

I downloaded the code from https://github.com/raspberrypi/linux/ra ... verlay.dts and edited it as follows:

Code: Select all

pi@dtc1:~/fan-control $ cat rpi-poe-overlay.dts
/*
 * Overlay for the Raspberry Pi POE HAT.
 */
/dts-v1/;
/plugin/;

/ {
        compatible = "brcm,bcm2708";

        fragment@0 {
                target-path = "/";
                __overlay__ {
                        fan0: rpi-poe-fan@0 {
                                compatible = "raspberrypi,rpi-poe-fan";
                                firmware = <&firmware>;
                                cooling-min-state = <0>;
                                cooling-max-state = <3>;
                                #cooling-cells = <2>;
                                cooling-levels = <0 50 150 255>;
                                status = "okay";
                        };
                };
        };

        fragment@1 {
                target = <&cpu_thermal>;
                __overlay__ {
                        trips {
                                threshold: trip-point@0 {
                                        temperature = <50000>;
                                        hysteresis = <5000>;
                                        type = "active";
                                };
                                target: trip-point@1 {
                                        temperature = <55000>;
                                        hysteresis = <2000>;
                                        type = "active";
                                };
                                cpu_hot: cpu_hot@0 {
                                        temperature = <60000>;
                                        hysteresis = <2000>;
                                        type = "active";
                                };
                        };
                        cooling-maps {
                                map0 {
                                        trip = <&threshold>;
                                        cooling-device = <&fan0 0 1>;
                                };
                                map1 {
                                        trip = <&target>;
                                        cooling-device = <&fan0 1 2>;
                                };
                                map2 {
                                        trip = <&cpu_hot>;
                                        cooling-device = <&fan0 2 3>;
                                };
                        };
                };
        };
};
pi@dtc1:~/fan-control $
and then ran:

Code: Select all

dtc -@ -I dts -O dtb -o rpi-poe.dtbo rpi-poe-overlay.dts
That command produces warnings:

Code: Select all

pi@dtc1:~/fan-control $ dtc -@ -I dts -O dtb -o rpi-poe.dtbo rpi-poe-overlay.dts
rpi-poe.dtbo: Warning (unit_address_vs_reg): Node /fragment@0 has a unit name, but no reg property
rpi-poe.dtbo: Warning (unit_address_vs_reg): Node /fragment@0/__overlay__/rpi-poe-fan@0 has a unit name, but no reg property
rpi-poe.dtbo: Warning (unit_address_vs_reg): Node /fragment@1 has a unit name, but no reg property
rpi-poe.dtbo: Warning (unit_address_vs_reg): Node /fragment@1/__overlay__/trips/trip-point@0 has a unit name, but no reg property
rpi-poe.dtbo: Warning (unit_address_vs_reg): Node /fragment@1/__overlay__/trips/trip-point@1 has a unit name, but no reg property
rpi-poe.dtbo: Warning (unit_address_vs_reg): Node /fragment@1/__overlay__/trips/cpu_hot@0 has a unit name, but no reg property
pi@dtc1:~/fan-control $
After copying it to the

Code: Select all

/boot/overlays/
folder, after rebooting the PI the fan does nothing - not even when the temperature gets up above 65degC.

Additionally, after applying it, I ran dmesg -w and noticed that I'm now getting over-current warnings: I don't have any devices plugged into the PI at all; its headless and I connect over SSH.

Code: Select all

pi@dtc1:~ $ sudo dmesg -C
pi@dtc1:~ $ dmesg -w
[   72.037711] usb 1-1-port2: over-current change
[   72.131720] usb 1-1.1-port2: over-current change
[   72.271588] usb 1-1-port3: over-current change
[   72.371592] usb 1-1.1-port3: over-current change
[   72.511585] usb 1-1-port4: over-current change
[   93.891759] usb 1-1.1-port2: over-current change
[   94.053660] usb 1-1-port2: over-current change
[   94.131606] usb 1-1.1-port3: over-current change
[   94.301594] usb 1-1-port3: over-current change
[   94.371595] usb 1-1.1-port2: over-current change

(this goes on and on and on...)

Any thoughts? Help!

Thanks!

martinrowan
Posts: 76
Joined: Wed Aug 26, 2015 11:00 am
Location: Berkshire, UK
Contact: Website Twitter

Re: PoE HAT Fan Speed adjustment

Thu Aug 30, 2018 7:35 pm

On the over-current warnings, this is something being tracked in this thread: https://www.raspberrypi.org/forums/view ... 5&t=220984
Sorry due to the over-current issues, I've not experimented with altering the fan profile myself.

martinrowan
Posts: 76
Joined: Wed Aug 26, 2015 11:00 am
Location: Berkshire, UK
Contact: Website Twitter

Re: PoE HAT Fan Speed adjustment

Sun Sep 02, 2018 5:29 pm

I too had the same issue with the updated overlay not working. It looks like 4 days ago there was a code change submitted (https://github.com/raspberrypi/linux/co ... c65db65959) which modified the file: rpi-poe-overlay.dts

Since the new driver that included the rest of the changes isn't released yet, it's necessary to get the older version of the file or just undo the simple change.

Change:

Code: Select all

compatible = "raspberrypi,rpi-poe-fan";
Back to:

Code: Select all

compatible = "rpi-poe-fan";
Or download the older version of the file: https://raw.githubusercontent.com/raspb ... verlay.dts


Also running the command as root ensure the files are created with root owner and group as per the original file:

Code: Select all

sudo dtc -@ -I dts -O dtb -o rpi-poe.dtbo rpi-poe-overlay.dts
Hopefully that will get your fan working once again and able to change the thresholds.
Thanks Martin

dr.sputnik
Posts: 2
Joined: Thu Aug 30, 2018 3:31 pm

Re: PoE HAT Fan Speed adjustment

Tue Sep 04, 2018 12:24 pm

That's sorted it! Many thinks.

hansamann
Posts: 7
Joined: Fri Mar 22, 2013 7:40 pm

Re: PoE HAT Fan Speed adjustment

Fri Oct 12, 2018 5:34 pm

If someone else feels the POE fan needs more user-controllable settings, please consider voting / starring for an issue I created =:
https://github.com/raspberrypi/linux/is ... 3Aopen+poe

TLDR: make the fan user controllable with different operating levels in raspi-config.

thx
Sven

jordipalet
Posts: 3
Joined: Sun Dec 09, 2018 8:18 pm

Re: PoE HAT Fan Speed adjustment

Sun Dec 09, 2018 8:29 pm

New with Raspberry and using the Pi 3 Model B+ with the PoE Hat.

Had the same problem with the fans running too much even with normal 45C, so followed those instructions and changed in the code published by dr.sputnik, compatible = "rpi-poe-fan"

I still got
rpi-poe.dtbo: Warning (unit_address_vs_reg): Node /fragment@0 has a unit name, but no reg property
rpi-poe.dtbo: Warning (unit_address_vs_reg): Node /fragment@0/__overlay__/rpi-poe-fan@0 has a unit name, but no reg property
rpi-poe.dtbo: Warning (unit_address_vs_reg): Node /fragment@1 has a unit name, but no reg property
rpi-poe.dtbo: Warning (unit_address_vs_reg): Node /fragment@1/__overlay__/trips/trip-point@0 has a unit name, but no reg property
rpi-poe.dtbo: Warning (unit_address_vs_reg): Node /fragment@1/__overlay__/trips/trip-point@1 has a unit name, but no reg property
rpi-poe.dtbo: Warning (unit_address_vs_reg): Node /fragment@1/__overlay__/trips/cpu_hot@0 has a unit name, but no reg property

after the sudo dtc -@ -I dts -O dtb -o rpi-poe.dtbo rpi-poe-overlay.dts

ignored it, done a chmod +x and copied over to /boot/overlay (backed up first).

However, no results with sudo dmesg -C
and sudo dmesg -w, doesn't provide anything ... need to ^c, as not coming back to the prompt

Is that normal?

Or there is an alternative way to do this since september with this thread was published -?

(I've everything updated to the last version)

Thanks!
martinrowan wrote:
Sun Sep 02, 2018 5:29 pm
I too had the same issue with the updated overlay not working. It looks like 4 days ago there was a code change submitted (https://github.com/raspberrypi/linux/co ... c65db65959) which modified the file: rpi-poe-overlay.dts

Since the new driver that included the rest of the changes isn't released yet, it's necessary to get the older version of the file or just undo the simple change.

Change:

Code: Select all

compatible = "raspberrypi,rpi-poe-fan";
Back to:

Code: Select all

compatible = "rpi-poe-fan";
Or download the older version of the file: https://raw.githubusercontent.com/raspb ... verlay.dts


Also running the command as root ensure the files are created with root owner and group as per the original file:

Code: Select all

sudo dtc -@ -I dts -O dtb -o rpi-poe.dtbo rpi-poe-overlay.dts
Hopefully that will get your fan working once again and able to change the thresholds.
Thanks Martin

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6343
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: PoE HAT Fan Speed adjustment

Tue Dec 11, 2018 4:25 pm

It's a bit simpler now. Restore the original overlay.

https://github.com/raspberrypi/firmware ... ADME#L1646

In config.txt:

Code: Select all

dtparam=poe_fan_temp0=55000,poe_fan_temp1=60000
That should turn the fan on at 55C

jordipalet
Posts: 3
Joined: Sun Dec 09, 2018 8:18 pm

Re: PoE HAT Fan Speed adjustment

Tue Dec 11, 2018 5:32 pm

Thanks a lot, it worked only issue is that params seems to work this way:
dtparam=poe_fan_temp0=55000,poe_fan_temp1=60000

ShiftPlusOne wrote:
Tue Dec 11, 2018 4:25 pm
It's a bit simpler now. Restore the original overlay.

https://github.com/raspberrypi/firmware ... ADME#L1646

In config.txt:

Code: Select all

dtparam=poe_fan_temp0=55,poe_fan_temp1=60
That should turn the fan on at 55C

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6343
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: PoE HAT Fan Speed adjustment

Tue Dec 11, 2018 6:06 pm

Yes, sorry I was in a hurry. I'll edit the post so it doesn't trip others up.

bobbyiliev
Posts: 1
Joined: Sat Feb 09, 2019 8:57 pm
Contact: Website Twitter

Re: PoE HAT Fan Speed adjustment

Sat Feb 09, 2019 9:03 pm

This works great!
ShiftPlusOne wrote:
Tue Dec 11, 2018 4:25 pm
It's a bit simpler now. Restore the original overlay.

https://github.com/raspberrypi/firmware ... ADME#L1646

In config.txt:

Code: Select all

dtparam=poe_fan_temp0=55000,poe_fan_temp1=60000
That should turn the fan on at 55C
https://bobbyiliev.com

maltwix
Posts: 3
Joined: Mon May 27, 2019 5:32 pm

Re: PoE HAT Fan Speed adjustment

Mon May 27, 2019 5:36 pm

ShiftPlusOne wrote:
Tue Dec 11, 2018 4:25 pm
It's a bit simpler now. Restore the original overlay.

https://github.com/raspberrypi/firmware ... ADME#L1646

In config.txt:

Code: Select all

dtparam=poe_fan_temp0=55000,poe_fan_temp1=60000
That should turn the fan on at 55C
Hi ShiftPlusOne,
unfortunately this does not work on my RPI. I have the newest version of raspbian (downloaded 2 days ago). I added the following in my config.txt:
dtoverlay=rpi-poe:poe_fan_temp0=59000,poe_fan_temp1=60000

and output from vcdbg log msg:
002294.543: Loaded overlay 'rpi-poe'
002294.598: dtparam: poe_fan_temp0=59000
002301.831: dtparam: poe_fan_temp1=60000

But Fan does still turn on at 50000...

It would be great if you can help me.

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6343
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: PoE HAT Fan Speed adjustment

Wed Jun 05, 2019 4:21 pm

Just tried your settings and it seems to work for me.

What's in /sys/class/thermal/thermal_zone0/trip_point_1?

Are you sure it's coming on at 50 and you're not just seeing it remain on while the temperature drops down from 59?

maltwix
Posts: 3
Joined: Mon May 27, 2019 5:32 pm

Re: PoE HAT Fan Speed adjustment

Mon Jun 10, 2019 3:46 pm

The files are named like this:


-r--r--r-- 1 root root 4096 Jun 9 15:18 cdev0_trip_point
-r--r--r-- 1 root root 4096 Jun 9 15:18 cdev1_trip_point
-rw-r--r-- 1 root root 4096 Jun 9 15:18 trip_point_0_hyst
-r--r--r-- 1 root root 4096 Jun 9 15:18 trip_point_0_temp
-r--r--r-- 1 root root 4096 Jun 9 15:18 trip_point_0_type
-rw-r--r-- 1 root root 4096 Jun 9 15:18 trip_point_1_hyst
-r--r--r-- 1 root root 4096 Jun 9 15:18 trip_point_1_temp
-r--r--r-- 1 root root 4096 Jun 9 15:18 trip_point_1_type

And now I have the correct settings in it because I rebuilt the dtbo file with the settings I want to have. This is wokring now...

Kondziu
Posts: 1
Joined: Thu Jul 11, 2019 5:46 pm

Re: PoE HAT Fan Speed adjustment

Thu Jul 11, 2019 5:47 pm

I'm in the same boat - configuration for the PoE hat in /boot/config.txt does nothing for me, while .dtbs modifications do the trick.

bibou65
Posts: 1
Joined: Tue Jan 14, 2020 7:32 pm

Re: PoE HAT Fan Speed adjustment

Tue Jan 14, 2020 7:48 pm

Hi all,

I have a Raspberry Pi 4 (4GB) and a POE HAT and I also encounter difficulties to manage the fan of the POE HAT.

I have a standard Pi4 case (red and white) and my Pi only have a Ubiquiti controler and PiHole installed. The temperatur of the PI is always around 75 C° when the system is running (let say idle state). If I start playing with the Ubiquiti controler and the PiHole, it easily get to 82 C° and I'm scared that something start braking due to the temperature to high.

For the moment I have disabled the fan because it ran like 5 seconds every 15 seconds and it is very noisy/annoying.
I have tried to follow the steps above in this post but with my poor linux and dev knowledge, I can't figure out what I have to do.

I have tested the line:

Code: Select all

dtparam=poe_fan_temp0=55000,poe_fan_temp1=60000
in the /boot/config.txt and change the values to test but nothing is changing the fan still run every 15 seconds etc.

I have tried to check the links below but I feel completely lost with it. I don't know what to do with all these text/overlay stuff and where to install/place the content/files:
https://github.com/raspberrypi/firmware ... ADME#L1646
https://github.com/raspberrypi/firmware ... 78cb40e6e4

Is there any "easy" stuff for basic users to manage the fan of the POE HAT just like the https://shop.pimoroni.com/products/fan-shim?

Thanks in advance :)

T1NBK
Posts: 1
Joined: Sun Apr 05, 2020 8:30 pm

Re: PoE HAT Fan Speed adjustment

Sun Apr 05, 2020 8:41 pm

I tested with poe_fan_temp0 and poe_fan_temp1 but found I was only able to set a lower setpoint for starting the fan.
RBP 3B+ with raspberry buster

I looked at the overlays in the firmware/README and found the following

poe_fan_temp0 Temperature (in millicelcius) at which the fan
turns on (default 50000)
poe_fan_temp0_hyst Temperature delta (in millicelcius) at which
the fan turns off (default 5000)
poe_fan_temp1 Temperature (in millicelcius) at which the fan
speeds up (default 55000)
poe_fan_temp1_hyst

So I also added the hyst params and now I'm able to set a higher setpoint.

Code: Select all

dtparam=poe_fan_temp0=60000,poe_fan_temp0_hyst=5000,poe_fan_temp1=65000,poe_fan_temp1_hyst=5000
I'm not sure what the lowest possible RPM is and how much noise the fan makes at those RPM but the idea I have is to keep the fan running at it's lowest RPM when the system is idle and use a PID control to keep it below a certain setpoint.
For me its not the fan itself that is annoying. Its the constant starting at (too) high RPM and then stopping again cyclus that gets annoying.

brontide
Posts: 4
Joined: Mon Apr 27, 2020 5:28 pm

Re: PoE HAT Fan Speed adjustment

Mon Apr 27, 2020 5:42 pm

Using the latest firmware I've applied the following options to make my rPi 4 k8s cluster nearly silent. A low, barely audible, fan will kick on at 55 and be audible but still quiet at 65; it should not start being noisy until 71 which is still below thermal throttling of 83/85 for this device, the full fan speed kicks on at 73. Running CPU intensive workloads I was unable to push it past the second setpoint.

Code: Select all

dtparam=poe_fan_temp0=55000,poe_fan_temp0_hyst=5000,poe_fan_temp1=66000,poe_fan_temp1_hyst=5000
dtparam=poe_fan_temp2=71000,poe_fan_temp2_hyst=5000,poe_fan_temp3=73000,poe_fan_temp3_hyst=5000
What's odd is that it appears to map the values in reverse, so temp0 = trip_point_3_temp. I'm going to try messing with the device tree since I think a lot more could be done with the cooling levels by having more cooling steps at lower PWM levels.

As a benefit the lower fan speeds appear to shave ~1W of power usage off the units ( measured at PoE switch ).

brontide
Posts: 4
Joined: Mon Apr 27, 2020 5:28 pm

Re: PoE HAT Fan Speed adjustment

Tue Apr 28, 2020 11:55 pm

Okay, another day where I spent some quality time with the code. I've modified the overlay to give more steps in the quiet range of the fan. I've patched the firmware overlay with new trip levels and it's really useful.

Code: Select all

cooling-levels = <0 15 31 63 255>;
Temperature trips are set to 43, 58, 69, and 78 with hysteresis at 1, 2, 9, and 9 degrees ( multiply all numbers by 1000 for the dtparam ). With the quiet end of the range it's easy to have minimal hysteresis but as you go up you need to raise it in order to prevent the cycling that is so annoying.

jordipalet
Posts: 3
Joined: Sun Dec 09, 2018 8:18 pm

Re: PoE HAT Fan Speed adjustment

Wed Apr 29, 2020 10:16 am

I wonder if this should also work with the last firmware of the Pi 3 Model B+ with the PoE Hat.

The fan never stay on in the "lower" possible speed, so the problem is the fan on/off noise ...

Also I've another problem which I'm not sure is related to the heat or what. From time to time (typically every week), I like to reboot the Pi, for example, after a firmware upgrade. The system seems to work, but the Ethernet, even if blinking, is not reachable (no ping, no ssh). I usually need to use the switch interface to power it off, then power it on and most of the time, just doing this once, it works (some times I need to do it once more).

The Pi is in a Dlink PoE swith wich many other POE devices on it. All the other devices don't have any trouble, so I don't think it is a switch problem.
brontide wrote:
Mon Apr 27, 2020 5:42 pm
Using the latest firmware I've applied the following options to make my rPi 4 k8s cluster nearly silent. A low, barely audible, fan will kick on at 55 and be audible but still quiet at 65; it should not start being noisy until 71 which is still below thermal throttling of 83/85 for this device, the full fan speed kicks on at 73. Running CPU intensive workloads I was unable to push it past the second setpoint.

Code: Select all

dtparam=poe_fan_temp0=55000,poe_fan_temp0_hyst=5000,poe_fan_temp1=66000,poe_fan_temp1_hyst=5000
dtparam=poe_fan_temp2=71000,poe_fan_temp2_hyst=5000,poe_fan_temp3=73000,poe_fan_temp3_hyst=5000
What's odd is that it appears to map the values in reverse, so temp0 = trip_point_3_temp. I'm going to try messing with the device tree since I think a lot more could be done with the cooling levels by having more cooling steps at lower PWM levels.

As a benefit the lower fan speeds appear to shave ~1W of power usage off the units ( measured at PoE switch ).

brontide
Posts: 4
Joined: Mon Apr 27, 2020 5:28 pm

Re: PoE HAT Fan Speed adjustment

Wed Apr 29, 2020 4:06 pm

jordipalet wrote:
Wed Apr 29, 2020 10:16 am
I wonder if this should also work with the last firmware of the Pi 3 Model B+ with the PoE Hat.

The fan never stay on in the "lower" possible speed, so the problem is the fan on/off noise ...
I think it's the same firmware so the same fix should work. The trick with the noise is to make sure the hyst is high, that way when it steps up it's going to take longer to step down. Without knowing your workload and ambient temp it's hard to make any hard recommendations but you can watch.

Code: Select all

$ cat /sys/class/thermal/cooling_device0/cur_state 
1
$ cat /sys/class/thermal/cooling_device0/stats/time_in_state_ms 
state0  1
state1  78601953
state2  3075
state3  0
state4  0
$ # if you don't see 5 states then you're on an older kernel device tree and will have fewer trip points to configure.
To see where your device is spending more time. If it's cycling in a state too frequently you want to increase the temp separation AND the hyst so that is goes into that state less frequently and stays there longer. That's actually a mistake in my first example, the temperatures should be further apart because hyst will be capped to min(value, abs(temp-next step), abs(temp-previos step)). If your step is only 2 degress the hyst will be capped there as well. If you use 40, 50, 60, 75 ( nice, spread out values ) you can raise the hyst to 10,10,10,15 which should keep the fans on longer at whatever speed the step up to.
Also I've another problem which I'm not sure is related to the heat or what. From time to time (typically every week), I like to reboot the Pi, for example, after a firmware upgrade. The system seems to work, but the Ethernet, even if blinking, is not reachable (no ping, no ssh). I usually need to use the switch interface to power it off, then power it on and most of the time, just doing this once, it works (some times I need to do it once more).
Can't be help there, mine reboot no problem using either `reboot` or `shutdown -r now`. I've got my units attached to a Ubuquiti US-8-60w without complains.

geoffr
Posts: 89
Joined: Wed Aug 22, 2012 11:25 am
Location: Melbourne, VIC

Re: PoE HAT Fan Speed adjustment

Wed May 20, 2020 11:18 am

brontide wrote:
Tue Apr 28, 2020 11:55 pm
Okay, another day where I spent some quality time with the code. I've modified the overlay to give more steps in the quiet range of the fan. I've patched the firmware overlay with new trip levels and it's really useful.

Code: Select all

cooling-levels = <0 15 31 63 255>;
Temperature trips are set to 43, 58, 69, and 78 with hysteresis at 1, 2, 9, and 9 degrees ( multiply all numbers by 1000 for the dtparam ). With the quiet end of the range it's easy to have minimal hysteresis but as you go up you need to raise it in order to prevent the cycling that is so annoying.
I've made a similar change. I'm happy running my lowest fan speed up to 55 degrees, and instead of using 15 as the PWM value, I am using 10. It would be useful for the overlay not to have the PWM values hard-coded, but rather to allow them to be changed in config.txt. I have however not spent long enough looking at how overlays are written to work out how to change that.

r59f9
Posts: 5
Joined: Thu Jul 18, 2019 10:57 am

Re: PoE HAT Fan Speed adjustment

Thu May 28, 2020 4:31 pm

I have two 3B+ set up with the PoE HAT. For months I've had them happily running with the following in /boot/config.txt to control when the fans run:

Code: Select all

# to regulate when the fan comes on and off
dtparam=poe_fan_temp0=60000,poe_fan_temp1=65000
I ssh in and run apt update/upgrade a couple of times a week. I did that today as usual and there were a few updates installed.

Since then, both of the Pis appear to have stopped controlling the fan according to the above settings. It seems that the fans now come on when the temperature hits 50C - which if I think is maybe the default if not overridden?

I've done a bit of checking, turning one off at a time, and they both appear to be doing the same thing with the fans after the same software updates today.

One (possibly both) of the Pis has started intermittently making that high pitched noise on and off, possibly in association with the fan being triggered frequently due to the settings not working. As the temperature seems to hover around 50C most of the time, the fans come on a lot, sometimes for just a half second at a time. Sounds like someone wheezing and whistling in the corner, which is quite annoying as the Pis are in my home office so I'm hearing this all the time.

Has a recent Raspbian update changed how the PoE HAT fan is regulated? If so, what can I change to adjust the settings back to something closer to what I had before?

Thanks!

r59f9
Posts: 5
Joined: Thu Jul 18, 2019 10:57 am

Re: PoE HAT Fan Speed adjustment

Fri May 29, 2020 11:25 am

To follow up on my post above, it seems that some changes have been made, discussed in recent posts on this Github page: https://github.com/raspberrypi/linux/issues/2715

I've still been unable to work out what I need to change to restore the functionality. Whatever I do, the fan appears to run on default settings.

After numerous attempts I've opted to disable the fan altogether by entering disable_poe_fan=1 as a line in /boot/config.txt

Any tips on what's needed would be appreciated.

r59f9
Posts: 5
Joined: Thu Jul 18, 2019 10:57 am

Re: PoE HAT Fan Speed adjustment

Fri May 29, 2020 12:08 pm

OK I managed to get it working with the following entry, which starts the fan at 60C and increases intensity if temp increases above the additional thresholds:

Code: Select all

# fan activation and escalation settings
dtoverlay=rpi-poe
dtparam=poe_fan_temp0=60000
dtparam=poe_fan_temp1=62000
dtparam=poe_fan_temp2=64000
dtparam=poe_fan_temp3=68000

Return to “HATs and other add-ons”