jccat
Posts: 16
Joined: Tue Aug 03, 2021 6:13 am

Can not get LibreELEC to run on Linux Mint 20.2

Tue Sep 14, 2021 7:15 am

I started out downloading
LibreELEC 10.0.0 Kodi (Matrix) v19.1 to LibreELEC users.


chmod +x LibreELEC.USB-SD.Creator.Linux-64bit.bin

sudo ./LibreELEC.USB-SD.Creator.Linux-64bit.bin
https://www.linuxbabe.com/raspberry-pi/ ... spberry-pi

Each time I try the terminal just seems to hang any Idea s J

6by9
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 11850
Joined: Wed Dec 04, 2013 11:27 am
Location: ZZ9 Plural Z Alpha, aka just outside Cambridge.

Re: Can not get LibreELEC to run on Linux Mint 20.2

Tue Sep 14, 2021 8:10 am

You say you're running Mint 20.2. On an x86 system, or on a Pi?
Those downloads for installers are almost certainly for x86 (32 or 64 bit variants), not ARM.

Simplest to use the Raspberry Pi Imager to install Libreelec - https://www.raspberrypi.org/software/
Software Engineer at Raspberry Pi Trading. Views expressed are still personal views.
I'm not interested in doing contracts for bespoke functionality - please don't ask.

jccat
Posts: 16
Joined: Tue Aug 03, 2021 6:13 am

Re: Can not get LibreELEC to run on Linux Mint 20.2

Tue Sep 14, 2021 7:42 pm

I was trying to get LibreELEC to run on the Linux Mint 64.bit the same way raspberry imager comes up I have used raspberry imager in the past all ways works well

Most time I use the terminal to down load and install programs I have not found this with LibreELEC

jccat
Posts: 16
Joined: Tue Aug 03, 2021 6:13 am

Re: Can not get LibreELEC to run on Linux Mint 20.2

Tue Sep 14, 2021 8:05 pm

Hi Just tried the raspberry imager it would not install the balena-etcher-electron-1.5.122-linux-x64.zipdownload to the sd card

Input file is not a valid disk image file size 96119880bytes is not a multiple of 512bytes

so it looks like their installer is needed ?

at this stage i'm lost is there a raspberry up dated file with the updated bullseye

thanks J

jccat
Posts: 16
Joined: Tue Aug 03, 2021 6:13 am

Re: Can not get LibreELEC to run on Linux Mint 20.2

Wed Sep 15, 2021 1:08 am

Hi Kodi no longer works with NZ Streaming it needs the to OS to be upgraded to run Kodi v19 Matrix widevine is the problem it needs to be (4.10.2252.0 ) the libre has put together LibreELEC with Matrix included (4.10.2252.0)

I down loaded the LibreELEC for windows and it installed but would not write the LibreELEC file to the sd card so back to square one a new version of Raspberry from the raspberry site with 4.10.2252.0 on it this has some think to do with the upgrade the linux Debin os raspberry is built on

That is my understanding I'm not a tect person just been on computers for last 60years J

jccat
Posts: 16
Joined: Tue Aug 03, 2021 6:13 am

Re: Can not get LibreELEC to run on Linux Mint 20.2

Wed Sep 15, 2021 9:45 pm

Hi in case others are reading this post Yesterday I in stall kodi on a fresh install of linux Mint 20.2 this did not go well V18.6 and missing was the Kodi inputstream adaptive and RTMP input so uninstalled it

next I came across a site that included some files via terminal then install kodi / kodi icon did not show up so uninstalled Kodi /then reinstalled this time kodi 19 was installed and every thing works

So what this proves is the kodi v19 is needed to be installed on the raspberry pi 4

I had installed a fresh install of the raspberry os on a 8gb sd card then put it into the raspberry 4 and proceeded to up grade to kodi I turned away from the screen and when I looked back the screen was black / tried restarting the raspberry but it just hung / have reinstalled raspberry on the card and will try again to up grade to v19

I look forward to any comments J

Cloudcentric
Posts: 1277
Joined: Fri Sep 14, 2012 9:13 am

Re: Can not get LibreELEC to run on Linux Mint 20.2

Thu Sep 16, 2021 2:29 am

jccat wrote:
Wed Sep 15, 2021 9:45 pm
Hi in case others are reading this post Yesterday I in stall kodi on a fresh install of linux Mint 20.2 this did not go well V18.6 and missing was the Kodi inputstream adaptive and RTMP input so uninstalled it

next I came across a site that included some files via terminal then install kodi / kodi icon did not show up so uninstalled Kodi /then reinstalled this time kodi 19 was installed and every thing works

So what this proves is the kodi v19 is needed to be installed on the raspberry pi 4

I had installed a fresh install of the raspberry os on a 8gb sd card then put it into the raspberry 4 and proceeded to up grade to kodi I turned away from the screen and when I looked back the screen was black / tried restarting the raspberry but it just hung / have reinstalled raspberry on the card and will try again to up grade to v19

I look forward to any comments J

You do not need / want Ubuntu or RaspiOS as Kodi Software has not been optimised for the Raspberry Pi.



There are 2 Standalone Operating Systems which have good support for the Raspberry Pi 4B which use Kodi 19 as the User Interface:


LibreElec is based of JeOS Linux:

http://libreelec.tv/2021/08/26/libreelec-matrix-10-0


OSMC is based of Debian Buster

https://osmc.tv/2021/08/osmcs-august-up ... h-kodi-v19
.
.

jccat
Posts: 16
Joined: Tue Aug 03, 2021 6:13 am

Re: Can not get LibreELEC to run on Linux Mint 20.2

Thu Sep 16, 2021 5:13 am

thanks I have spent 2days trying to get LibreELEC I have down loaded 3 times the install for linux and 1 time for windows the win7 one install came up but would not wrtie to the sd card I could not get the linux one to install LibreELEC.USB-SD.Creator.Linux-32bit.bin I had downloaded both 32biot and 64 bit I get unknown file type

I went to osmc and it ops sorry not found

To day I got raspberry to upgrade to 19 but it tells me there a broken packages and wont install kodi J will check for any info from you tomorrow j

jccat
Posts: 16
Joined: Tue Aug 03, 2021 6:13 am

Re: Can not get LibreELEC to run on Linux Mint 20.2

Thu Sep 16, 2021 7:52 pm

Hi last night I came across a how to using Etcher to write to sd I got the installer to come up now i'm told that the down load libreelec-rpi4.arm-10.0.0.img.gz has MISSING partiition table ??? /home/jacksprat/Downloads/LibreELEC-RPi4.arm-10.0.0.img.gz as you can see this is the downloaded and same story missing partition file

Any one got a method to down load a file that works J

jccat
Posts: 16
Joined: Tue Aug 03, 2021 6:13 am

Re: Can not get LibreELEC to run on Linux Mint 20.2

Thu Sep 16, 2021 10:27 pm

at long last I have got it all working
Installing Libreelec on sd card 17Sept2021

I used https://linuxhint.com/install_etcher_linux/
to get etcher working
once you have (BalenaEtcher-1.5.122-x64.Appimage (it is in downloads)
Left double click on it and it comes up on screen
I used Flash from url
To get the url i started to down load the file then hit copy url
Now paste it in to LibreOffice (it is needed as you have to type it into Etcher
(Echer will save it as a reacent can click on it and it goes back to use image url)
ok
Select target (put in you sd card (Check the size to ID your card)
Click on it (in my case Generic Storage (2 ticks on the left hand side )
Select 1
Flash
Your Password
Starting (about 5 minutes )
Kodi is now working on Raspberry pi 4

Cheers J

Return to “Other”