Wulph
Posts: 4
Joined: Sun Mar 15, 2015 12:57 am

Re: Raspberry pi 3 Model B WiFi MAC address keeps changing

Sat Feb 24, 2018 12:01 am

I had the same symptom after installing network-manager-openvpn (among other things).

Thanks to this thread I was able to restore sane operation by removing network-manager-openvpn and purging the unused packages, which included network-manager:

Code: Select all

sudo apt remove network-manager-openvpn
sudo apt autoremove
and a reboot.

Apparently this is a desired feature of network-manager. https://blogs.gnome.org/thaller/2016/08 ... ger-1-4-0/

maurik
Posts: 2
Joined: Fri Apr 14, 2017 6:35 pm

Re: Raspberry pi 3 Model B WiFi MAC address keeps changing

Mon Mar 12, 2018 4:55 pm

Hello All,

Interesting. I just caught my Raspberry Pi in the act of doing exactly the same thing!
It started after I installed "accountsservice" which is supposed get rid of an error in the logs during boot up. This suggested I install "gnome-control-center", which then installs a whole host of other stuff, including: network-manager and network-manager-gnome

Removing these two packages ("apt-get remove network-manager network-manager-gnome") stops the network (duh!), but then when I re-enabled the network all was good and the old hardware MAC address registered again with the router.

The versions were: network-manager-gnome (1.4.4-1) , network-manager (1.6.2-3)

If anyone know more about this, or whether this is due to some misconfiguration I had of NeworkManager (I did not see anything suspicious), let us know.

Thanks.

ejolson
Posts: 9526
Joined: Tue Mar 18, 2014 11:47 am

Re: Raspberry pi 3 Model B WiFi MAC address keeps changing

Tue Mar 13, 2018 1:16 am

maurik wrote:
Mon Mar 12, 2018 4:55 pm
If anyone know more about this, or whether this is due to some misconfiguration I had of NeworkManager
I think MAC randomisation is a security feature designed to keep the DHCP server from guessing who you are. It might have limited use in the case where your ISP is operating a data mine that tries to track users based on MAC number. In my opinion network manager is a prototypical example of how automated tools make the easy case easier while at the same time making the difficult case even more difficult.


treii28
Posts: 97
Joined: Fri May 10, 2013 4:52 pm

Re: Raspberry pi 3 Model B WiFi MAC address keeps changing

Sat Jun 15, 2019 7:06 pm

I'm suddenly running into something similar on the wlan0 port of my pi3. This thread seems to be all over the place. Did anyone find a specific cause to investigate?

SW

werddomain
Posts: 1
Joined: Fri Aug 23, 2019 10:53 pm

Re: Raspberry pi 3 Model B WiFi MAC address keeps changing

Fri Aug 23, 2019 10:56 pm

If you have Network-Manager installed:

To disable the MAC address randomization create the file
/etc/NetworkManager/conf.d/100-disable-wifi-mac-randomization.conf
with the content

Code: Select all

[connection]
wifi.mac-address-randomization=1
 
[device]
wifi.scan-rand-mac-address=no
https://blog.muench-johannes.de/network ... zation-314

trusty27
Posts: 1
Joined: Thu Jun 25, 2020 9:17 pm

Re: Raspberry pi 3 Model B WiFi MAC address keeps changing

Thu Jun 25, 2020 9:19 pm

I know it's quite a long time since this issue was raised but i came across the same thing with my Pi 4 and found that it started to happen when I installed cockpit (which includes "network-manager")
I removed cockpit and the issue was resolved for me.

JeffZ123
Posts: 18
Joined: Sun Aug 12, 2018 3:43 pm

Re: Raspberry pi 3 Model B WiFi MAC address keeps changing

Fri Dec 11, 2020 10:56 pm

I installed Cockpit onto a Pi 3A+ for a non-ssh savvy user. Mac & IP Changed every reboot.

This is what worked for me (from other thread) notice that "wifi.scan-rand-mac-address=no" is added directly to NetworkManager.conf
panec wrote:
Sun Mar 15, 2020 9:21 pm
In my case this helped:
Network-Manager will reset your mac address during the wifi scanning.

To permanently change your mac address:

Edit your /etc/NetworkManager/NetworkManager.conf as follows:

[device]
wifi.scan-rand-mac-address=no
Reboot and verify your settings.

Got from https://community.home-assistant.io/t/t ... 38?u=panec

Return to “General discussion”