yabusa
Posts: 4
Joined: Mon Dec 09, 2019 12:01 am

HDMI audio doesn't work

Mon Dec 09, 2019 12:05 am

Hi there,

I tried following the article here: https://www.raspberrypi.org/documentati ... -config.md, with no luck.
Headphones work in the analog port, but when I switch to hdmi, there's no audio from my monitor.

User avatar
mahjongg
Forum Moderator
Forum Moderator
Posts: 14229
Joined: Sun Mar 11, 2012 12:19 am
Location: South Holland, The Netherlands

Re: HDMI audio doesn't work

Mon Dec 09, 2019 12:29 pm

If you have an RPI4, then note there is only audio coming from the left HDMI0 port, not from the right HDMI1 port.

User avatar
davidcoton
Posts: 6584
Joined: Mon Sep 01, 2014 2:37 pm
Location: Cambridge, UK

Re: HDMI audio doesn't work

Mon Dec 09, 2019 3:16 pm

yabusa wrote:
Mon Dec 09, 2019 12:05 am
... there's no audio from my monitor.
Does your monitor have speakers? Many don't.
Location: 345th cell on the right of the 210th row of L2 cache

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 30168
Joined: Sat Jul 30, 2011 7:41 pm

Re: HDMI audio doesn't work

Tue Dec 10, 2019 7:43 am

mahjongg wrote:
Mon Dec 09, 2019 12:29 pm
If you have an RPI4, then note there is only audio coming from the left HDMI0 port, not from the right HDMI1 port.
Audio should work fine on both ports.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Working in the Applications Team.

User avatar
mahjongg
Forum Moderator
Forum Moderator
Posts: 14229
Joined: Sun Mar 11, 2012 12:19 am
Location: South Holland, The Netherlands

Re: HDMI audio doesn't work

Sun Dec 22, 2019 2:21 pm

jamesh wrote:
Tue Dec 10, 2019 7:43 am
mahjongg wrote:
Mon Dec 09, 2019 12:29 pm
If you have an RPI4, then note there is only audio coming from the left HDMI0 port, not from the right HDMI1 port.
Audio should work fine on both ports.
Thanks for the update.

Return to “General discussion”