Uranne
Posts: 8
Joined: Sat Apr 13, 2019 3:54 pm

Connexion SSH avec putty : connection refused

Sat Apr 13, 2019 4:05 pm

Bonjour,
J'ai l'impression de passer à côté d'un truc parce que tout les tutos que j'ai pu trouver pour accéder à ma carte en ssh ne me permettent pas d'y arriver.

En utilisant putty j'ai donc mis l'adresse de ma carte (que j'ai préalablement rendu fixe sur ma box orange), j'arrive à pinger l'adressse.
J'ai également mis le bon port.
Est -ce qu'il peut y avoir une config à faire sur la box internet dont je n'ai pas entendu parlé ? ou alors malwarebyte bloc ? Il n'y aucun log qui me permet de le penser.

J'ai vu une histoire comme quoi la clé inscrite dans le gestionnaire de registre par putty pourrait être en cause mais elle n'apparait pas dans mon gestionnaire.

Vous auriez de l'aide à m'apporter s'il vous plait ?

Raspberry 3 modèle B, raspbian a jour (j'ai la carte depuis une semaine).
Pc sous windows 10.

totoharibo
Posts: 4643
Joined: Thu Jan 24, 2013 8:43 am

Re: Connexion SSH avec putty : connection refused

Sat Apr 13, 2019 8:02 pm

ssh bloqué au démarrage avec SD nouvellement chargé pour des raisons de sécurité
changer le mot de passe dans rapbian et activer ssh (avec clavier/souris et écran) par la commande "sudo raspi-config"
ou appeler "preferences->configuraion du raspberry"

soit ajouter un ficher dans /boot et changer le mot de passe une fois connecté.
Je ne me rappelle plus du nom du fichier et je ne trouve pas

Uranne
Posts: 8
Joined: Sat Apr 13, 2019 3:54 pm

Re: Connexion SSH avec putty : connection refused

Sat Apr 13, 2019 8:10 pm

Merci pour ta réponse rapide.

Dès l'installation du bios, j'ai activé dans la config (en mode interface) le ssh.
Puis dans le fichier, j'ai modifié les mdp root et pi.
J'ai modifié le port également, et j'ai interdis la connexion root directement en ssh.
Peut être que l'activation du ssh sans passer par les lignes de commandes ne suffit pas ??

totoharibo
Posts: 4643
Joined: Thu Jan 24, 2013 8:43 am

Re: Connexion SSH avec putty : connection refused

Sun Apr 14, 2019 9:22 am

il ne reste que la solution de te brancher en direct : écran/clavier

Ça fonctionne.

Uranne
Posts: 8
Joined: Sat Apr 13, 2019 3:54 pm

Re: Connexion SSH avec putty : connection refused

Sun Apr 14, 2019 10:15 am

C'est pas une solution satisfaisante pour moi de ne pas utiliser le ssh. Il doit bien y avoir un moyen de régler ce problème non ?

totoharibo
Posts: 4643
Joined: Thu Jan 24, 2013 8:43 am

Re: Connexion SSH avec putty : connection refused

Sun Apr 14, 2019 10:28 am

non ce n'est que pour la configuration de départ pour valider le ssh.
avec la commande "sudo raspi-config"
Une fois activé ssh, changé le mot de passe et donné une IP fixe tu peux utiliser ssh

Uranne
Posts: 8
Joined: Sat Apr 13, 2019 3:54 pm

Re: Connexion SSH avec putty : connection refused

Sun Apr 14, 2019 2:35 pm

OK,
Je me suis rebranché sur la raspberry.
J'ai mis à jour avec apt-get update
J'ai activé le ssh par raspi-config
Mes mdp pi et su ne sont pas les mdp par défaut
J'ai vérifié les infos dans sudo nano /etc/ssh/sshd_config (j'ai changé le port et passé le PermitRootLogin a no
J'ai ajouté aussi un fichier ssh dans boot
et bien entendu redémarré la carte plusieurs fois.

Malgré ça, ça ne fonctionne pas. Je ne sais plus quoi faire.

totoharibo
Posts: 4643
Joined: Thu Jan 24, 2013 8:43 am

Re: Connexion SSH avec putty : connection refused

Sun Apr 14, 2019 3:50 pm

J'ai mis à jour avec apt-get update
il faut faire aussi apt-get upgrade
Mais ce n'est pas pour ça que tu as le problème.

le fichier ssh au boot c'est pour le premier démarrage. Si tu est sur le RPi ce n'est pas utile et je te conseille de le supprimer.
Normalement pas de mot de passe su (root) on fait sudo su avec éventuellement le mot de passe de pi.

Ça ne marche pas : la réponse s'est
- "pas de RPi" -> mauvaise adresse IP
- "refus de connexion" cela veut pas dire pas de service ssh.

sur le RPi en ligne de commande :
systemctl status ssh
pour voir si le serveur ssh est en route.
Derrière tu vois l'historique du service

JumpZero
Posts: 1271
Joined: Thu Mar 28, 2013 7:35 pm
Location: Arcachon, France

Re: Connexion SSH avec putty : connection refused

Sun Apr 14, 2019 3:57 pm

Bonjour,
oui c'est frustrant, d'après ce que tu écris tu semble avoir tout bien fait.
Essaies de tout recommencer avec une image Raspbian neuve (re-flash une carte SD) et d'y aller petit à petit:
La doc offiielle https://www.raspberrypi.org/documentati ... ccess/ssh/ dis que tu as 2 voies: avec un écran/clavier ou sans
Créer un fichier nommé ssh (juste ssh sans extension et même vide) et le placer dans la partition /boot (qui est la seule visible sous Windows). Au boot Raspbian trouve ce fichier, l'efface et active le serveur ssh (sshd). C'est très simple et ça marche toujours! Le seul truc difficile c'est que si tu boot le pi comme ça tu ne connais pas son adresse ip, pour l'avoir tu peux vérifier sur ta box (ou routeur) les adresses attribuées (dhcp) avant de booter le pi et revérifier après le boot du pi s'il y a une nouvelle adresse il y a des chances que ce soit le pi.
Avec un écran clavier tu suit la procédure avec raspi-config et là tu peux voir l'adresse ip du pi.
tu n'as pas besoin de faire d'autres changements, allons-y par étapes, tu les feras + tard, y compris le mot de passe du user pi, tu auras juste un message d'avertissement. Mais bien sur il faudra le faire!
Vérifie ensuite que le pi est visible sur le réseau, tu peut le "pinger" depuis une autre machine (tu as dis que oui)
Et là normalement avec les regalages de base de putty (port 22) comme montré sur la doc ça doit marcher.
Ensuite si putty ne veut rien savoir essaies autre chose, une autre machine Unix sur réseau (un mac, un Linux) serait le plus simple. Sinon il y a des clients ssh pour Android et iOS...
Le pi est en wifi ou ethernet?
Es-tu sur du réseau rien ne bloque en chemin? Le PC et le pi sont bien sur le même réseau?
Allez encore quelques essais! :D

Uranne
Posts: 8
Joined: Sat Apr 13, 2019 3:54 pm

Re: Connexion SSH avec putty : connection refused

Sun Apr 14, 2019 6:13 pm

Bon,

J'ai donc reinstaller rasbian, je suis passé par noob comme la première fois.
J'ai ensuite fait la procédure en utilisant écran + clavier.
J'ai essayé avec les configs de base, ça marche.

Maintenant je modifi le fichier de config. Je change le port pour un autre, dans les 14XX, et j'essaye à nouveau...
Et ça marche pas ...
Par contre l'accès avec le port 22 fonctionne toujours...

Alors, qu'est ce que j'ai mal fait ? ><

JumpZero
Posts: 1271
Joined: Thu Mar 28, 2013 7:35 pm
Location: Arcachon, France

Re: Connexion SSH avec putty : connection refused

Sun Apr 14, 2019 7:11 pm

Eh bien bravo si ça marche tu as déjà fait un grand pas.
Quel est le fichier de config que tu modifies, est-ce bien le fichier de config du serveur ssh (sshd_config a ne pas confondre avec ssh_config qui lui est le client). Esr-ce que tu relances le serveur aprés modif avec

Code: Select all

sudo systemctl restart sshd
Bon c'est juste des pistes. Mais à ce stade ce qu'il faut que tu fasses c'est lire la doc, et faire les modif de config une par une, tester, et continuer ;)
Bon courage
PS: Raspbian étant basé sur Debian la doc ne manque pas même en français comme ici par ex.: https://www.debian.org/index.fr.html

Uranne
Posts: 8
Joined: Sat Apr 13, 2019 3:54 pm

Re: Connexion SSH avec putty : connection refused

Mon Apr 15, 2019 9:00 am

Merci pour ton aide.
Je vais pouvoir tester ça ce soir.
Je débute autant sur Debian que sur raspberry, bien qu'informaticien par ailleurs, je suis pas encore très à l'aise.

Lire la doc m'aidera sans doute pas mal. Merci.

Uranne
Posts: 8
Joined: Sat Apr 13, 2019 3:54 pm

Re: Connexion SSH avec putty : connection refused

Tue Apr 16, 2019 6:12 pm

Je viens avec les réponses à ma tentative :

failed to restart sshd.service : unit sshd.service not found

voici le screen du status :
https://i.imgur.com/E4OwptW.png

et le screen de mon fichier de config :
https://i.imgur.com/bZUZvcs.png

Il écoute bien au port 22 pour le moment ...
et je suis interloqué de pouvoir faire des commandes sudo sans mdp depuis putty :/

totoharibo
Posts: 4643
Joined: Thu Jan 24, 2013 8:43 am

Re: Connexion SSH avec putty : connection refused

Tue Apr 16, 2019 7:59 pm

pour sshd manque le paquet openssh-server

JumpZero
Posts: 1271
Joined: Thu Mar 28, 2013 7:35 pm
Location: Arcachon, France

Re: Connexion SSH avec putty : connection refused

Wed Apr 17, 2019 3:16 pm

Uranne wrote:
Tue Apr 16, 2019 6:12 pm
Je viens avec les réponses à ma tentative :

failed to restart sshd.service : unit sshd.service not found

voici le screen du status :
https://i.imgur.com/E4OwptW.png
Le resultat de ta commande montre que le service ssh fonctionne il est "acive et running" Tout est ok
si ta commande

Code: Select all

sudo service ssh status
a fonctionnée. Celle la fonctionnera aussi

Code: Select all

sudo service ssh restart
C'est la même chose que

Code: Select all

sudo systemctl restart ssh

Pour la petite histoire "service" c'était avant systemd mais pour conserver la compatabilité la commande fonctionne toujours
Uranne wrote:
Tue Apr 16, 2019 6:12 pm
et le screen de mon fichier de config :
https://i.imgur.com/bZUZvcs.png
Il écoute bien au port 22 pour le moment ...
et je suis interloqué de pouvoir faire des commandes sudo sans mdp depuis putty :/
:D Dans le monde Unix tout ce qui démarre par le caractère dièse: "#" est un commentaire (comme en Python!)
quand tu remplace

Code: Select all

#Port 22
par

Code: Select all

#Port 1402
ça ne fait strictement rien car dans les deux cas la ligne est ignorée car c'est un commentaire. Ce que tu as sans doute voulu faire c'est

Code: Select all

Port 1402
Comme expliqué en tête de sshd_config toutes les options par défaut sont listées, mais commentées, pour en changer une tu de-commentes et tu changes ce que tu veux changer. C'est simple et pratique!
C'est dit ici:

Code: Select all

# The strategy used for options in the default sshd_config shipped with
# OpenSSH is to specify options with their default value where
# possible, but leave them commented.  Uncommented options override the
# default value.
Enfin ne t’étonnes pas de pouvoir utiliser sudo sans mot de passe root! sudo est justement fait pour ça! Tu as déjà donné un mot de passe pour te connecter en tant que user pi, et le user pi est autorisé d'après les règles définies dans le fichiers /etc/sudoers, mais c'est encore une autre histoire, car bien sûr, comme toujours, sous GNU/Linux, tout est configurable, et l'on peut changer ça. Mais pour aujourd'hui ssh suffira! ;)

Uranne
Posts: 8
Joined: Sat Apr 13, 2019 3:54 pm

Re: Connexion SSH avec putty : connection refused

Wed Apr 17, 2019 7:34 pm

Et là on remarque bien que je suis pas encore a l'aise du tout ^^
Merci pour tes conseils, tu m'aides bien. Je me sens un peu con, effectivement j'ai pas lu en détail le fichier que je modifié et ça m'aurait suffit à trouver l'astuce...
Du coup mon sujet est résolu. Je vais maintenant pouvoir suivre mon apprentissage à la dur de cette technologie. Merci

JumpZero
Posts: 1271
Joined: Thu Mar 28, 2013 7:35 pm
Location: Arcachon, France

Re: Connexion SSH avec putty : connection refused

Thu Apr 18, 2019 1:03 pm

Uranne wrote:
Wed Apr 17, 2019 7:34 pm
Du coup mon sujet est résolu. Je vais maintenant pouvoir suivre mon apprentissage à la dur de cette technologie. Merci
On a tous débuté un jour!
Changer le port ssh par défaut (le 22) n'a pas vraiment d’intérêt si ssh reste accessible sur le réseau local seulement.
Si tu envisages de pouvoir accéder à ton pi depuis internet, il te faudra configurer ton routeur/box pour faire du NAT, et de plus si changer le port par défaut n'est pas une mauvaise idée il te faut envisager un accès par clefs publique/privée plutôt que par mot de passe (et surtout pas le mot de passe par défaut de Raspbian. C'est pour ça qu'il y a un avertissement quand ssh est activé et que le mot de passe du user pi n'a pas été changé). Tu trouveras toute la doc que tu veux pour utiliser ssh avec des clefs et configurer une box/routeur pour accès depuis internet sur le web tant le sujet est connu, le site de debian restant une reference incontournable!
Bonne lecture

Return to “Français”