User avatar
Posts: 946
Joined: Sat Aug 27, 2011 1:16 pm

Citrix Receiver on Jessie

Sun Oct 11, 2015 4:36 pm

In case anyone's interested these are the steps I used to get Citrix Receiver working on a new Jessie install:

1) Get gdebi as detailed in the blog post below:
sudo apt-get install gdebi

2) Get Iceweasel as this is best for the citrix session I will connect to. Might not be best for others
sudo apt-get install iceweasel

3) From ... -1321.html download the most recent armhf package

4) Navigate to where you downloaded it and install
sudo gdebi icaclientWeb_13.2.1.328635_armhf.deb

5) Install things it needs at runtime (there may be smaller installs than this - but I installed these and it works)
sudo apt-get install libwebkit-dev
sudo apt-get install libxerces-c-dev

6) Run it
/opt/Citrix/ICAClient/selfservice &

7) Connect. (I do this through an Iceweasel browser connection to my work... )

For Wheezy, the instructions in this blog post worked for me: ... an-wheezy/

Posts: 76
Joined: Wed Aug 26, 2015 11:00 am
Location: Berkshire, UK

Re: Citrix Receiver on Jessie

Fri Dec 11, 2015 4:54 pm

I just wanted to point out that the extra step to install the libwebkit and libxerces files wouldn't be necessary if you downloaded the full package (icaclient_13.2.1.328635_armhf.deb) rather than the web package (icaclientWeb_13.2.1.328635_armhf.deb). Then when installing with gdebi it should pick up all the necessary dependencies.

Since you also linked to my earlier guide on using Receiver on Wheezy, you may find the updated guide for Jessie interesting: ... ian-jessie

User avatar
Posts: 946
Joined: Sat Aug 27, 2011 1:16 pm

Re: Citrix Receiver on Jessie

Sun Dec 13, 2015 6:49 pm

Aha! Thank you. I didn't know there were two different packages to choose from.

Posts: 4
Joined: Fri Jun 03, 2016 11:20 pm

Re: Citrix Receiver on Jessie

Fri Jun 10, 2016 12:31 am

I do the first step that was instructed "sudo apt-get install gdebi" it asked me I wanted to continue and I typed "y". Then it showed me that a couple of packages could not be authenticated, so it asked me if i wanted to install those packages without verification and I typed "y" again. The line after that it wrote "0% [Waiting for headers]". I do not know what this means, for I am only a beginner in this Raspbian world, I noticed I get this exact same line after I run "sudo apt-get update", which most of the other forums recommended to do after installing a new image of Raspbian Jessie. I have a wired internet connection and it works, I can go on the browser and use it. I have looked around for solutions but nothing has helped, what else can I do?

Return to “Raspberry Pi OS”