thevdm
Posts: 2
Joined: Sun Dec 14, 2014 11:36 pm

How to disable screen timeout? Raspbian Jessie

Sun Sep 04, 2016 6:22 pm

Hi all.

I've built a Pi powered internet radio using Tron Radio. So far everything is working quite well apart from one thing. The screen goes blank after 5 minutes, despite trying every method I have found on google.

As this may well make a difference I am using the Waveshare 3.2" touchscreen display (HDMI disabled).

I have tried using (both manually and adding it to the ~/.xinitrc):

Code: Select all

xset s off
xset -dpms
xset s noblank
also adding this to /etc/lightdm/lightdm.conf under SeatDefaults:

Code: Select all

xserver-command=X -s 0 dpms
I've tried installing xscreensaver to override the screen blanking, but still no joy.

The screen goes blank (with the backlight still on) after 5 minutes/300 seconds and wakes the second the blank screen is touched (i.e. input is received).

The set-up involves the Pi booting, automatically starting x-window (lxde), auto-login, auto starting Tron Radio (written using pygame, seemingly in full screen).

Are there any other suggestions to remove the screen timeout?

hhoanganh
Posts: 44
Joined: Thu Apr 24, 2014 8:38 am

Re: How to disable screen timeout? Raspbian Jessie

Sat Sep 10, 2016 7:19 am

xserver-command=X -s 0 -dpms

look like you missed " - " at dpms

DNPNWO
Posts: 126
Joined: Fri Jul 08, 2016 1:51 am

Re: How to disable screen timeout? Raspbian Jessie

Sat Sep 10, 2016 1:40 pm

An easier way
open:

Code: Select all

sudo nano ~/.config/lxsession/LXDE-pi/autostart
add/save file:

Code: Select all

@xset s 0 0
@xset s noblank
@xset s noexpose
@xset dpms 0 0 0
reboot


You can also enable screenlocking from menu and keyboard, and monitor power save mode (monitor powers itself off after a set determined time)
https://youtu.be/aTrp83lgq_s

banrep
Posts: 2
Joined: Mon May 20, 2013 8:10 pm

Re: How to disable screen timeout? Raspbian Jessie

Fri Jan 27, 2017 9:53 pm

I have been trying to disable screen blanking/timeout but it seems none of these methods work when you have VNC enabled. I have just disabled VNC and screen blanking is disabled and working fine. Does anyone know how to disable screen blanking with VNC please?
ben :D

DirtyArray
Posts: 1
Joined: Thu Mar 23, 2017 4:21 pm

Re: How to disable screen timeout? Raspbian Jessie

Thu Mar 23, 2017 4:24 pm

I have the exact same problems. I have already written the neccessary xset commands into LXDE-pi/autostart and LXDE/autostart, set the boot parameter, put it into an .xinitrc. Nothing works. After X starts up, I have to login and run the commands on the CLI, then it works. I also need to have VNC enabled.

If anyone finds a solution, I'd be grateful.

User avatar
tatxen
Posts: 4
Joined: Thu Mar 09, 2017 3:47 pm

Re: How to disable screen timeout? Raspbian Jessie

Sun Apr 16, 2017 9:14 pm

Create archive /etc/X11/xorg.conf with this content:

Code: Select all

Section "ServerFlags"
Option "blank time" "0"
Option "standby time" "0"
Option "suspend time" "0"
Option "off time" "0"
EndSection 
Save and restart.

Option "BlankTime" "time"
sets the inactivity timeout for the blanking phase of the screensaver. time is in minutes. This is equivalent to the Xorg server's `-s' flag, and the value can be changed at run-time with xset(1x) . Default: 10 minutes.
Option "StandbyTime" "time"
sets the inactivity timeout for the "standby" phase of DPMS mode. time is in minutes, and the value can be changed at run-time with xset(1x) . Default: 20 minutes. This is only suitable for VESA DPMS compatible monitors.
Option "SuspendTime" "time"
sets the inactivity timeout for the "suspend" phase of DPMS mode. time is in minutes, and the value can be changed at run-time with xset(1x) . Default: 30 minutes. This is only suitable for VESA DPMS compatible monitors.
Option "OffTime" "time"
sets the inactivity timeout for the "off" phase of DPMS mode. time is in minutes, and the value can be changed at run-time with xset(1x) . Default: 40 minutes. This is only suitable for VESA DPMS compatible monitors.

Font: ftp://www.x.org/pub/X11R6.7.0/doc/xorg. ... html#sect0

gnored
Posts: 2
Joined: Thu Sep 29, 2016 10:03 pm

Re: How to disable screen timeout? Raspbian Jessie

Tue Jul 18, 2017 9:56 pm

Thanks to tatxan. It's the only solution that has worked for me, and I thought I'd tried them all!

srinusakamuri1
Posts: 1
Joined: Thu Jan 25, 2018 11:12 am

Re: How to disable screen timeout? Raspbian Jessie

Thu Jan 25, 2018 11:16 am

adding xserver-command=X -s 0 -dpms to /etc/lightdm/lightdm.conf solved the screen timeout issue on Raspeberry Pi !

User avatar
Grumpy Mike
Posts: 1005
Joined: Sat Sep 10, 2011 7:49 pm
Location: English Lake District

Re: How to disable screen timeout? Raspbian Jessie

Mon Apr 23, 2018 4:16 pm

Dosn't work on the new OS for the V3B+ Pi

Return to “Raspberry Pi OS”