User avatar
Posts: 65
Joined: Tue Jun 24, 2014 1:16 am
Location: computer

uae4all2 (Amiga emulator)

Sat Jun 28, 2014 5:29 pm

update 21.5.2015: - deprecation notice -

i pulled my build as
chips version is not only faster, because of using
native dispmanx acceleration, it's even more polished
all around!

so use his version from

thanks for reading & have fun!
- rSl
Last edited by rSl on Wed May 20, 2015 11:40 pm, edited 5 times in total.

User avatar
Forum Moderator
Forum Moderator
Posts: 6802
Joined: Mon Mar 04, 2013 6:12 pm
Location: Bristol, U.K.

Re: uae4all2 (Amiga emulator)

Sat Jun 28, 2014 5:56 pm

Edited post title to make things clearer - I had to google what "uae4all2" was "all" about :)
Still running Raspbian Jessie or Stretch on some older Pi's (an A, B1, 2xB2, B+, P2B, 3xP0, P0W, 2xP3A+, P3B, B+, and a A+) but Buster on the P3B+, P4B's & P400. See:

User avatar
Posts: 65
Joined: Tue Jun 24, 2014 1:16 am
Location: computer

Re: uae4all2 (Amiga emulator)

Sat Jun 28, 2014 6:20 pm


Posts: 1667
Joined: Mon Oct 29, 2012 2:07 pm

Re: uae4all2 (Amiga emulator)

Sun Jun 29, 2014 8:10 am

Welcome to the Forum! Many improvements over UAE4ALL including increased performance and the GUI is neater allowing 'multiple' Floppy Drives without any fuss. Software is also emulated more accurately with CinemaWare Titles for instance, now running without glitches in Cut Scenes and the infamous 'Juggler' Demo also renders correctly (in UAE4ALL there were heavy graphical errors). For those wanting to Test this new version, it seems the GUI Library needs to be downloaded from the Repos (note to rSI, many users tend not to look at README files lol!) so before running the program*

Type - sudo apt-get install libguichan-0.8.1-1
Type - sudo apt-get install libguichan-sdl-0.8.1-1

*Don't forget to run 'sudo apt-get update' if you have a Fresh Wheezy Image

Note: For 'Fullscreen' run the amiga script rather than the uae4all Binary (which is the cog/gear Symbol)
Type - ./amiga

I will also add this to the Emulation on the Raspberry Pi Thread. Nice Work!
"The list of things I have heard now contains everything!"

Posts: 91
Joined: Sun Jun 29, 2014 7:12 pm

Re: uae4all2 (Amiga emulator)

Sun Jun 29, 2014 7:23 pm


Many thanks for this, I just got it working!!

I had to sudo chmod +x amiga & unae4all for it to run. I am not a linux expert so there might have been ways around this.

I just need to sort out the keys for using with my Bartop Arcade. Using this emulator with my OUYA we did find some SDL keys (included at the bottom)

Is there anyway to change these keys? On my bartop I have LCTRL & LALT, but I have it set-up for MAME4ALL, FBA etc etc etc.

'1'- <Button A> autofire [HOME]
'2'- <Button B> Right mouse click [END]
'3'- <Button X> joystick fire/left click [PAGEDOWN]
'4'- <Button Y> [PAGEUP]
'5' <Button L> [SDLK_RSHIFT]
'6' <Button R> [SDLK_RCTRL]
old textUI vkeybd - '2'+'4'

SDL keycode action:
F15 textUI vkeybd
LCTRL - emulator menu toggle
LALT - change input method

Posts: 91
Joined: Sun Jun 29, 2014 7:12 pm

Re: uae4all2 (Amiga emulator)

Sun Jun 29, 2014 8:39 pm


There seems to be something up with the Custom Controls.

If I edit the controls using the GUI to my controls they don't do anything.
I have checked the uaeconfig.conf file that was generated and the keycodes seem wrong for RPI.
For example I have B = Right Control (keycode 97) but in the .conf it is shown as 32?
Up = Arrow Up (normally 103) but .conf shows it as 1

Any idea?


Posts: 94
Joined: Sat Feb 01, 2014 9:02 pm

Re: uae4all2 (Amiga emulator)

Sun Jun 29, 2014 9:14 pm

amiga1200gamer here (EAB) .
Looking over your readme, Mousemovement shouldn't crash the GUI. Id recommend you compile guichan from the 03012014 source (released with the uae4all2 source)
Should be able to run the built library in your bundled sdl folder.

Not sure why you need to change realtime priorities chrt... you must have a lot of background tasks!

Custom control/keymapping doesnt work on raspberry pi through the menus (yet). Keymaps can only be changed through the source code. Custom Joystick mapping isn't in, its just the default 2 buttons.

I've been busy the last few weeks but ill get back into this project soon. I have some success with dispmanx built into uae4all2 but it is breaking the not sure how to get dispmanx working with guichan right now- I will be prioritising looking at this before looking at controls and extras.

If i remember i had some problems setting up Hard drive support through the menus, but i can confirm hardfiles work fine with a config line such as

Right now this project really is just a few minor code changes to the android port, there is a lot to do for full raspberry pi support (as i mentioned in the eab thread)

Posts: 94
Joined: Sat Feb 01, 2014 9:02 pm

Re: uae4all2 (Amiga emulator)

Sun Jun 29, 2014 9:23 pm


heres the default sdl keys in the source
they are around line 500 in gui.cpp gui_handle_events

dpadUp = keystate[SDLK_UP];
dpadDown = keystate[SDLK_DOWN];
dpadLeft = keystate[SDLK_LEFT];
dpadRight = keystate[SDLK_RIGHT];
buttonA = keystate[SDLK_RSHIFT];
buttonB = keystate[SDLK_RCTRL];
buttonX = keystate[SDLK_PAGEDOWN];
buttonY = keystate[SDLK_PAGEUP];
triggerL = keystate[SDLK_HOME];
triggerR = keystate[SDLK_END];
buttonSelect = keystate[SDLK_LCTRL];
buttonStart = keystate[SDLK_LALT];

User avatar
Posts: 65
Joined: Tue Jun 24, 2014 1:16 am
Location: computer

Re: uae4all2 (Amiga emulator)

Tue Jul 01, 2014 9:26 pm

good to know that it's running fine for you.

and thanks for adding to the emulation sticky thread! :)

as i wrote in the readme (unpacked it to the ftp) i think controls are somewhat hardcoded right now, as amiga(1200)gamer said correctly.
i added the chrt to the amiga wrapperscript because it made my vice emu a lot smoother even with verry low load in the background.
without this i had some slight stutters every 20sec or so and with the chrt trick its supersmooth all the time. so i think this can not hurt for uae4all2 either. :) (will release the vice build next)


Posts: 2
Joined: Mon Jan 07, 2013 7:35 pm

Re: uae4all2 (Amiga emulator)

Mon Nov 17, 2014 10:10 am


Thanks for compiling it for Raspi !

Emulation is a bit slow (but usable) and sound is stuttering. Do you think last version are improving this ? If so, can you compile a new build based on last version ?

My goal is to build a SD image of this directly booting to uae4all2, including a small WB3.1 HDF preinstalled with WHDLoad.

Posts: 1
Joined: Sat Nov 15, 2014 5:51 pm

Re: uae4all2 (Amiga emulator)

Thu Nov 20, 2014 8:23 am

Hi there..

First post :D

I'm very exited about the uae4all v2, and i have it up and running on my B+...
Is it possible to get an estimate on how long before we get an updated version with some better performance (if possible on the RPi) since i'm tired of using my PC as emu.. ;)

I have tried to Mount an .hdf file, but without luck (also in the config files)
I read above that it should Work - maybe my file is corupted ? :)

I'm looking forward for see some improvements on this release, since it's the best so far in terms of A1200 capabilities..!

Best regards from Denmark 8-)

User avatar
Posts: 65
Joined: Tue Jun 24, 2014 1:16 am
Location: computer

Re: uae4all2 (Amiga emulator)

Sat Nov 29, 2014 11:12 pm

welcome on board! :)

<lame_excuse> sorry for replying so late, but i got stuck
in the 80's... ;) </lame_excuse>

i'm going to build the recent version now, so maybe we get
some speedup with this.
my expectation however is that the amigacore is pretty optimized
already so i think the best way for more speed is to
overclock the rpi cpu as fast as it gets.
i'm currenly only running a500 and mostly everything is buttersmooth
with my not overvolted cpu clocked to 900mhz.

i'm only using .adf's so i can not help much with the .hdf
file problem. sounds to me like a corrupted file as it
should work as reported earlier.
does anoher .hdf work ok?

ok, i'm trying to get the build done now, see ya later...

User avatar
Posts: 65
Joined: Tue Jun 24, 2014 1:16 am
Location: computer

Re: uae4all2 (Amiga emulator)

Wed Dec 03, 2014 3:09 am

new build done, for download url see first post.
have fun! :)

Posts: 2
Joined: Wed Dec 03, 2014 7:40 am

Re: uae4all2 (Amiga emulator)

Wed Dec 03, 2014 7:49 am

Thanks - nice work :D

Posts: 19
Joined: Tue Dec 10, 2013 8:59 am

Re: uae4all2 (Amiga emulator)

Wed Dec 03, 2014 9:26 am

First of all I want to thank you for this new Amiga emulator.
Since I have got a Raspberry last year I eagerly tried to get an Amiga emulator working on this hardware. I tried several versions of emulators (thanks to welshy for his uptodate emulator info channel!) but every emulator has its faults and problems. They were not really usable. But I did not give up hope.
Now my dream is getting within reach: Sitting on my couch and playing my favorite Amiga titles! :D
Thank you so much!

At the moment I am trying to get my setup working. I have two questions regarding this:

1) I do not have LCTRL (left strg) on my keyboard (its a small bluetooth keyboard). So I cannot get to the GUI after starting an adf file. How can I get to the emulator menu without this special key? Is it possible to remap this key? Or can I get to the menu with a joystick/gamepad somehow?

2) Is it possible to start an adf file directly within the command line? I tried

Code: Select all

./uae4all file.adf
but this did not work.

Do you have a hint for me?

User avatar
Posts: 65
Joined: Tue Jun 24, 2014 1:16 am
Location: computer

Re: uae4all2 (Amiga emulator)

Thu Dec 04, 2014 12:22 am

i were in the complete same situation when i tried amiga
emulation on the pi at first.

this is the only version i know which runs at least a lot of a500 titles verry well. so i *had* to share this. :)

for x86pc i used fs-uae before, but now i'm sitting on the
couch, just like you hopefully soon, using my wireless mini-keyboard and i love it!

regarding question 1
on my mini-kb i have no RCTRL, arg!
who makes this keyboards without *all* the needed keys?
i look at you riitek. ;)

as this is a unmodified built from the pandora handheld sources, these keys got hardcoded into the source because
they map to the special keys on the pandora keyboard, like left/right shoulderbuttons, start/select and a/b/x/y keys, which makes sense on the pandora but is not so great on other keyboards without these gamecontrols built in.
sadly i'm not a real coder so adding stuff like key-customisation is beyond my skills, sniff.

i had the idea to change the hardcoded values to other
more sane keys, so more users can use this better
with their tiny keyboards.
maybe we can find and agree on some better mapping here?

i have not tested with a gamepad yet, but maybe it works

regarding 2
i think there is no commandline mode.
at least you have to start the uae4all binary via the "amiga" wrapper-script i added, so the supplied libs for guichan
and dispmanx-sdl can be found.

so, what to do now?
i think we have two options.

1) we get a coder who can add customkey config
2) we hardcode a better default mapping ourself

option 1 would be the correct one i guess, but hey... ;)
at least the full source is there on the ftp link so who
in the meantime we should do option 2. or not?

sunjammer wrote:Do you have a hint for me?

Posts: 19
Joined: Tue Dec 10, 2013 8:59 am

Re: uae4all2 (Amiga emulator)

Thu Dec 04, 2014 9:32 am

There is a 3rd option: Buying a new suitable keyboard! ;)

Unfortunately I do not have great programming skills so let us try option 2: remapping hardcoded keys

I will split this subject:

a) key for GUI menu
I would suggest using the key "F12". This key should be on every PC keyboard. And it is not on an Amiga keyboard which only has function keys up to F10. For example vice2.4 (C64 emulator) also uses F12 for the emulator menu.

b) mapping joystick/gamepad
I am using a Wii U Pro controller with my Raspberry as my gamepad. I only have tried Xenon 2 yet. But the controls were somewhat strange. "Fire" is mapped to gamepad button "Y". The d-pad on my gamepad does not work. For direction changes I have to use left axis. The left axis works somehow, but it is nearly unusable. The ship in Xenon 2 drifts to the left the whole time when I do not touch the left axis. Perhaps the axis events which my gampad sends are interpreted as button events or something like that.
nice to have: The "select" and "start" buttons on my gamepad are not used at the moment. Opening the emulator menu using the "select" button an my gamepad would be great!
But I am afraid every joystick/gamepad out there has different mappings. In one case the "select" button could be button number 9 in another case it could be button number 7 or whatever.. So hardcoding button mappings for a joystick/gamepad will work for this special joystick/gamepad but probably not for a different device.

c) custom mapping
Is there any way for testing key/gamepad mapping with the help of those custom mappings? I have read above that custom mappings through then menu do not work. Can I try changing the config file? Do changes to the custom mapping in the config file have any impact?

In the meantime I will do some tests with my setup (-> weekend). Perhaps I will find out something which will help.

User avatar
Posts: 65
Joined: Tue Jun 24, 2014 1:16 am
Location: computer

Re: uae4all2 (Amiga emulator)

Fri Dec 05, 2014 4:48 am

hi sunjammer

regarding a)
i did a new build with a changed keymapping.
the f12 key isn't defined in the sources i think, so i used
f8 (which fits my keyboard nicely).
see the textfile in the "newkeys4you" ftp subdir for more.

at least its doing something!
i haven't tested the gampad right now, but i will give it a
try soon, around xmass i think. :)
maybe you can calibrate the nub via the linux joystick tools
or something like that.

i had no luck with custom-mapping switched on via gui.
when its on i simply get no input.
don,t know if configfile editing will better this, but hey
maybe you find out something new.

so good luck and i hope the new binary gives you some
better usability for a fun "nikolaus". :)

cheers & hohoho,

Posts: 19
Joined: Tue Dec 10, 2013 8:59 am

Re: uae4all2 (Amiga emulator)

Fri Dec 05, 2014 8:35 am


Wow, thank you very much, rSi!
Now I can do some serious testing without a reboot each time I want to test another menu item. :)

I will report back this weekend or on Monday.

PS: In gui.cpp I have seen keystate[SDLK_F12] for toggle fullscreen. So at least the key F12 is used there.

Posts: 19
Joined: Tue Dec 10, 2013 8:59 am

Re: uae4all2 (Amiga emulator)

Mon Dec 08, 2014 9:38 am

I made some testing this weekend. I have not completed the tests yet. But here is a intermediate report:
  • Using F8 to enter the emulator menu does work with the altered version of uae4all! :)
  • Changing the rom path in conf/adfdir.conf results in a constantly changed directory for the rom listing. With that I do not have to click through all directories to find my amiga files anymore.
  • Joystick/gamepad does work. I had to calibrate my gamepad to get it working flawlessly. But after that I can use the left axis and the y-button for fire. Unfortunatly I did not managed to to customize these controls
    yet. But hey: It works! :)
  • It takes a long time (about 30 seconds) until an adf file is loaded and running when loading most of my test adf files. Before that I see a black screen after selecting the file and pressing "Reset" in order to start the file. So please be patient when testing files. They will show up after some time.
  • I made an update of the firmware to the experimental kernel 3.17 using rpi-update. After that the problem described above was solved: The files were loaded immediately. No more waiting for the game showing up.
  • Command line options do not work. I did not find any evidence of this in the source code.
  • Starting an adf file directly with command line does not work.
  • The menu for saving and loading config-files does not work. But using the button for saving a config file for the currently loaded adf file does work. The result is a config file with the same name (*.conf instead of *.adf) inside the conf directory. Inside this you will find more parameters as in the standard config file. Among other entries you will find "df0=path_to_adffile_in_disk_slot_df0".
  • I have tested about 10 different games. All of them started and did work. In one of them I had some graphic glitches.
  • I had no problems using an A500 setup. Using an A1200 setup I had graphic glitches.
  • I had to turn frame skipping on in order to get almost no stuttering. The status line shows 25 fps. I am using a overclock of 1000Mhz.
That is all for the moment.
I now want to test the custom key configuration. Also I want to test using a batch script for loading an adf file directly using a config file.

User avatar
Posts: 65
Joined: Tue Jun 24, 2014 1:16 am
Location: computer

Re: uae4all2 (Amiga emulator)

Mon Dec 08, 2014 4:52 pm

wow, thanks for the indepth testing!

sounds like a real fun & productive amiga winter-weekend! :)
all in all it seemed to be a pretty smooth ride. verry nice!
some notes...

here it remembers the last used directory via gui without
manually editing this file.

nice! my trusty thrustmaster t-wireless pad can't wait any
longer to get in action! :)
nice thing with this pad is that one can change the mapping
of the buttons/sticks directly via the 'remapping' feature
on the pad. just press 'remap' and the two buttons you like
to switch and there you go.

loading delay
had no problem with this, good that kernel 3.17 fixed it for you.

good to know! hadn't tried it out.

same here. for me, my pi is a classic a500, period. ;)

thanks again!
have fun with your shiny new amiga-on-a-pi!

ps. i had a nice 'pinball dreams weekend'.


Posts: 19
Joined: Tue Dec 10, 2013 8:59 am

Re: uae4all2 (Amiga emulator)

Tue Dec 09, 2014 9:33 am

I made a bit more testing:
  • Surprisingly save states do work! After loading an adf file it is possible to load and save save states in the appropriate emulator menu. After restarting the emulator and reloading the same adf file the save states are still present. The save states are saved into the rom directory.
  • I did not get the custom key configuration working. It is possible to change the entries regarding the key customization inside the config file. The number following an entry corresponds to the index number of the drop down box entry in the menu. "-1" means 1 entry above the default entry, "30" equals entry number 30 under the default entry. Nevertheless changing an entry results in incomprehensible behaviour: The appropriate key does not work anymore. At least it does something... ;)
  • Using "df0=" in the config file has no impact. It shoud do something according to the source code but I did not get it working. I will keep trying because I really like the idea if starting a adf file directly (using the Emulationstation for example).
  • My mouse pointer in the emulator menu ist just a small black rectangle. Is this normal?

User avatar
Posts: 65
Joined: Tue Jun 24, 2014 1:16 am
Location: computer

Re: uae4all2 (Amiga emulator)

Wed Dec 10, 2014 1:12 am

yay for savestates working! good to know!
mousepointer looks the same here, maybe some bitmap
missing upstream.

good hunt!

Posts: 29
Joined: Sun Oct 26, 2014 9:40 am
Location: Planet Earth

Re: uae4all2 (Amiga emulator)

Thu Dec 11, 2014 7:27 pm

Where did you get the original source from?
Would it be an idea to host it in a github so there can be some collaboration?

User avatar
Posts: 65
Joined: Tue Jun 24, 2014 1:16 am
Location: computer

Re: uae4all2 (Amiga emulator)

Thu Dec 11, 2014 10:09 pm

hi sphaero,

devs are always welcome!
as the source is gpl there should be no problem
to host it on a github.

the uae4all-src.tgz (on the first post ftp link) contains:

1. unmodified pandora uae4all source.
it comes from pandora dev tomb, released on (may need board
account for dl) ... e4all-2510

2. unmodified but somehow 'bugfixed' version of guichan
released together with uae4all src from tomb (see 1 for url)

3. unmodified rpi dispmanx sdl source
comes from vanfanel's github at

4. rpi makefile from amiga(1200)gamer
from lubomyr's github at

lubomyr does the android port of uae4all and contributed the
guichan gui to tomb's 'upstream' version when i understand things correctly.

lubomyr's github already contains the
(unmodified) latest pandora source from tomb in his uae4all github under the /src directory. the files added around this
are for onscreen android touch-control and the android makescripts.

there is a development thread for rpi on abime which
is monitored by lubomyr regularly at

the only thing i did change in the uae4all latest
'newkeys4you' version i built (see posts above) is to
change some keyboardmapping defaults in 2 src files.
i will make a patchfile for this and put it into the
next src.tgz.

i can see that a 'forked on github' rpi version
makes sense for adding more rpi stuff like changed keyboard
layouts etc.

if you want to do this it would be nice to inform tomb and lubomyr first and then go for it.

the thing i can contribute at this time is the keyboardmapping-patch.
all other parts are 'vanilla upstream' right now. :)


sphaero wrote:Where did you get the original source from?
Would it be an idea to host it in a github so there can be some collaboration?

Return to “Gaming”