Posts: 1
Joined: Sat Oct 05, 2013 10:24 pm

Initial Problem

Sat Oct 05, 2013 10:33 pm


I'm new to the Raspberry Pi and tried to power my B model up for the first time this evening, using a 16GB Class 10 SanDisk Ultra SDHC card (according to a listing on wikipedia, this has been successfully tested with the Pi and the default OS). I formatted it using the recommended tool, unzipped and copied across the NOOBS v1.3 files and powered on the Pi with SD card and various peripherals attached. I chose to install the recommended OS (Raspbian) and this completed successfully. Upon clicking OK after OS install, the screen goes black, no output is then read from the Pi.

Powering on/off brings up the rainbow screen, followed by the Pi logo, plus press shift option. If I press shift I can reinstall an OS if desired. If I don't press shift I get a dark black screen of nothingness again (after a semi green flicker). The green light on the Pi comes on when I first plug the power in, but all I get after that is red. The keyboard also loses power. Is this a power issue from the USB ports to the mouse (bluetooth wireless device) and keyboard (Microsoft wired)? Or is something else going on? I have tried reformatting the SD card in my laptop and reinstalling the OS to no avail. I'm using a 5v (1 amp) power supply - mobile phone charger.

Any help would be hugely appreciated, many thanks in advance.

Posts: 1337
Joined: Sat Dec 17, 2011 5:05 pm

Re: Initial Problem

Sun Oct 06, 2013 6:43 pm

Have you tried the raw Raspbian img without NOOBS?
SBC with 32GB RAM: https://hardkernel.com

FAQ : https://raspberrypi.stackexchange.com

Unanswered: https://www.raspberrypi.org/forums/search.php?search_id=unanswered

Posts: 366
Joined: Tue Aug 20, 2013 9:11 pm

Re: Initial Problem

Sun Oct 06, 2013 7:58 pm

It appears that some Laptop SDCard Readers can cause issues, though as suggested first try a Raspbian Wheezy Image.

I bought a USB Card Reader for a £1 from Poundland !
Searching is easy, most questions have been asked before !

Posts: 19
Joined: Wed Jul 10, 2013 10:02 pm
Location: S.California

Re: Initial Problem

Sun Oct 06, 2013 9:06 pm

I don't use NOOBS but have some frustrations with beginning using the rpi. The main problem has been with power supply causing weird failures I couldn't identify. After changing to a stronger PS, nearly all strange things have gone away. So some suggestions.

If you are using a usb hub, it must have its own power supply. Each port should put out at least 500ma fully loaded. I have a little D-Link 7 port powered hub DUB-H7 with 3A power supply. 2 of the ports have especially high amps for charging cell phones etc., but can also be used for normal data. I use one of these ports to attach a 2.5" usb-connected hardrive sometimes. I can run the rpi plugged into one of these ports, but the voltage test points show just under the minimum 4.75v required, so I use a separate 2A (2000ma) ps for the rpi. I've even moved the wifi dongle over to the hub so the only usb connection to the rpi is to the powered usb hub.

If you are using an unpowered usb hub plugged directly into the rpi, with keyboard, mouse, usb wifi, etc., and a "1 amp ps" you will have reliability problems sooner or later.


Return to “Beginners”