Page 1 of 1

Can't set up ralink wifi dongle

Posted: Tue Feb 11, 2014 9:57 pm
by Ricardo Neves
Hi everyone.
This is my first post here.
I bought a cheap usb wifi dongle( Like this one: ... ano_09.jpg) from ebay and I tried a couple of tutorials but I can't make it work.
I have 2 operative systems, raspbian and openelec. I started by going to raspbian, open terminal and I ran some commands to update the raspberry pi, then I used "lsusb" and I found a line with "ralink"(Probably the wifi adapter) but it has nothing related to model or whatever like I saw in many tutorials. Then I edited a couple of files to provide my network details, I restarted raspberry pi but still not working.
Can anyone help me with this?

PS: When I got the wifi working on raspbian it is going to work on openelec or do I have to repeat the same steps on openelec?

Thanks in advance.

Re: Can't set up ralink wifi dongle

Posted: Wed Feb 12, 2014 8:42 pm
by Ricardo Neves
I figured out the model, it's Ralink 7601. Any help or should I just buy a new one?

I've searching for some good usb wifi dongle? which ones do you recommend?
What do you think about this one: ... 2c7856761d
Does it have a better compatibility than the ralink 7601?

Re: Can't set up ralink wifi dongle

Posted: Wed Feb 12, 2014 9:20 pm
by Bazzer
Have a read through the post at ... 28&t=44044

I had problems with my Realtek and had to follow the post at ... 82#p462982 as kindly pointed out by MrEngman. I have a Realtek and you have a ralink so they are different but check if the lsmod sees your module at least.

I would post lsusb, lsmod, dmesg and ifconfig -a outputs to your thread and see if others can spot the issue.