K1tty
Posts: 13
Joined: Sun Oct 27, 2019 8:30 am

DFRobot CM4 Router and OpenVPN

Sun Sep 19, 2021 7:38 pm

Hi All,

I have a DFRobot CM4 Router board. I installed the OpenWRT image which worked fine so I decided to go ahead and install OpenVPN (from these instructions https://www.ovpn.com/en/guides/openwrt). I need OpenVPN for my project.

I managed to install luci-app-openvpn but not openvpn-openssl. It came up with what I think is a kernel version issue. Specifically it says:

Details for package openvpn-openssl
Version: 2.5.3-3
Size: ~232.4 KB installed
Dependencies:
kmod-tun (27.7 KB) NOT INSTALLED
kernel VERSION INCOMPATIBLE
liblzo2 (39.1 KB) NOT INSTALLED
libopenssl1.1 (1.3 MB) NOT INSTALLED
Description
Open source VPN solution using OpenSSL
The installed version of package kernel is not compatible, require 5.4.143-1-deb45357... while
5.4.108-1-79565365... is installed

Overwrite files from other package(s) Cancel Install

Does anyone know how to fix this? Is it simple? Can one simply select the 'Overwrite files from other package(s)' option? Or does one need a PhD in computer science?

Thanks!
Bob
The question is not whether something can be done on a Raspberry Pi - it's about whether Jeff Geerling is crazy enough to try it!

Return to “Compute Module”