chief_beef
Posts: 2
Joined: Tue Dec 30, 2014 6:28 pm

[Raspbian] MPD -- random error

Tue Dec 30, 2014 6:49 pm

Good evening.

My Raspberry Pi has functioned incredibly well as an mpd server since April. Today, however, it decided to throw a random error my way:

Code: Select all

Inconsistency detected by ld.so: dynamic-link.h: 190: elf_get_dynamic_info: Assertion `info[20]->d_un.d_val == 17 || info[20]->d_un.d_val == 7' failed!
and mpd will not start. This error occurs when I run "mpd", or "sudo service mpd start".
It has also appeared after a reinstall (purge, then install):

Code: Select all

The following NEW packages will be installed:
  mpd
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/195 kB of archives.
After this operation, 471 kB of additional disk space will be used.
debconf: apt-extracttemplates failed: No such file or directory
Selecting previously unselected package mpd.
(Reading database ... 81512 files and directories currently installed.)
Unpacking mpd (from .../mpd_0.16.7-2_armhf.deb) ...
Processing triggers for man-db ...
Setting up mpd (0.16.7-2) ...
[....] Starting Music Player Daemon: mpdInconsistency detected by ld.so: dynamic-link.h: 190: elf_get_dynamic_info: Assertion `info[20]->d_un.d_val == 17 || info[20]->d_un.d_val == 7' failed!
 failed!
invoke-rc.d: initscript mpd, action "start" failed.
dpkg: error processing mpd (--configure):
 subprocess installed post-installation script returned error exit status 127
Errors were encountered while processing:
 mpd
E: Sub-process /usr/bin/dpkg returned an error code (1)
I've hit a wall, although it seems like some shared libraries (ld.so) may be the culprit. I just don't know how to diagnose it further. My log file only shows some recent songs I had been listening to.

Please help .__.

chief_beef
Posts: 2
Joined: Tue Dec 30, 2014 6:28 pm

Re: [Raspbian] MPD -- random error

Tue Dec 30, 2014 7:27 pm

okay, it works now...for an inconspicuous reason...I'll provide the steps I took to "solve" this issue, although there really isn't any meaningful way for me to know or explain what-fixed-what:

1) purged mpd [again]
2) ran moc to make sure my alsa libs/bins weren't corrupted; Led Zeppelin III played without problems
3) reboot
4) post-reboot, installed mpd; this time, it successfully booted.

Sorry to "cry wolf" about this. I could find no meaningful insights about similar issues elsewhere on the web, and I've noticed that Pi apps tend to just break (had a similar issue with NTP not long ago).

Hopefully this helps someone else at some point.

Asampaiz
Posts: 10
Joined: Mon Feb 01, 2016 9:43 am

Re: [Raspbian] MPD -- random error

Tue Jul 26, 2016 12:20 pm

From my experience, this is caused by corrupt Micro/SD Card or the file system. The solution is try to do a disk check using fsck to make sure, or change the card with the new one.

squan888
Posts: 1
Joined: Sun Jan 29, 2017 7:30 pm

Re: [Raspbian] MPD -- random error

Sun Jan 29, 2017 8:01 pm

I'm using the Raspberry Pi 3 as an internet radio with mpd / mpc play.

I can get between, typically, somewhere between 3 minutes to 3 hour before suddenly, the stream pauses. If I do a mpc stop && mpc play, the mpc play command locks indefinitely. The only thing I can do to restore things is sudo service mpd restart && mpc play and everything repeats.

I've encountered this with Jessie and have rebuilt the internet radio on different SD cards.

I built this project over a year ago with an older OS without this problem.

/var/log/mpd/mpd.log doesn't appear to report anything out of the ordinary.

Return to “Troubleshooting”