Posts: 36
Joined: Fri Jun 01, 2012 6:54 pm

cloning Kernel - Fatal error

Thu Jul 19, 2012 9:56 am

i am trying to get usbip working and if i use the howto from secretagent ... 91#p121691 i have to use git to clone the kernel

Code: Select all

sudo apt-get install git
git clone git:// kernel
but i get all the time this error

Code: Select all

]Recieving Objects: 100% ("some numbers") , 465,76Mb
Error: index-pack died of Signal  901563)     901563)
Fatal: index-pack failed
The number after signal changes with every try.

I used the wheezy beta image with updates (apt-get update, apt-get upgrade, aptitude update, aptitude upgrade and 2 times i also use the hexxa updater for the kernel update.
I tried different sd cards - but all the time i used the raspi-config script to use all available space on the sdcard (perhaps this is wrong?)

Anybody nows whats wrong here? My pi or git or something else?

User avatar
Posts: 10808
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK
Contact: Twitter YouTube

Re: cloning Kernel - Fatal error

Thu Jul 19, 2012 10:02 am

possibly you are running out of memory,
if this is on a RPi then
configure a swapfile or enable a swap partition.
the RPi is set to low swapiness so will only use it if needed.
How To ask Questions :-
WARNING - some parts of this post may be erroneous YMMV


Posts: 36
Joined: Fri Jun 01, 2012 6:54 pm

Re: cloning Kernel - Fatal error

Fri Jul 20, 2012 6:53 am

Thanks, it seems that this was the problem.

I found an how to on this page ... y-pi-setup
To create the swapfile;

sudo dd if=/dev/zero of=/var/swapfile bs=1M count=128

This creates a 128MB file filled with zeros called /var/swapfile, and might take a little while depending on the speed of your card.

sudo mkswap /var/swapfile (to setup the file as swap space)

sudo swapon /var/swapfile (to enable the swap space, this also might take a little while.)

sudo reboot

All thats left now is to edit /etc/fstab and tell the system to mount the file as swap every time it starts up;

sudo nano /etc/fstab

Whilst in nano, delete the line starting with a hash (#), and paste or type in:

/dev/mmcblk0p2 / ext4 defaults,noatime,nodiratime 0 0

/var/swapfile none swap sw 0 0

This tells the system to mount the 2nd partition at / in the filesystem, and to mount it with “noatime,nodiratime”, meaning the system will not write when files and directories were last accessed, speed things up a bit. The next line also tells the system to mount the swapfile we made. This file is read at boot time, and tells the system to mount the stated devices automatically each time the system is booted.

“CTRL+W” then “Y” to exit nano and save changes, and then a final reboot is all that’s needed.
and after that it worked!

Thanks for the tip!

Return to “Troubleshooting”