serozhax
Posts: 6
Joined: Fri Jun 29, 2018 7:41 am

A/V connection problem

Fri Jun 29, 2018 7:57 am

Hi friends!
I have the Raspberry PI 3 B+.
I can't connect it whith TV via A/V output. There isn't a picture on TV.
I bought cable for MP3 player and little modified it like on schema on internet. Multimeter test is OK.
Maybe I should edit some setings on device?
Help me please.

User avatar
DougieLawson
Posts: 41958
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: A/V connection problem

Fri Jun 29, 2018 11:06 am

https://www.raspberrypi-spy.co.uk/2014/ ... ideo-jack/

What's your TV standard? The default if you add nothing to /boot/config.txt is that the AV video is NTSC 60Hz 480i.
Languages using left-hand whitespace for syntax are ridiculous

DMs sent on Twitter/LinkedIn will be answered next month.
Fake doctors - are all on my foes list.

The use of crystal balls and mind reading is prohibited.

serozhax
Posts: 6
Joined: Fri Jun 29, 2018 7:41 am

Re: A/V connection problem

Fri Jun 29, 2018 11:36 am

DougieLawson wrote:
Fri Jun 29, 2018 11:06 am
https://www.raspberrypi-spy.co.uk/2014/ ... ideo-jack/

What's your TV standard? The default if you add nothing to /boot/config.txt is that the AV video is NTSC 60Hz 480i.
I followed this instruction.
And how can I find standard of my TV? It's model LG 21FS2CG-TS

User avatar
DougieLawson
Posts: 41958
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: A/V connection problem

Fri Jun 29, 2018 12:21 pm

What country are you in?

add

Code: Select all

sdtv_mode=2
sdtv_aspect=1
That sets it to PAL 50Hz 576i 4:3.
Languages using left-hand whitespace for syntax are ridiculous

DMs sent on Twitter/LinkedIn will be answered next month.
Fake doctors - are all on my foes list.

The use of crystal balls and mind reading is prohibited.

fruitoftheloom
Posts: 27226
Joined: Tue Mar 25, 2014 12:40 pm

Re: A/V connection problem

Fri Jun 29, 2018 12:59 pm

serozhax wrote:
Fri Jun 29, 2018 11:36 am
DougieLawson wrote:
Fri Jun 29, 2018 11:06 am
https://www.raspberrypi-spy.co.uk/2014/ ... ideo-jack/

What's your TV standard? The default if you add nothing to /boot/config.txt is that the AV video is NTSC 60Hz 480i.
I followed this instruction.
And how can I find standard of my TV? It's model LG 21FS2CG-TS

SDTV Modes

https://www.raspberrypi.org/documentati ... t/video.md
Take what I advise as advice not the utopian holy grail, and it is gratis !!

serozhax
Posts: 6
Joined: Fri Jun 29, 2018 7:41 am

Re: A/V connection problem

Fri Jun 29, 2018 1:29 pm

DougieLawson wrote:
Fri Jun 29, 2018 12:21 pm
What country are you in?

add

Code: Select all

sdtv_mode=2
sdtv_aspect=1
That sets it to PAL 50Hz 576i 4:3.
I'm from Russia

drgeoff
Posts: 12563
Joined: Wed Jan 25, 2012 6:39 pm

Re: A/V connection problem

Fri Jun 29, 2018 1:48 pm

Russia choose to follow France and use SECAM. However most TVs that can decode SECAM also decode PAL.

In any case, it is extremely rare that the wrong* setting of sdtv_mode in config.txt will of itself be the reason for nothing appearing on a TV screen.

(* Even 525/625)
Last edited by drgeoff on Fri Jun 29, 2018 1:50 pm, edited 1 time in total.
Quis custodiet ipsos custodes?

fruitoftheloom
Posts: 27226
Joined: Tue Mar 25, 2014 12:40 pm

Re: A/V connection problem

Fri Jun 29, 2018 1:50 pm

serozhax wrote:
Fri Jun 29, 2018 7:57 am
Hi friends!
I have the Raspberry PI 3 B+.
I can't connect it whith TV via A/V output. There isn't a picture on TV.
I bought cable for MP3 player and little modified it like on schema on internet. Multimeter test is OK.
Maybe I should edit some setings on device?
Help me please.

Cable issue ???

https://www.raspberrypi-spy.co.uk/2014/ ... ideo-jack/
Take what I advise as advice not the utopian holy grail, and it is gratis !!

pksato
Posts: 295
Joined: Fri Aug 03, 2012 5:25 pm
Location: Brazil

Re: A/V connection problem

Fri Jun 29, 2018 2:02 pm

Hi,
Or need to force composite output disabling HDMI.

Code: Select all

hdmi_ignore_hotplug=1
From wikipedia Russia use Secam as ATV color system. But, LG TV also is compatible with PAL.

drgeoff
Posts: 12563
Joined: Wed Jan 25, 2012 6:39 pm

Re: A/V connection problem

Fri Jun 29, 2018 2:03 pm

1. Is the RPi actually booting?

2. Ensure nothing is plugged in to the RPi's HDMI socket when powering up.

3. What OS is on the card? Has NOOBS been used?
Quis custodiet ipsos custodes?

serozhax
Posts: 6
Joined: Fri Jun 29, 2018 7:41 am

Re: A/V connection problem

Fri Jun 29, 2018 2:27 pm

drgeoff wrote:
Fri Jun 29, 2018 2:03 pm
1. Is the RPi actually booting?

2. Ensure nothing is plugged in to the RPi's HDMI socket when powering up.

3. What OS is on the card? Has NOOBS been used?
1. I have updated system today.
2. Nothing is plugged in to the RPi's HDMI socket.
3. OS Raspbian. Installed without NOOBS.

Maybe there is cable issue... But I checked it for many times...
1 - Video
2 - Ground
3 - Right Audio
4 - Left Audio

serozhax
Posts: 6
Joined: Fri Jun 29, 2018 7:41 am

Re: A/V connection problem

Fri Jun 29, 2018 2:39 pm

pksato wrote:
Fri Jun 29, 2018 2:02 pm

From wikipedia Russia use Secam as ATV color system. But, LG TV also is compatible with PAL.
How to set it up? SECAM instead PAL.

drgeoff
Posts: 12563
Joined: Wed Jan 25, 2012 6:39 pm

Re: A/V connection problem

Fri Jun 29, 2018 2:46 pm

serozhax wrote:
Fri Jun 29, 2018 2:39 pm
pksato wrote:
Fri Jun 29, 2018 2:02 pm

From wikipedia Russia use Secam as ATV color system. But, LG TV also is compatible with PAL.
How to set it up? SECAM instead PAL.
TVs can often automatically switch between PAL and SECAM.

But even if the PAL/SECAM setting is not correct you would get a black and white display.

You did not confirm that the RPi is booting.
Quis custodiet ipsos custodes?

serozhax
Posts: 6
Joined: Fri Jun 29, 2018 7:41 am

Re: A/V connection problem

Fri Jun 29, 2018 2:55 pm

pksato wrote:
Fri Jun 29, 2018 2:02 pm

Code: Select all

hdmi_ignore_hotplug=1
IT WORKS!!!! Thank you!!!

P.S. If i want connect HDMI must I change this setting?

pksato
Posts: 295
Joined: Fri Aug 03, 2012 5:25 pm
Location: Brazil

Re: A/V connection problem

Fri Jun 29, 2018 5:26 pm

serozhax wrote:
Fri Jun 29, 2018 2:55 pm
pksato wrote:
Fri Jun 29, 2018 2:02 pm

Code: Select all

hdmi_ignore_hotplug=1
IT WORKS!!!! Thank you!!!

P.S. If i want connect HDMI must I change this setting?
Yes, need to set to 0 or comment or remove the line.

klricks
Posts: 8191
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA

Re: A/V connection problem

Fri Jun 29, 2018 9:47 pm

serozhax wrote:
Fri Jun 29, 2018 2:55 pm
pksato wrote:
Fri Jun 29, 2018 2:02 pm

Code: Select all

hdmi_ignore_hotplug=1
IT WORKS!!!! Thank you!!!

P.S. If i want connect HDMI must I change this setting?
When using the default settings of Raspbian (Not NOOBS), the RPi will automatically use HDMI if connected at boot. If no HDMI is connected then the RPi will automatically switch to composite (AV) on boot.
You only need to change the setting for PAL:

Code: Select all

sdtv_mode=2
Unless specified otherwise my response is based on the latest and fully updated RPi OS Bullseye w/ Desktop OS.

Return to “Troubleshooting”