Celestial
Posts: 3
Joined: Wed Jun 26, 2019 1:41 pm

Firefox Pi 4

Mon Jul 08, 2019 11:59 am

Hello!!

Total noob here.

I'm trying to install Firefox on my Pi 4 with Noobs/Raspian but it won't work.

sudo apt-get update
sudo apt-get upgrade

and then

sudo apt-get install firefox-esr

But I get this error

1 http://raspbian.raspberrypi.org/raspbian buster/main armhf firefox-esr armhf 60.6.3esr-1+rpi1
404 Not Found

Is there another way to get it?

User avatar
neilgl
Posts: 4462
Joined: Sun Jan 26, 2014 8:36 pm
Location: Near The National Museum of Computing

Re: Firefox Pi 4

Mon Jul 08, 2019 12:11 pm

Try it again now - it is working ok for me

Celestial
Posts: 3
Joined: Wed Jun 26, 2019 1:41 pm

Re: Firefox Pi 4

Mon Jul 08, 2019 12:15 pm

neilgl wrote:
Mon Jul 08, 2019 12:11 pm
Try it again now - it is working ok for me
Nope. Still the same error

User avatar
neilgl
Posts: 4462
Joined: Sun Jan 26, 2014 8:36 pm
Location: Near The National Museum of Computing

Re: Firefox Pi 4

Mon Jul 08, 2019 12:33 pm

OK what is in your /etc/apt/sources.list
Might need to add a mirror local to you.

grayerbeard
Posts: 7
Joined: Mon Jul 08, 2019 3:37 pm

Re: Firefox Pi 4

Mon Jul 08, 2019 3:42 pm

I am having the same issue and it cannot be the repository address as I have managed to install two other applications without any problem,

My error is .....

sudo apt-get install firefox-esr
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following package was automatically installed and is no longer required:
libreoffice-gtk2
Use 'sudo apt autoremove' to remove it.
Suggested packages:
fonts-stix | otf-stix fonts-lmodern pulseaudio
The following NEW packages will be installed:
firefox-esr
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 35.9 MB of archives.
After this operation, 142 MB of additional disk space will be used.
Err:1 http://raspbian.raspberrypi.org/raspbian buster/main armhf firefox-esr armhf 60.6.3esr-1+rpi1
404 Not Found [IP: 93.93.128.193 80]
E: Failed to fetch http://raspbian.raspberrypi.org/raspbia ... _armhf.deb 404 Not Found [IP: 93.93.128.193 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

User avatar
5t4n5
Posts: 40
Joined: Mon Jul 01, 2019 5:22 pm
Location: Near a beach in Devon

Re: Firefox Pi 4

Mon Jul 08, 2019 3:46 pm

I added it using the add program thing on the main menu.
Honestly, i've no idea what i'm doing. :oops:

User avatar
neilgl
Posts: 4462
Joined: Sun Jan 26, 2014 8:36 pm
Location: Near The National Museum of Computing

Re: Firefox Pi 4

Mon Jul 08, 2019 4:22 pm

Can you post what is in your /etc/apt/sources.list

grayerbeard
Posts: 7
Joined: Mon Jul 08, 2019 3:37 pm

Re: Firefox Pi 4

Mon Jul 08, 2019 6:15 pm

I just found the solution to my difficulty with installing Firefox on R Pi 4.

The cure is described at http://eriberto.pro.br/blog/2019/07/07/ ... to-stable/

Essentially if you enter " # apt-get --allow-releaseinfo-change update"

Then do ... upgrade"

Then install Firefox works OK.

blades2ko
Posts: 1
Joined: Tue Jun 16, 2020 11:29 pm

Re: Firefox Pi 4

Tue Sep 01, 2020 11:00 pm

I am getting the same error this is whats in /etc/apt/sources.list.d


Raspi.list

deb http://archive.raspberrypi.org/debian/ buster main
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://archive.raspberrypi.org/debian/ buster main

Not sure what to do.

NOOB

neilparker62
Posts: 10
Joined: Sat Nov 21, 2020 5:24 pm

Re: Firefox Pi 4

Mon Jan 18, 2021 10:22 am

Surely - with a reasonably up to date version of rasbian-os , we should not be having basic problems accessing repositories ?? First I thought it was to do with ipv6 so I disable ipv6. Now I get following when trying to install firefox-esr:

Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
libexiv2-14 libgfortran3 libgmime-2.6-0 libncurses5 libssl1.0.2 uuid-dev
Use 'sudo apt autoremove' to remove them.
Suggested packages:
fonts-stix | otf-stix fonts-lmodern pulseaudio
The following NEW packages will be installed:
firefox-esr
0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
Need to get 48.9 MB of archives.
After this operation, 180 MB of additional disk space will be used.
Err:1 http://raspbian.raspberrypi.org/raspbian buster/main armhf firefox-esr armhf 78.6.0esr-1~deb10u1+rpi1
404 Not Found [IP: 93.93.128.193 80]
E: Failed to fetch http://raspbian.raspberrypi.org/raspbia ... _armhf.deb 404 Not Found [IP: 93.93.128.193 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Return to “Beginners”