Posts: 4
Joined: Mon May 03, 2021 4:54 pm

cdc_acm / socat / OctoPrint problems

Thu May 25, 2023 3:58 pm

I tried to run Octoprint in a Container. On the host the Prusa Mini+ is actually connected to I am running socat with the following params:

Code: Select all

ExecStart=/usr/bin/socat -d -d -d TCP4-LISTEN:4000,fork,reuseaddr /dev/ttyACM0,raw,echo=1,b115200
I found out that the cdc_acm-Device /dev/ttyACM0 does not work properly when I try to use it over socat. It worked for several days then it stopped working. Unplugging and replugging the USB cable (from the printer to the socat host which is a RPi 4 running RPi OS BullsEye) helped once. Then it seemed to have stopped working completely. I managed to make it work again by removing the kernel module and re-adding it:

Code: Select all

modprobe -r cdc_acm
modprobe cdc_acm
But that also seemed to work only 1 out of 100 times.

When I install Octoprint locally on the RPi everything works as it should.

So... any ideas what might be wrong with /dev/ttyACM0? Or might my socat params be wrong?

Any hints would be highly appreciated!


User avatar
Posts: 5919
Joined: Fri Jul 22, 2016 9:09 pm
Location: Eberbach, Germany

Re: cdc_acm / socat / OctoPrint problems

Thu May 25, 2023 7:29 pm

I assume you use a "big" Pi as reason why you want to run more than Ocoprint on a single Pi?
If not, I use a dedicated Pi3A+ and just installed "OctoPi" with rpi-imager, and everything worked.
That small RAM Pi is good enough to drive my Prusa Mini+ 3Dprinter, as well as a v1 scene and a USB nozzle camera:

Return to “Advanced users”