Posts: 5
Joined: Sat Sep 18, 2021 5:21 pm

Boot from SSD problems

Mon May 29, 2023 5:07 pm


I'm attempting to boot my Raspberry Pi 4 from a Samsung 250GB SSD, but I've run into a problem. Here's the sequence of steps I've taken thus far:

I ensured my SSD was entirely empty and had a greater storage capacity than my SD card.

I inserted an SD card into my Windows PC and used the Raspberry Pi Imager to write the bootloader with the "USB Boot" option to the SD card.

I inserted the SD card into the Raspberry Pi and powered it up to update the bootloader to support USB boot.

After the Pi booted up successfully from the SD card, I powered it down and removed the SD card.

On my Windows machine, I connected the SSD.

I used the Raspberry Pi Imager to write the Raspberry Pi OS to the SSD.

Once the Raspberry Pi OS was written to the SSD, I disconnected it from the PC and connected it to the Raspberry Pi.

Now, when I power up the Raspberry Pi, it appears to attempt to boot from the SSD. The boot sequence starts, and it displays "Trying to boot mode USB-MSD". But then it doesn't proceed any further. The power LED on the Pi lights up, and the SSD also light up, but the boot sequence doesn't complete, and the Pi never boots up.

(tried to add some photos but couln't because apparently they were "to large").

Does anyone have any suggestions on what could be causing this issue or how I might troubleshoot it further? Any advice or guidance would be greatly appreciated.

Thanks in advance for your help!

User avatar
Posts: 9866
Joined: Fri Jan 13, 2012 4:41 pm
Location: Darkest Somerset, UK

Re: Boot from SSD problems

Mon May 29, 2023 5:49 pm

For most boot problems start here: viewtopic.php?t=58151

Which model Pi?
What chipset is in your USB/SATA bridge?
What PSU are you using?
How much power does your SSD require?
Knowledge, skills, & experience have value. If you expect to profit from someone's you should expect to pay for them.

All advice given is based on my experience. it worked for me, it may not work for you.
Need help?

Return to “Troubleshooting”