saken
Posts: 12
Joined: Fri Sep 07, 2018 4:55 pm

OMV 6 no permissions after installing Plex

Wed Jun 07, 2023 8:01 pm

I installed Openmediavault 6 on my pi3b.
Went all fine. Transferred some audio files.

Then followed a youtube tuturial on installing Plex. But not I cannot move or delete or whatsoever any files on the network map to my Pi. Keeps saying i dont have permissions. Anyone have an idea how to fix this?

bjtheone
Posts: 2407
Joined: Mon May 20, 2019 11:28 pm
Location: The Frozen North (AKA Canada)

Re: OMV 6 no permissions after installing Plex

Wed Jun 07, 2023 8:38 pm

My crystal ball, though dropped a couple of times and somewhat cloudy, says that either the youtube video was wrong or you did not follow it correctly and broke your install or you are not running Plex correctly.

If you provide a bunch more details such as:

* OS you are running
* how you installed OMV
* how you installed Plex
* link to the tutorial you followed for Plex
* any error messages you are receiving <==== ESEPCIALLY THIS
* any observations of stuff that did not go well
* exactly what you mean by "cannot move of delete any files", from the Pi or from another computer, if another computer what OS is it running

someone might be able to provide more intelligent suggestions.

saken
Posts: 12
Joined: Fri Sep 07, 2018 4:55 pm

Re: OMV 6 no permissions after installing Plex

Wed Jun 07, 2023 9:01 pm

bjtheone wrote:
Wed Jun 07, 2023 8:38 pm
My crystal ball, though dropped a couple of times and somewhat cloudy, says that either the youtube video was wrong or you did not follow it correctly and broke your install or you are not running Plex correctly.

If you provide a bunch more details such as:

* OS you are running
* how you installed OMV
* how you installed Plex
* link to the tutorial you followed for Plex
* any error messages you are receiving <==== ESEPCIALLY THIS
* any observations of stuff that did not go well
* exactly what you mean by "cannot move of delete any files", from the Pi or from another computer, if another computer what OS is it running

someone might be able to provide more intelligent suggestions.
hi,

will provide more info later. I noticed after a restart it does not see the filesystem. when I unplug and replug the usb stick and make new filesystem it is recognised.....

saken
Posts: 12
Joined: Fri Sep 07, 2018 4:55 pm

Re: OMV 6 no permissions after installing Plex

Thu Jun 08, 2023 12:34 pm

bjtheone wrote:
Wed Jun 07, 2023 8:38 pm
My crystal ball, though dropped a couple of times and somewhat cloudy, says that either the youtube video was wrong or you did not follow it correctly and broke your install or you are not running Plex correctly.

If you provide a bunch more details such as:

* OS you are running
* how you installed OMV
* how you installed Plex
* link to the tutorial you followed for Plex
* any error messages you are receiving <==== ESEPCIALLY THIS
* any observations of stuff that did not go well
* exactly what you mean by "cannot move of delete any files", from the Pi or from another computer, if another computer what OS is it running

someone might be able to provide more intelligent suggestions.
Hello BJ,

I installed Raspberry OS lite 64 bit without the desktop interface and enabled SSH in the image software which I ran on my windows PC.
https://pimylifeup.com/raspberry-pi-openmediavault/ <----- I used this tutorial to install OMV
Install went fine, though failed once when I tried through SSH. When I installed it using an attached keyboard and screen it installed OK. But then I couldn't login the OMV web interface, so had to run a command in SSH to change the password. Then I could login.

Then I tried another tutorial to install Plex through docker, but I couldn't seem to install docker because the OMV-Extras tab said:
Please install the openmediavault-compose to provide docker functionality within the OMV web interface.

Strange thing is the compose plugin was already installed :-/


So I followed a part of another tutorial to install Plex.
This is the tutorial, approx from of this part / time: https://youtu.be/8kwTdjSsqew?t=592

Now I am able to transfer files to the map I shared in OMV. But have permission issues due to the filesystem keep getting disconnected or something when I restart or shutdown the PI. The USB stick (USB2 16gb) is not mounted when I restart. I have to replug the stick and make a new volume. Result? All files wiped on the partition and I have to assign new user / group permissions.

Any clue ? Thanks !

I'm quite a Noob in Linux and just want to have a NAS with Plex setup. Is there any Noob proof solution? Like a preinstalled OMV with bittorent and plex? :-P

Return to “Beginners”