Posts: 1
Joined: Fri Sep 01, 2023 6:38 am

Failure to Launch

Fri Sep 01, 2023 6:56 am

I have a HP Elitedesk 800 G2 mini running Raspberry OS for PC that I use for a PLEX server. Been working fine for a year or two now. Had it down for maintenance, blow out the fan sort of stuff, and when I booted it backup I got a CMOS battery failure. Replaced CMOS battery and reconfigure BIOS from what I remembered the first time I set it up. The results are always the same "No Bootable Device" press F2 for diagnostics. In order to get the system up I booted a supergrub USB drive and selected Operating System and then picked the grubx64.efi from the list. That in turn starts Grub when in turn starts the OS and all is good. So what's the deal? Grub files seems to be intact, I have tried every setting possible in the HP BIOS and still no boot. Will continue to boot from Supergrub for now. Is it a BIOS setting, as far as I can tell it is to old to have a browse function where I could point the UEFI BIOS to the appropriate location. Is it seem piece of code in the PC that has to be refreshed or something in the EFI? Any suggestions would be appreciated.

Return to “Raspberry Pi Desktop for PC and Mac”