nemo87
Posts: 59
Joined: Tue Feb 21, 2017 7:56 am

dac hifi doesn't sing

Tue Nov 28, 2023 2:45 pm

Good evening,
I purchased hifi digipro for my raspberry 4 4gb with the latest version of raspberry pi os installed
I connected the DAC, when I turn on the Rasp the green LED lights up, I connected the Logitech Z906 system to it via analog coaxial cable, and from rapi-config I set the audio output from the speakers but it remains mute...
ss I set the audio signal from the HDMI cable and it can be heard normally (the monotor has speakers), could you tell me how to do it?

terribleted
Posts: 1572
Joined: Tue Oct 06, 2020 8:07 pm

Re: dac hifi doesn't sing

Tue Nov 28, 2023 5:16 pm

did you set the output?
Right-click the volume icon and set the output to whatever you want.
The only people that don't make mistakes are people that don't do anything.

nemo87
Posts: 59
Joined: Tue Feb 21, 2017 7:56 am

Re: dac hifi doesn't sing

Tue Nov 28, 2023 6:13 pm

Yes, the output is set up the right way, I found this guide: https://www.hifiberry.com/docs/software ... checklist/
[nemo@raspberrypi:~ $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: vc4hdmi0 [vc4-hdmi-0], device 0: MAI PCM i2s-hifi-0 [MAI PCM i2s-hifi-0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: vc4hdmi1 [vc4-hdmi-1], device 0: MAI PCM i2s-hifi-0 [MAI PCM i2s-hifi-0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 2: sndrpihifiberry [snd_rpi_hifiberry_digi], device 0: HifiBerry Digi HiFi wm8804-spdif-0 [HifiBerry Digi HiFi wm8804-spdif-0]
Subdevices: 0/1
Subdevice #0: subdevice #0
/quote]

and so I set up the config.txt file
[# For more options and information see
# http://rptl.io/configtxt
# Some settings may impact device functionality. See link above for details

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Enable audio (loads snd_bcm2835)
dtoverlay=hifiberry-digi

# Additional overlays and parameters are documented
# /boot/firmware/overlays/README

# Automatically load overlays for detected cameras
camera_auto_detect=1

# Automatically load overlays for detected DSI displays
display_auto_detect=1

# Automatically load initramfs files, if found
auto_initramfs=1

# Enable DRM VC4 V3D driver
dtoverlay=hifiberry-digi

# Don't have the firmware create an initial video= setting in cmdline.txt.
# Use the kernel's default instead.
disable_fw_kms_setup=1

# Run in 64-bit mode
arm_64bit=1

# Disable compensation for displays with overscan
disable_overscan=1

# Run as fast as firmware / board allows
arm_boost=1

[cm4]
# Enable host mode on the 2711 built-in XHCI USB controller.
# This line should be removed if the legacy DWC2 controller is required
# (e.g. for USB device mode) or if USB support is not required.
otg_mode=1

[all]
/quote]

Man in a van
Posts: 342
Joined: Sat Dec 27, 2014 2:41 pm
Location: Staffordshire, UK.

Re: dac hifi doesn't sing

Fri Dec 01, 2023 4:32 pm

@nemo87

The output for two channel should be


Name: hifiberry-digi
Info: Configures the HifiBerry Digi and Digi+ audio card
Load: dtoverlay=hifiberry-digi
Params: <None>


Name: hifiberry-digi-pro
Info: Configures the HifiBerry Digi+ Pro and Digi2 Pro audio card
Load: dtoverlay=hifiberry-digi-pro

Params: <None>


Normally, just the one overlay entry is required. I don't know why you have this

# Enable DRM VC4 V3D driver
dtoverlay=hifiberry-digi


ronnie

Return to “Media centres”