User avatar
CaxtonPi
Posts: 84
Joined: Fri May 08, 2020 10:45 am
Location: Cambridgshire, United Kingdom

Pi5: Second monitor blanking after a few seconds

Tue Nov 28, 2023 3:45 pm

Everything set up on my new Pi5 and very impressed with the performance.

Everything has been great for a week or so but unfortunately my second screen blanks after about 10 seconds and needs to be switched off and on again

I can't workout how to change this. I don't seem to be able to find it in Preferences/Appearance Settings or /Screen Configuration.

Thanks!

Abmvk
Posts: 259
Joined: Sat Feb 04, 2023 10:07 pm
Location: Netherlands

Re: Second monitor blanking after a few seconds

Tue Nov 28, 2023 3:48 pm

CaxtonPi wrote:
Tue Nov 28, 2023 3:45 pm
Everything set up on my new Pi5 and very impressed with the performance.

Everything has been great for a week or so but unfortunately my second screen blanks after about 10 seconds and needs to be switched off and on again

I can't workout how to change this. I don't seem to be able to find it in Preferences/Appearance Settings or /Screen Configuration.

Thanks!
I would consider the possibility that this isn’t something you should solve in settings. The Pi5 should be able to use two screens out of the box without a problem. Mine works with two mini-HDMI connected screens for a lot longer than 10 seconds and there was nothing I had to do after plugging in.

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 33193
Joined: Sat Jul 30, 2011 7:41 pm

Re: Second monitor blanking after a few seconds

Tue Nov 28, 2023 5:16 pm

CaxtonPi wrote:
Tue Nov 28, 2023 3:45 pm
Everything set up on my new Pi5 and very impressed with the performance.

Everything has been great for a week or so but unfortunately my second screen blanks after about 10 seconds and needs to be switched off and on again

I can't workout how to change this. I don't seem to be able to find it in Preferences/Appearance Settings or /Screen Configuration.

Thanks!
Do you get the desktop appearing? Or does it blank before then? If you swap the displays does the fault follow the display ?
Principal Software Engineer at Raspberry Pi Ltd.
Working in the Applications Team.
Meet me and the Pi team at Embedded World in Nürnberg, April 9th-11th, 2024
Hall 3A Stand 138
https://events.raspberrypi.com/official/24d5151d-dd0f-483d-88a7-a5fddaa5c554

User avatar
CaxtonPi
Posts: 84
Joined: Fri May 08, 2020 10:45 am
Location: Cambridgshire, United Kingdom

Re: Raspberry Pi 5 discussion thread

Tue Nov 28, 2023 6:37 pm

Yes, the desktop and second screen appear at startup. When I swap screens the fault follows the screen.

User avatar
CaxtonPi
Posts: 84
Joined: Fri May 08, 2020 10:45 am
Location: Cambridgshire, United Kingdom

Re: Raspberry Pi 5 discussion thread

Tue Nov 28, 2023 6:40 pm

Both screens worked when I set the pi up and continued to work for a week. Now one screen blanks 10 seconds after power up.

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 7175
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: Raspberry Pi 5 discussion thread

Tue Nov 28, 2023 7:03 pm

CaxtonPi wrote:
Tue Nov 28, 2023 6:37 pm
Yes, the desktop and second screen appear at startup. When I swap screens the fault follows the screen.
Definitely screen and not hdmi cable?

If you have a spare sdcard then testing if a clean install has the issue would be interesting.
If it doesn't it suggests something installed, updated or configured has caused this.
If it does then it sounds more like a hardware issue (power supply, cable, monitor) - something has got worse.

I might try adding

Code: Select all

vc4.force_hotplug=3
to cmdline.txt (on the existing line).
That would rule out if the display is doing something unexpected with hotplug line that might trigger the blanking.

User avatar
CaxtonPi
Posts: 84
Joined: Fri May 08, 2020 10:45 am
Location: Cambridgshire, United Kingdom

Re: Pi5: Second monitor blanking after a few seconds

Wed Nov 29, 2023 12:05 pm

Solved

Thanks dom.

It was the cable. I am using a Micro HDMI To VGA male to female converter for second monitor which is an old DELL 1280 x 1024 screen.

There was a loose connection.

This is now resolved. Thanks to all contributors for their comments.

Return to “Troubleshooting”