trustno1foxm
Posts: 6
Joined: Sat Dec 02, 2023 12:38 pm

The following packages have been kept back

Sun Dec 03, 2023 10:34 am

Hello, I have a RPI4 with bookworm installed, but some packages are kept back. Is it safe to do a dist-upgrade?
kernel is 6.1.0 so not the latest one.

thx! so long

User avatar
kerry_s
Posts: 7103
Joined: Thu Jan 30, 2020 7:14 pm

Re: The following packages have been kept back

Sun Dec 03, 2023 10:37 am

Code: Select all

sudo apt -y full-upgrade

trustno1foxm
Posts: 6
Joined: Sat Dec 02, 2023 12:38 pm

Re: The following packages have been kept back

Sun Dec 03, 2023 10:41 am

thx! is it normal that the kernel still remains at 6.1.0 while bulleyes kernel is 6.1.21?

User avatar
kerry_s
Posts: 7103
Joined: Thu Jan 30, 2020 7:14 pm

Re: The following packages have been kept back

Sun Dec 03, 2023 10:43 am

did you reboot after upgrade.

trustno1foxm
Posts: 6
Joined: Sat Dec 02, 2023 12:38 pm

Re: The following packages have been kept back

Sun Dec 03, 2023 10:53 am

yes, it's 6.1.0-rpi6-rpi-v8

User avatar
bensimmo
Posts: 6812
Joined: Sun Dec 28, 2014 3:02 pm
Location: East Yorkshire

Re: The following packages have been kept back

Sun Dec 03, 2023 11:06 am

That version 6 of the file, it contains a newer 6.1.##


for example when you log in to the termail, here via SSH
you might get
Linux pi5sdlite 6.1.0-rpi6-rpi-2712 #1 SMP PREEMPT Debian 1:6.1.58-1+rpt2 (2023-10-27) aarch64
and you can see it is 6.1.58 and some rpt tweaks

if you don't see it then you can type
uname -a
at a terminal, among other methods.


EDIT:
They (RPi) changed the naming guideline for bookwork to follow Debians naming method.

trustno1foxm
Posts: 6
Joined: Sat Dec 02, 2023 12:38 pm

Re: The following packages have been kept back

Sun Dec 03, 2023 2:08 pm

thx! that's interesting, so don't trust uname -r and use uname -a :!:

Return to “Troubleshooting”