User avatar
schoolpost
Posts: 246
Joined: Sun Feb 19, 2017 10:47 am
Location: Canada

SDL2 / OpenGL ES 3.1 + EGL | Unknown debug message

Fri Dec 08, 2023 5:17 am

I have been building a camera based application using SDL2 OpenGL ES 3.1 + EGL. ( EGL for libcamera dmabuf functionality )

My application sporadically spits out a debug message in my main loop:

Code: Select all

Failed to submit TFU job: -1
What is likely to be the cause? what might I need to address to suppress it?
-Csaba Nagy

User avatar
PeterO
Posts: 6396
Joined: Sun Jul 22, 2012 4:14 pm

Re: SDL2 / OpenGL ES 3.1 + EGL | Unknown debug message

Fri Dec 08, 2023 9:07 am

All I can offer is that TFU = Texture Formatting Unit.
PeterO
Discoverer of the PI2 XENON DEATH FLASH!
Interests: C,Python,PICO,Electronics,Ham Radio (G0DZB),1960s British Computers.
"The primary requirement (as we've always seen in your examples) is that the code is readable. " Dougie Lawson

User avatar
schoolpost
Posts: 246
Joined: Sun Feb 19, 2017 10:47 am
Location: Canada

Re: SDL2 / OpenGL ES 3.1 + EGL | Unknown debug message

Fri Dec 08, 2023 9:19 am

Here's a capture terminal output during another session:

Code: Select all

Failed to submit TFU job: -1
blit unsupported r16_unorm -> r16_unorm
Failed to submit TFU job: -1
blit unsupported r16_unorm -> r16_unorm
Failed to submit TFU job: -1
blit unsupported r16_unorm -> r16_unorm
Failed to submit TFU job: -1
blit unsupported r16_unorm -> r16_unorm
Failed to submit TFU job: -1
blit unsupported r16_unorm -> r16_unorm
Failed to submit TFU job: -1
blit unsupported r16_unorm -> r16_unorm
Failed to submit TFU job: -1
blit unsupported r16_unorm -> r16_unorm
Failed to submit TFU job: -1
blit unsupported r16_unorm -> r16_unorm
Failed to submit TFU job: -1
blit unsupported r16_unorm -> r16_unorm
Failed to submit TFU job: -1
blit unsupported r16_unorm -> r16_unorm
I've tried googling these, but information around these exact messages is non-existent...
-Csaba Nagy

Return to “OpenGLES”