Marsha
Posts: 15
Joined: Sun Mar 12, 2023 5:25 pm

Re: [DEV] LineageOS 20 (Android 13) for Raspberry Pi 4 & Pi 5

Thu Feb 01, 2024 4:42 am

Hi

Thank you very much for your work

I installed "LineageOS 20 Android TV (Android 13) for Raspberry Pi 5"

How-To install F-Droid and Jellyfin app? There seems no browser available

Thank you

Snaplash
Posts: 1
Joined: Thu Feb 01, 2024 3:23 pm

Re: [DEV] LineageOS 20 (Android 13) for Raspberry Pi 4 & Pi 5

Thu Feb 01, 2024 3:26 pm

@Konsta. Could you point me to a build that I can use the Sixfab Hat on please? "I have builds (of older Android versions) that have support for Sixfab modem HAT and Quectel EC25."

Thanks in advance and keep up the great work!

Digivix
Posts: 8
Joined: Sat Jan 27, 2024 5:05 am

Re: [DEV] LineageOS 20 (Android 13) for Raspberry Pi 4 & Pi 5

Thu Feb 01, 2024 11:02 pm

Hello,

I've read through all the posts but haven't figured out how to resolve my issue. I'm using Android TV on RPI 5 running LineageOS20. I have a new HDMI cable and have tried others. The audio wasn't working initially. I don't have many options but tried changing RPI settings to use both 0 and 1. Using 0 and flipping through the menu the audio started working (I have system sounds on). I was able to watch a few shows through google tv and kodi but then I rebooted and now the audio isn't working again.

Is there an audio option to toggle the audio on/off in the AndroidTV app view? I can use a remote to change the volume but was looking for a way to select the output source. I am thinking I should have access to see both my SamsungTV and/or the soundbar. I've tried plugging in the rip to both and neither output sound. Bluetooth audio works consistently.

I attempted to add a HDMI setting to the config_user.txt but have been unable to get around the read only permission. I remounted as root and pulled it down but when trying to push back the change it fails.

I'm at a loss as to what to do, try and why it worked but stopped. Any guidance is appreciated! Thank you.

werimail
Posts: 17
Joined: Sat Mar 11, 2023 7:54 pm

Re: [DEV] LineageOS 20 (Android 13) for Raspberry Pi 4 & Pi 5

Mon Feb 05, 2024 10:54 am

Hi @Konsta, with the current builds for the Rpi4 from 20230814 and 20240111 I can generally no longer connect a Bluetooth speaker. With the build from 20230505 everything still works without any problems. Is this already known? Therefore I created a logcat (see attachment).

Greetings Weri
Attachments
lineage_bluetooth.txt.7z
(164.5 KiB) Downloaded 3 times

Digivix
Posts: 8
Joined: Sat Jan 27, 2024 5:05 am

Re: [DEV] LineageOS 20 (Android 13) for Raspberry Pi 4 & Pi 5

Wed Feb 07, 2024 8:01 pm

I was able to sideload apps using adb.
You need to turn on developer settings and allow over network adb to accomplish that. Hth took me a minute to figure out how to work through this.
Marsha wrote:
Thu Feb 01, 2024 4:42 am
Hi

Thank you very much for your work

I installed "LineageOS 20 Android TV (Android 13) for Raspberry Pi 5"

How-To install F-Droid and Jellyfin app? There seems no browser available

Thank you

dkranendonk
Posts: 1
Joined: Mon Feb 05, 2024 7:22 am

Re: [DEV] LineageOS 20 (Android 13) for Raspberry Pi 4 & Pi 5

Sun Feb 11, 2024 3:46 pm

Digivix wrote:
Thu Feb 01, 2024 11:02 pm
Hello,

I've read through all the posts but haven't figured out how to resolve my issue. I'm using Android TV on RPI 5 running LineageOS20. I have a new HDMI cable and have tried others. The audio wasn't working initially. I don't have many options but tried changing RPI settings to use both 0 and 1. Using 0 and flipping through the menu the audio started working (I have system sounds on). I was able to watch a few shows through google tv and kodi but then I rebooted and now the audio isn't working again.

Is there an audio option to toggle the audio on/off in the AndroidTV app view? I can use a remote to change the volume but was looking for a way to select the output source. I am thinking I should have access to see both my SamsungTV and/or the soundbar. I've tried plugging in the rip to both and neither output sound. Bluetooth audio works consistently.

I attempted to add a HDMI setting to the config_user.txt but have been unable to get around the read only permission. I remounted as root and pulled it down but when trying to push back the change it fails.

I'm at a loss as to what to do, try and why it worked but stopped. Any guidance is appreciated! Thank you.
I'm new to Android but have been a long time Linux and Pi user. I've been trying to understand how the HDMI audio system works on my bench setup at home. I've been using it to build a better infotainment environment for my RV.

I have a similar HDMI audio problem but might not be the same issue. I've been struggling with getting HDMI Audio working for Media playback over the Monitor speakers. I have both a Samsung 27" M5 (Smart Monitor) on my work bench and a 15" Touch Display with built in speakers.

I am able to get sound out of the display speakers from the Settings -> Sound & Vibration -> Alarm Volume. When I click on the slider the audio is coming from the Monitor Speakers. I seem to have the same behavior whan I switch to the 3.5mm Audio under the Raspberry Pi Settings. Only the Alarm Tones come from the 3.5mm jack to the speaker any music or alerts do not. Only the Alarm Tones.

When I use a bluetooth speaker as the output device the media play back and the Alarm tones work on the bluetooth speaker.

Is there a way to change the mapping of the Media Output so that I can get sound out of the display speakers? HDMI0 Audio path is working for the Alarm Volume. How can I get the Media path to do the same?

I've tried using several different versions of the Konstakang LineageOS. 20... I thought that I had this working on an older Android 11 version. But though I've wiped out the images and replaced them with clean installations. I seem to be experiencing the same issues now on new and old versions. I have 3 different Pi4 boards connected to 2 different displays and they seem to all have the same behavior.

I have confirmed that Ubuntu 22 and Rasberry PI Bookwork OS versions do work for HDMI Audio on these displays along with Touch on the 15" Display.

Thank you,

Digivix
Posts: 8
Joined: Sat Jan 27, 2024 5:05 am

Re: [DEV] LineageOS 20 (Android 13) for Raspberry Pi 4 & Pi 5

Wed Feb 14, 2024 10:49 pm

Not sure if this should be posted elsewhere but I'm running LineageOS 20 AndroidTV on Pi5. I have Kodi installed and am seeing issues where some shows play all the way through while others stop working, boot me to the main screen. I have to launch Kodi again and sometimes it will play without error other times it will continue.

Kodi version is v 20.4

In the logs I see an error referencing and egl attribute error - egl bad config. Kodi system info says it's using OpenGL Mesa 23.3.3.

I don't know what to try to resolve this but I purchased this Pi5 just for the purpose of running Kodi on my living tv.

Any help/suggestions/ideas is appreciated! :idea:

WODAK
Posts: 74
Joined: Thu Jan 23, 2020 1:53 pm

Re: [DEV] LineageOS 20 (Android 13) for Raspberry Pi 4 & Pi 5

Thu Feb 15, 2024 10:49 am

Digivix wrote:
Wed Feb 14, 2024 10:49 pm
Not sure if this should be posted elsewhere but I'm running LineageOS 20 AndroidTV on Pi5. I have Kodi installed and am seeing issues where some shows play all the way through while others stop working, boot me to the main screen. I have to launch Kodi again and sometimes it will play without error other times it will continue.

Kodi version is v 20.4

In the logs I see an error referencing and egl attribute error - egl bad config. Kodi system info says it's using OpenGL Mesa 23.3.3.

I don't know what to try to resolve this but I purchased this Pi5 just for the purpose of running Kodi on my living tv.

Any help/suggestions/ideas is appreciated! :idea:
Maybe you shoud try PINN and install LibreElec and LineAge as two separate sistems.

Digivix
Posts: 8
Joined: Sat Jan 27, 2024 5:05 am

Re: [DEV] LineageOS 20 (Android 13) for Raspberry Pi 4 & Pi 5

Thu Feb 15, 2024 1:38 pm

WODAK wrote:
Thu Feb 15, 2024 10:49 am
Digivix wrote:
Wed Feb 14, 2024 10:49 pm
Not sure if this should be posted elsewhere but I'm running LineageOS 20 AndroidTV on Pi5. I have Kodi installed and am seeing issues where some shows play all the way through while others stop working, boot me to the main screen. I have to launch Kodi again and sometimes it will play without error other times it will continue.

Kodi version is v 20.4

In the logs I see an error referencing and egl attribute error - egl bad config. Kodi system info says it's using OpenGL Mesa 23.3.3.

I don't know what to try to resolve this but I purchased this Pi5 just for the purpose of running Kodi on my living tv.

Any help/suggestions/ideas is appreciated! :idea:
Maybe you shoud try PINN and install LibreElec and LineAge as two separate sistems.
Thanks didn't know this what an option. Why do you think it will be resolved doing it this way? I'm trying to learn and understand what is happening.

WODAK
Posts: 74
Joined: Thu Jan 23, 2020 1:53 pm

Re: [DEV] LineageOS 20 (Android 13) for Raspberry Pi 4 & Pi 5

Thu Feb 15, 2024 2:00 pm

Digivix wrote:
Thu Feb 15, 2024 1:38 pm
Thanks didn't know this what an option. Why do you think it will be resolved doing it this way? I'm trying to learn and understand what is happening.
It is a dedicated system for a media center. You have a lot of links on google and even raspberry Pi forum to see what is it all about.
Maybe you shoud get an old sd cars or maybe buy a new one (the are really cheap today), install Libreelec and check if it suits you...

some links:
viewtopic.php?t=340431
https://libreelec.tv/

Digivix
Posts: 8
Joined: Sat Jan 27, 2024 5:05 am

Re: [DEV] LineageOS 20 (Android 13) for Raspberry Pi 4 & Pi 5

Thu Feb 15, 2024 10:42 pm

WODAK wrote:
Thu Feb 15, 2024 2:00 pm
Digivix wrote:
Thu Feb 15, 2024 1:38 pm
Thanks didn't know this what an option. Why do you think it will be resolved doing it this way? I'm trying to learn and understand what is happening.
It is a dedicated system for a media center. You have a lot of links on google and even raspberry Pi forum to see what is it all about.
Maybe you shoud get an old sd cars or maybe buy a new one (the are really cheap today), install Libreelec and check if it suits you...

some links:
viewtopic.php?t=340431
https://libreelec.tv/
Thanks I did some research and I don't really want to have to boot to a separate os depending on whether I want to watch Androidtv or Kodi. Do you know what the issue that I'm experiencing is? Is it specific to Kodi/Pi5 or Lineage/Pi5 or Lineage/Kodi? I appreciate the help!

Return to “Android”