akhs
Posts: 2
Joined: Wed Feb 21, 2024 6:27 pm

SenseHAT not working with Scratch 3

Wed Feb 21, 2024 8:48 pm

I have a Raspberry Pi 400 and recently got a SenseHAT and an Adafruit cyberdeck to connect everything together.
I'm running Raspberry Pi OS (64-bit) Debian 12

The HAT works with no issue when using the python library, but the Scratch 3 extension doesn't work at all.

I tried running it with

Code: Select all

scratch-desktop --enable-logging
Whenever it tries to run SenseHAT steps, it logs this error:

Code: Select all

[1962:0221/124340.489812:INFO:CONSOLE(654)] "Uncaught ReferenceError: pel is not defined", source: webpack-internal:///./node_modules/scratch-vm/src/extensions/scratch3_pisensehat/index.js (654)

I can't find the source code for the extension, so it's very difficult to debug. Has anyone else encountered this issue? Any pointers on working configurations?

akhs
Posts: 2
Joined: Wed Feb 21, 2024 6:27 pm

Re: SenseHAT not working with Scratch 3

Thu Feb 22, 2024 7:47 am

Using an older OS worked.

Rueful-Pi
Posts: 9
Joined: Sat Feb 24, 2024 6:41 pm

Re: SenseHAT not working with Scratch 3

Sun Feb 25, 2024 9:27 pm

I have been having the same issue with Sense HAT V2 on Pi 5 running 64-bit Bookworm. I have not found a solution yet. Although I am following this Github thread in hopes that a solution will be found there. Perhaps you might want to check it out.

https://github.com/raspberrypi/bookworm ... issues/148

afred
Posts: 22
Joined: Tue Jan 12, 2021 6:40 am

Re: SenseHAT not working with Scratch 3

Fri Mar 01, 2024 7:04 pm

Thanks Rueful,

March 1, Scratch 3.30.8

I too have bookworm 64 RPI5 with the Sense Hat not working.

I will keep looking for an update at your link; does anyone know if that is the best place? I assume the sense hat code in scratch is different from General Bookworm problems.

Back in the day it seemed that the forum was the best place and Pi developers would actually call for feedback (like for Bullseye and buster). How bleeding edge is bookworm?

Thanks again,

Return to “Astro Pi”