dericklfl
Posts: 3
Joined: Fri Mar 01, 2024 1:54 am

Compute Module Boot Problems

Fri Mar 01, 2024 2:07 am

Hello,

I've recently made a basic CM4 board made that exposes some of the serial lines.

Upon recieving the boards, I am unable to get the CM4 to boot. The current draw is stable, at only 40mA at 5V, and I've probed the pins on the Hirose connectors to ensure that the CM4 is getting 5V.

Are there any additional circuits or pins that need to be driven in order to get the CM4 to boot? It boots fine on the IO board. I've also tried the eMMC CM4 instead of the lite, with no success.

I've attached an image of the schematic below.

Any comments or suggestions are appreciated. Thanks!

Image

dp11
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 1292
Joined: Thu Dec 29, 2011 5:46 pm

Re: Compute Module Boot Problems

Fri Mar 01, 2024 6:27 am

Have you checked the troubleshooting section of the CM4 datasheet?. Could you post your full design ? Schematics and layout. Does your layout have any ERCs?

dericklfl
Posts: 3
Joined: Fri Mar 01, 2024 1:54 am

Re: Compute Module Boot Problems

Fri Mar 01, 2024 6:25 pm

dp11 wrote:
Fri Mar 01, 2024 6:27 am
Have you checked the troubleshooting section of the CM4 datasheet?. Could you post your full design ? Schematics and layout. Does your layout have any ERCs?
Looking at the troubleshooting section now. I've attached the full schematic and layout in the link below.

https://drive.google.com/file/d/1swCGQ1 ... sp=sharing

dp11
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 1292
Joined: Thu Dec 29, 2011 5:46 pm

Re: Compute Module Boot Problems

Fri Mar 01, 2024 6:42 pm

It doesn't look like any of the GND pins of the compute module are connected.

dericklfl
Posts: 3
Joined: Fri Mar 01, 2024 1:54 am

Re: Compute Module Boot Problems

Fri Mar 01, 2024 8:58 pm

dp11 wrote:
Fri Mar 01, 2024 6:42 pm
It doesn't look like any of the GND pins of the compute module are connected.
That would do it... thank you for the help!

Return to “Compute Module”